~chromium-team/chromium-browser/beta

« back to all changes in this revision

Viewing changes to debian/patches/linker-asneeded-bug.patch

  • Committer: Chad Miller
  • Date: 2013-08-27 16:58:09 UTC
  • mfrom: (915.1.13 saucy-working)
  • Revision ID: chad.miller@canonical.com-20130827165809-up7594cwptx3v6mz
* New release 29.0.1547.57:  (LP: #1215361)
  - CVE-2013-2900: Incomplete path sanitization in file handling.
  - CVE-2013-2905: Information leak via overly broad permissions on shared
    memory files.
  - CVE-2013-2901: Integer overflow in ANGLE.
  - CVE-2013-2902: Use after free in XSLT.
  - CVE-2013-2903: Use after free in media element.
  - CVE-2013-2904: Use after free in document parsing.
  - CVE-2013-2887: Various fixes from internal audits, fuzzing and other
    initiatives (Chrome 29).
* debian/rules: Fix packaging-sanity test.
* debian/patches/search-credit.patch:  Update URLs.
* debian/patches/disable_dlog_and_dcheck_in_release_builds.patch,
  debian/patches/wehkit_rev_parser.patch,
    No longer necessary.  Deleted.
* debian/chromium-browser.sh.in: Include command-line parameters for
  registered plugins.
* Since we include remoting locales too, also split its locales info 
  into the -l10n package correctly.
* debian/rules: Disable arm_neon_optional. Impossible with sandbox, AND
  breaks build right now.
* debian/rules:
  - Make unused-file matches simpler, and install rule more descriptive.
  - get-orig-source has to make the directory for the orig contents. 
* debian/source/lintian-overrides:
  - Add old-fsf-address-in-copyright-file and image-file-in-usr-lib
  - Fix setuid-binary to be "source". Seems like it should be "binary". :(
* debian/checkout-orig-source.mk: Remove tests and add unofficialness
  marker file to orig tarball when we can't use upstream orig releases.
* debian/control: Set VCS URL to be accurate.
* debian/rules: Start rule to create patch that includes Launchpad
  translations.  Never change upstream orig tarball.  This will be a 
  release-time manual rule that updates a quilt patch.
* New release 28.0.1500.95:
  - CVE-2013-2881: Origin bypass in frame handling.
  - CVE-2013-2882: Type confusion in V8.
  - CVE-2013-2883: Use-after-free in MutationObserver.
  - CVE-2013-2884: Use-after-free in DOM.
  - CVE-2013-2885: Use-after-free in input handling.
  - CVE-2013-2886: Various fixes from internal audits, fuzzing and other
    initiatives.
* debian/rules:
  - Keepalive in tests rule, to keep builder machines from reaping.
  - Further exclude a few tests that interact with fakeroot,
    ReadOnlyFileUtilTest.
* debian/rules:
  - Disable logging calls in chromium binary to save several MB of executable
    size.
* debian/patches/linker-asneeded-bug.patch:
  - Add patch to work around linker bug.
* debian/keep-alive.sh:
  - Treat disappearing /proc as error, and quit. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Avoid a linker bug where symbols are not found.
 
2
 > /usr/bin/ld.bfd.real: out/Release/obj.target/net/libnet.so: undefined reference to symbol 'SSL_ForceHandshake'
 
3
 > out/Release/obj.target/net/third_party/nss/libcrssl.so: error adding symbols: DSO missing from command line
 
4
 
 
5
--- a/src/build/common.gypi
 
6
+++ b/src/build/common.gypi
 
7
@@ -2770,7 +2770,7 @@
 
8
                   '-Wl,--as-needed',
 
9
                 ],
 
10
               }],
 
11
-              ['OS=="linux" and target_arch=="ia32"', {
 
12
+              ['OS=="linux"', {
 
13
                 'ldflags': [
 
14
                   '-Wl,--no-as-needed',
 
15
                 ],
 
16
@@ -2806,7 +2806,6 @@
 
17
               # Specifically tell the linker to perform optimizations.
 
18
               # See http://lwn.net/Articles/192624/ .
 
19
               '-Wl,-O1',
 
20
-              '-Wl,--as-needed',
 
21
             ],
 
22
             'conditions' : [
 
23
               ['no_gc_sections==0', {
 
24
@@ -2849,6 +2848,11 @@
 
25
                   '-fno-asynchronous-unwind-tables',
 
26
                 ],
 
27
               }],
 
28
+              ['OS=="linux"', {
 
29
+                'ldflags': [
 
30
+                  '-Wl,--no-as-needed',
 
31
+                ],
 
32
+              }],
 
33
             ],
 
34
           },
 
35
         },