~focus-follows-mouse/ubuntu/precise/compiz/fix-883383

« back to all changes in this revision

Viewing changes to debian/patches/01_unity_window_decorator.patch

  • Committer: Bazaar Package Importer
  • Author(s): Didier Roche
  • Date: 2011-03-22 21:45:34 UTC
  • mfrom: (0.168.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20110322214534-l6i6ds54os5uoqt1
Tags: 1:0.9.4git20110322-0ubuntu1
* New upstream bug fix snapshot:
  - Application windows can sometimes fail to display and will
    mask regions of the screen (LP: #709461)
  - Compiz switcher Alt-Tab order is not predictable - should
    maintain LIFO ordering in application switcher (LP: #175874)
  - after compiz crashed, gnome-panel isn't mapped again (LP: #711378)
  - invisible windows border problem (LP: #710271)
  - Compiz thinks you are clicking in an edge window when you
    are not (LP: #734250)
  - Add test case for invisible window regressions (LP: #736876)
  - often can't alt-click-dnd to move the focussed dialog (LP: #711911)
  - When windows open for the first time they should not hide (LP: #723878)
  - Unity Grid is broken for multi-monitor setups (LP: #709221)
  - Pixmaps trashed during animations when window is unmapped (LP: #733331)
  - Windows have blank decorations when rapidly closing and
    reopening (LP: #733328)
  - Unity is not restored on unity/compiz crash: compiz doesn't register
    properly with gnome-session (LP: #716462)
* remove the patch taken from upstream
* refresh u-w-d patch with latest upstream work
* debian/compiz-core.install:
  - image move to the final destination
* debian/patches/100_bump_core.h.patch:
  - bump for ABI breakage
* debian/compiz-decorator:
  - use gtk-window-decorator and not unity-window-decorator as it's really
    crashy for now (will probably redo an upload tomorrow with a fixed
    decorator)

Show diffs side-by-side

added added

removed removed

Lines of Context:
64
64
 
65
65
Index: compiz-0.9.4/CMakeLists.txt
66
66
===================================================================
67
 
--- compiz-0.9.4.orig/CMakeLists.txt    2011-02-24 10:27:13.000000000 +0100
68
 
+++ compiz-0.9.4/CMakeLists.txt 2011-02-28 18:49:25.950382137 +0100
 
67
--- compiz-0.9.4.orig/CMakeLists.txt    2011-03-22 16:46:56.000000000 +0800
 
68
+++ compiz-0.9.4/CMakeLists.txt 2011-03-23 00:11:18.206188671 +0800
69
69
@@ -112,6 +112,7 @@
70
70
 add_subdirectory (libdecoration)
71
71
 add_subdirectory (gtk)
77
77
Index: compiz-0.9.4/unity/unity_window_decorator/.gitignore
78
78
===================================================================
79
79
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
80
 
+++ compiz-0.9.4/unity/unity_window_decorator/.gitignore        2011-02-28 18:49:25.966382221 +0100
 
80
+++ compiz-0.9.4/unity/unity_window_decorator/.gitignore        2011-03-23 00:11:18.206188671 +0800
81
81
@@ -0,0 +1 @@
82
82
+po/compiz.pot
83
83
Index: compiz-0.9.4/unity/unity_window_decorator/AUTHORS
84
84
===================================================================
85
85
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
86
 
+++ compiz-0.9.4/unity/unity_window_decorator/AUTHORS   2011-02-28 18:49:25.966382221 +0100
 
86
+++ compiz-0.9.4/unity/unity_window_decorator/AUTHORS   2011-03-23 00:11:18.216188681 +0800
87
87
@@ -0,0 +1,29 @@
88
88
+compiz and the standard set of plugins are designed and written by
89
89
+
117
117
Index: compiz-0.9.4/unity/unity_window_decorator/CMakeLists.txt
118
118
===================================================================
119
119
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
120
 
+++ compiz-0.9.4/unity/unity_window_decorator/CMakeLists.txt    2011-02-28 18:49:25.970382236 +0100
 
120
+++ compiz-0.9.4/unity/unity_window_decorator/CMakeLists.txt    2011-03-23 00:11:18.216188681 +0800
121
121
@@ -0,0 +1,38 @@
122
122
+project (unity-window-decorator)
123
123
+
160
160
Index: compiz-0.9.4/unity/unity_window_decorator/COPYING
161
161
===================================================================
162
162
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
163
 
+++ compiz-0.9.4/unity/unity_window_decorator/COPYING   2011-02-28 18:49:25.970382236 +0100
 
163
+++ compiz-0.9.4/unity/unity_window_decorator/COPYING   2011-03-23 00:11:18.216188681 +0800
164
164
@@ -0,0 +1,6 @@
165
165
+Most of the code is MIT licensed, some code is instead licensed
166
166
+under the LGPL and some under the GPL. Each source code file
171
171
Index: compiz-0.9.4/unity/unity_window_decorator/COPYING.GPL
172
172
===================================================================
173
173
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
174
 
+++ compiz-0.9.4/unity/unity_window_decorator/COPYING.GPL       2011-02-28 18:49:25.970382236 +0100
 
174
+++ compiz-0.9.4/unity/unity_window_decorator/COPYING.GPL       2011-03-23 00:11:18.226188695 +0800
175
175
@@ -0,0 +1,340 @@
176
176
+                   GNU GENERAL PUBLIC LICENSE
177
177
+                      Version 2, June 1991
516
516
Index: compiz-0.9.4/unity/unity_window_decorator/INSTALL
517
517
===================================================================
518
518
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
519
 
+++ compiz-0.9.4/unity/unity_window_decorator/INSTALL   2011-02-28 18:49:25.970382236 +0100
 
519
+++ compiz-0.9.4/unity/unity_window_decorator/INSTALL   2011-03-23 00:11:18.226188695 +0800
520
520
@@ -0,0 +1,14 @@
521
521
+compiz uses libstartup-notification which is available at
522
522
+ftp://ftp.gnome.org/pub/GNOME/sources/startup-notification/
535
535
Index: compiz-0.9.4/unity/unity_window_decorator/README
536
536
===================================================================
537
537
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
538
 
+++ compiz-0.9.4/unity/unity_window_decorator/README    2011-02-28 18:49:25.970382236 +0100
 
538
+++ compiz-0.9.4/unity/unity_window_decorator/README    2011-03-23 00:11:18.226188695 +0800
539
539
@@ -0,0 +1,8 @@
540
540
+compiz - OpenGL window and compositing manager
541
541
+
548
548
Index: compiz-0.9.4/unity/unity_window_decorator/src/CMakeLists.txt
549
549
===================================================================
550
550
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
551
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/CMakeLists.txt        2011-02-28 18:49:25.974382255 +0100
 
551
+++ compiz-0.9.4/unity/unity_window_decorator/src/CMakeLists.txt        2011-03-23 00:11:18.226188695 +0800
552
552
@@ -0,0 +1,161 @@
553
553
+function (compiz_install_gconf_schema _src _dst)
554
554
+    pkg_check_modules (GCONF gconf-2.0)
714
714
Index: compiz-0.9.4/unity/unity_window_decorator/src/TODO
715
715
===================================================================
716
716
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
717
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/TODO  2011-02-28 18:49:25.974382255 +0100
 
717
+++ compiz-0.9.4/unity/unity_window_decorator/src/TODO  2011-03-23 00:11:18.226188695 +0800
718
718
@@ -0,0 +1,6 @@
719
719
+
720
720
+* Plugin interface
726
726
Index: compiz-0.9.4/unity/unity_window_decorator/src/actionmenu.c
727
727
===================================================================
728
728
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
729
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/actionmenu.c  2011-02-28 18:49:25.974382255 +0100
 
729
+++ compiz-0.9.4/unity/unity_window_decorator/src/actionmenu.c  2011-03-23 00:12:32.000000000 +0800
730
730
@@ -0,0 +1,109 @@
731
731
+#include "gtk-window-decorator.h"
732
732
+
840
840
Index: compiz-0.9.4/unity/unity_window_decorator/src/blurprops.c
841
841
===================================================================
842
842
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
843
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/blurprops.c   2011-02-28 18:49:25.974382255 +0100
 
843
+++ compiz-0.9.4/unity/unity_window_decorator/src/blurprops.c   2011-03-23 00:12:32.000000000 +0800
844
844
@@ -0,0 +1,68 @@
845
845
+#include "gtk-window-decorator.h"
846
846
+
914
914
Index: compiz-0.9.4/unity/unity_window_decorator/src/cairo.c
915
915
===================================================================
916
916
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
917
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/cairo.c       2011-02-28 18:49:25.974382255 +0100
 
917
+++ compiz-0.9.4/unity/unity_window_decorator/src/cairo.c       2011-03-23 00:12:32.000000000 +0800
918
918
@@ -0,0 +1,1001 @@
919
919
+#include "gtk-window-decorator.h"
920
920
+
1920
1920
Index: compiz-0.9.4/unity/unity_window_decorator/src/config.h.gtk.in
1921
1921
===================================================================
1922
1922
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
1923
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/config.h.gtk.in       2011-02-28 18:49:25.974382255 +0100
 
1923
+++ compiz-0.9.4/unity/unity_window_decorator/src/config.h.gtk.in       2011-03-23 00:12:32.000000000 +0800
1924
1924
@@ -0,0 +1,25 @@
1925
1925
+/* Define to 1 if Metacity support is enabled */
1926
1926
+#cmakedefine USE_METACITY 1
1950
1950
Index: compiz-0.9.4/unity/unity_window_decorator/src/decorator.c
1951
1951
===================================================================
1952
1952
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
1953
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/decorator.c   2011-02-28 18:49:25.978382277 +0100
 
1953
+++ compiz-0.9.4/unity/unity_window_decorator/src/decorator.c   2011-03-23 00:12:32.000000000 +0800
1954
1954
@@ -0,0 +1,870 @@
1955
1955
+#include "gtk-window-decorator.h"
1956
1956
+
2825
2825
Index: compiz-0.9.4/unity/unity_window_decorator/src/decorprops.c
2826
2826
===================================================================
2827
2827
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
2828
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/decorprops.c  2011-02-28 18:49:25.978382277 +0100
 
2828
+++ compiz-0.9.4/unity/unity_window_decorator/src/decorprops.c  2011-03-23 00:12:32.000000000 +0800
2829
2829
@@ -0,0 +1,135 @@
2830
2830
+#include "gtk-window-decorator.h"
2831
2831
+
2965
2965
Index: compiz-0.9.4/unity/unity_window_decorator/src/events.c
2966
2966
===================================================================
2967
2967
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
2968
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/events.c      2011-02-28 18:49:25.978382277 +0100
 
2968
+++ compiz-0.9.4/unity/unity_window_decorator/src/events.c      2011-03-23 00:12:32.000000000 +0800
2969
2969
@@ -0,0 +1,1173 @@
2970
2970
+#include "gtk-window-decorator.h"
2971
2971
+
4143
4143
Index: compiz-0.9.4/unity/unity_window_decorator/src/forcequit.c
4144
4144
===================================================================
4145
4145
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
4146
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/forcequit.c   2011-02-28 18:49:25.982382303 +0100
 
4146
+++ compiz-0.9.4/unity/unity_window_decorator/src/forcequit.c   2011-03-23 00:12:32.000000000 +0800
4147
4147
@@ -0,0 +1,176 @@
4148
4148
+#include "gtk-window-decorator.h"
4149
4149
+
4324
4324
Index: compiz-0.9.4/unity/unity_window_decorator/src/gdk.c
4325
4325
===================================================================
4326
4326
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
4327
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/gdk.c 2011-02-28 18:49:25.982382303 +0100
 
4327
+++ compiz-0.9.4/unity/unity_window_decorator/src/gdk.c 2011-03-23 00:12:32.000000000 +0800
4328
4328
@@ -0,0 +1,87 @@
4329
4329
+#include "gtk-window-decorator.h"
4330
4330
+
4417
4417
Index: compiz-0.9.4/unity/unity_window_decorator/src/gtk-window-decorator.c
4418
4418
===================================================================
4419
4419
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
4420
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/gtk-window-decorator.c        2011-02-28 18:49:25.982382303 +0100
 
4420
+++ compiz-0.9.4/unity/unity_window_decorator/src/gtk-window-decorator.c        2011-03-23 00:12:32.000000000 +0800
4421
4421
@@ -0,0 +1,443 @@
4422
4422
+/*
4423
4423
+ * Copyright © 2006 Novell, Inc.
4865
4865
Index: compiz-0.9.4/unity/unity_window_decorator/src/gtk-window-decorator.h
4866
4866
===================================================================
4867
4867
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
4868
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/gtk-window-decorator.h        2011-02-28 18:49:25.982382303 +0100
 
4868
+++ compiz-0.9.4/unity/unity_window_decorator/src/gtk-window-decorator.h        2011-03-23 00:12:32.000000000 +0800
4869
4869
@@ -0,0 +1,980 @@
4870
4870
+#ifndef _GTK_WINDOW_DECORATOR_H
4871
4871
+#define _GTK_WINDOW_DECORATOR_H
5850
5850
Index: compiz-0.9.4/unity/unity_window_decorator/src/gwd.schemas.in
5851
5851
===================================================================
5852
5852
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
5853
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/gwd.schemas.in        2011-02-28 18:49:25.986382316 +0100
 
5853
+++ compiz-0.9.4/unity/unity_window_decorator/src/gwd.schemas.in        2011-03-23 00:11:18.246188725 +0800
5854
5854
@@ -0,0 +1,81 @@
5855
5855
+<gconfschemafile>
5856
5856
+    <schemalist>
5936
5936
Index: compiz-0.9.4/unity/unity_window_decorator/src/metacity.c
5937
5937
===================================================================
5938
5938
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
5939
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/metacity.c    2011-02-28 19:15:06.854023065 +0100
5940
 
@@ -0,0 +1,1924 @@
 
5939
+++ compiz-0.9.4/unity/unity_window_decorator/src/metacity.c    2011-03-23 00:12:32.000000000 +0800
 
5940
@@ -0,0 +1,1923 @@
5941
5941
+#include "gtk-window-decorator.h"
5942
5942
+
5943
5943
+#ifdef USE_METACITY
6424
6424
+
6425
6425
+    if (d->active)
6426
6426
+       *flags |= (MetaFrameFlags ) META_FRAME_HAS_FOCUS;
6427
 
+    else if (d->transient_windows &&
6428
 
+            g_slist_length (d->transient_windows) > 1)
 
6427
+    else if (g_slist_length (d->transient_windows) > 1)
6429
6428
+    {
6430
6429
+       GSList  *transient_windows = d->transient_windows;
6431
6430
+
7865
7864
Index: compiz-0.9.4/unity/unity_window_decorator/src/settings.c
7866
7865
===================================================================
7867
7866
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
7868
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/settings.c    2011-02-28 18:49:25.990382333 +0100
 
7867
+++ compiz-0.9.4/unity/unity_window_decorator/src/settings.c    2011-03-23 00:12:32.000000000 +0800
7869
7868
@@ -0,0 +1,564 @@
7870
7869
+#include "gtk-window-decorator.h"
7871
7870
+
8434
8433
Index: compiz-0.9.4/unity/unity_window_decorator/src/style.c
8435
8434
===================================================================
8436
8435
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
8437
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/style.c       2011-02-28 18:49:25.990382333 +0100
 
8436
+++ compiz-0.9.4/unity/unity_window_decorator/src/style.c       2011-03-23 00:12:32.000000000 +0800
8438
8437
@@ -0,0 +1,42 @@
8439
8438
+#include "gtk-window-decorator.h"
8440
8439
+
8481
8480
Index: compiz-0.9.4/unity/unity_window_decorator/src/switcher.c
8482
8481
===================================================================
8483
8482
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
8484
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/switcher.c    2011-02-28 18:49:25.990382333 +0100
 
8483
+++ compiz-0.9.4/unity/unity_window_decorator/src/switcher.c    2011-03-23 00:12:32.000000000 +0800
8485
8484
@@ -0,0 +1,455 @@
8486
8485
+#include "gtk-window-decorator.h"
8487
8486
+
8941
8940
Index: compiz-0.9.4/unity/unity_window_decorator/src/util.c
8942
8941
===================================================================
8943
8942
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
8944
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/util.c        2011-02-28 18:49:25.990382333 +0100
 
8943
+++ compiz-0.9.4/unity/unity_window_decorator/src/util.c        2011-03-23 00:12:32.000000000 +0800
8945
8944
@@ -0,0 +1,278 @@
8946
8945
+#include "gtk-window-decorator.h"
8947
8946
+
9224
9223
Index: compiz-0.9.4/unity/unity_window_decorator/src/wnck.c
9225
9224
===================================================================
9226
9225
--- /dev/null   1970-01-01 00:00:00.000000000 +0000
9227
 
+++ compiz-0.9.4/unity/unity_window_decorator/src/wnck.c        2011-02-28 19:15:06.866023123 +0100
9228
 
@@ -0,0 +1,758 @@
 
9226
+++ compiz-0.9.4/unity/unity_window_decorator/src/wnck.c        2011-03-23 00:16:27.000000000 +0800
 
9227
@@ -0,0 +1,774 @@
9229
9228
+#include "gtk-window-decorator.h"
9230
9229
+
9231
9230
+static void
9899
9898
+    d->cr = NULL;
9900
9899
+    d->buffer_pixmap = NULL;
9901
9900
+    d->picture = None;
9902
 
+    d->transient_windows = NULL;
 
9901
+    d->transient_windows = g_slist_alloc ();
9903
9902
+
9904
9903
+    connect_window (win);
9905
9904
+
9941
9940
+{
9942
9941
+    Display *xdisplay = GDK_DISPLAY_XDISPLAY (gdk_display_get_default ());
9943
9942
+    decor_t *d = g_object_get_data (G_OBJECT (win), "decor");
9944
 
+    WnckWindow *parent = d->transient_parent;
9945
 
+
9946
 
+    if (parent)
9947
 
+    {
9948
 
+       decor_t *d_parent = g_object_get_data (G_OBJECT (parent), "decor");
9949
 
+
9950
 
+       d_parent->transient_windows = g_slist_remove (d_parent->transient_windows, win);
 
9943
 
9944
+    if (d->transient_windows)
 
9945
+    {
 
9946
+       GSList *iter = d->transient_windows;
 
9947
+
 
9948
+       while (iter)
 
9949
+       {
 
9950
+           WnckWindow *win = (WnckWindow *) iter->data;
 
9951
+           decor_t    *d = g_object_get_data (G_OBJECT (win), "decor");
 
9952
+
 
9953
+           d->transient_parent = NULL;
 
9954
+
 
9955
+           iter = g_slist_next (iter);
 
9956
+       }
 
9957
+
 
9958
+       g_slist_free (d->transient_windows);
 
9959
+    }
 
9960
+
 
9961
+    if (d->transient_parent)
 
9962
+    {
 
9963
+       decor_t *d_parent = g_object_get_data (G_OBJECT (d->transient_parent), "decor");
 
9964
+
 
9965
+       d_parent->transient_windows = g_slist_remove (d_parent->transient_windows, win);
9951
9966
+    }
9952
9967
+
9953
9968
+    remove_frame_window (win);