~focus-follows-mouse/ubuntu/precise/compiz/fix-883383

« back to all changes in this revision

Viewing changes to debian/patches/102_git_fix_load_images.patch

  • Committer: Bazaar Package Importer
  • Author(s): Didier Roche
  • Date: 2011-03-22 21:45:34 UTC
  • mfrom: (0.168.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20110322214534-l6i6ds54os5uoqt1
Tags: 1:0.9.4git20110322-0ubuntu1
* New upstream bug fix snapshot:
  - Application windows can sometimes fail to display and will
    mask regions of the screen (LP: #709461)
  - Compiz switcher Alt-Tab order is not predictable - should
    maintain LIFO ordering in application switcher (LP: #175874)
  - after compiz crashed, gnome-panel isn't mapped again (LP: #711378)
  - invisible windows border problem (LP: #710271)
  - Compiz thinks you are clicking in an edge window when you
    are not (LP: #734250)
  - Add test case for invisible window regressions (LP: #736876)
  - often can't alt-click-dnd to move the focussed dialog (LP: #711911)
  - When windows open for the first time they should not hide (LP: #723878)
  - Unity Grid is broken for multi-monitor setups (LP: #709221)
  - Pixmaps trashed during animations when window is unmapped (LP: #733331)
  - Windows have blank decorations when rapidly closing and
    reopening (LP: #733328)
  - Unity is not restored on unity/compiz crash: compiz doesn't register
    properly with gnome-session (LP: #716462)
* remove the patch taken from upstream
* refresh u-w-d patch with latest upstream work
* debian/compiz-core.install:
  - image move to the final destination
* debian/patches/100_bump_core.h.patch:
  - bump for ABI breakage
* debian/compiz-decorator:
  - use gtk-window-decorator and not unity-window-decorator as it's really
    crashy for now (will probably redo an upload tomorrow with a fixed
    decorator)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 50ba20346c5a28dac5522c4a2da54c62a46efb3e Mon Sep 17 00:00:00 2001
2
 
From: Sam Spilsbury <sam.spilsbury@canonical.com>
3
 
Date: Mon, 28 Feb 2011 17:42:27 +0800
4
 
Subject: [PATCH 2/3] Fix the loading and installation of images - core images should
5
 
 be under the core plugin, freedesktop.png moved to cube
6
 
 and load images based on the actual install dirs
7
 
 
8
 
---
9
 
 CMakeLists.txt        |    2 +-
10
 
 images/CMakeLists.txt |    3 +--
11
 
 src/CMakeLists.txt    |    2 +-
12
 
 src/screen.cpp        |   13 +++++++++----
13
 
 4 files changed, 12 insertions(+), 8 deletions(-)
14
 
 
15
 
Index: compiz-0.9.4/CMakeLists.txt
16
 
===================================================================
17
 
--- compiz-0.9.4.orig/CMakeLists.txt    2011-03-01 02:16:07.319362600 +0800
18
 
+++ compiz-0.9.4/CMakeLists.txt 2011-03-01 02:16:07.479362839 +0800
19
 
@@ -40,7 +40,7 @@
20
 
 endif (COMPIZ_PACKAGING_ENABLED)
21
 
 
22
 
 set (compiz_plugindir ${libdir}/compiz)
23
 
-set (compiz_imagedir ${datadir}/compiz/images)
24
 
+set (compiz_sharedir ${datadir}/compiz/)
25
 
 set (compiz_metadatadir ${datadir}/compiz)
26
 
 set (COMPIZ_I18N_DIR ${CMAKE_SOURCE_DIR}/po)
27
 
 
28
 
Index: compiz-0.9.4/images/CMakeLists.txt
29
 
===================================================================
30
 
--- compiz-0.9.4.orig/images/CMakeLists.txt     2011-02-24 17:27:13.000000000 +0800
31
 
+++ compiz-0.9.4/images/CMakeLists.txt  2011-03-01 02:16:07.479362839 +0800
32
 
@@ -1,10 +1,9 @@
33
 
 
34
 
 set (_images
35
 
     icon.png
36
 
-    freedesktop.png
37
 
 )
38
 
 
39
 
 install (
40
 
     FILES ${_images}
41
 
-    DESTINATION ${COMPIZ_DESTDIR}${compiz_imagedir}
42
 
+    DESTINATION ${COMPIZ_DESTDIR}${compiz_sharedir}
43
 
 )
44
 
Index: compiz-0.9.4/src/CMakeLists.txt
45
 
===================================================================
46
 
--- compiz-0.9.4.orig/src/CMakeLists.txt        2011-02-24 17:27:13.000000000 +0800
47
 
+++ compiz-0.9.4/src/CMakeLists.txt     2011-03-01 02:16:07.479362839 +0800
48
 
@@ -17,7 +17,7 @@
49
 
 add_definitions (
50
 
     -DHAVE_CONFIG_H
51
 
     -DPLUGINDIR=\\\"${compiz_plugindir}\\\"
52
 
-    -DIMAGEDIR=\\\"${compiz_imagedir}\\\"
53
 
+    -DSHAREDIR=\\\"${compiz_sharedir}\\\"
54
 
     -DMETADATADIR=\\\"${compiz_metadatadir}\\\"
55
 
 )
56
 
 
57
 
Index: compiz-0.9.4/src/screen.cpp
58
 
===================================================================
59
 
--- compiz-0.9.4.orig/src/screen.cpp    2011-02-24 17:27:13.000000000 +0800
60
 
+++ compiz-0.9.4/src/screen.cpp 2011-03-01 02:16:07.479362839 +0800
61
 
@@ -1061,7 +1061,8 @@
62
 
     shutDown = true;
63
 
 }
64
 
 
65
 
-#define HOME_IMAGEDIR ".compiz-1/images"
66
 
+#define IMAGEDIR "images"
67
 
+#define HOMECOMPIZDIR ".compiz-1"
68
 
 
69
 
 bool
70
 
 CompScreen::readImageFromFile (CompString &name,
71
 
@@ -1081,10 +1082,12 @@
72
 
        {
73
 
            path =  home;
74
 
            path += "/";
75
 
-           path += HOME_IMAGEDIR;
76
 
+           path += HOMECOMPIZDIR;
77
 
            path += "/";
78
 
            path += pname;
79
 
            path += "/";
80
 
+           path += IMAGEDIR;
81
 
+           path += "/";
82
 
            path += name;
83
 
 
84
 
            status = fileToImage (path, size, stride, data);
85
 
@@ -1093,10 +1096,12 @@
86
 
                return true;
87
 
        }
88
 
 
89
 
-       path = IMAGEDIR;
90
 
+       path = SHAREDIR;
91
 
        path += "/";
92
 
        path += pname;
93
 
        path += "/";
94
 
+       path += IMAGEDIR;
95
 
+       path += "/";
96
 
        path += name;
97
 
        status = fileToImage (path, size, stride, data);
98
 
     }
99
 
@@ -3862,7 +3867,7 @@
100
 
 CompScreen::updateDefaultIcon ()
101
 
 {
102
 
     CompString file = priv->optionGetDefaultIcon ();
103
 
-    CompString pname = "";
104
 
+    CompString pname = "core/";
105
 
     void       *data;
106
 
     CompSize   size;
107