~henrix/ubuntu/precise/open-vm-dkms/lp-1416003

« back to all changes in this revision

Viewing changes to debian/patches/01-kvers.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Daniel Baumann
  • Date: 2008-10-23 15:32:00 UTC
  • mfrom: (1.1.2 upstream) (2.1.2 sid)
  • Revision ID: james.westby@ubuntu.com-20081023153200-gc1bfx89hj35c799
Tags: 2008.10.10-123053-2
* Correcting typo in dh_installinit call.
* Downgrading depends on module-assistant to recommends.

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
 
6
6
@DPATCH@
7
7
 
8
 
diff -Naur open-vm-tools-2007.11.21-64693.orig/modules/linux/vmblock/Makefile open-vm-tools-2007.11.21-64693/modules/linux/vmblock/Makefile
9
 
--- open-vm-tools-2007.11.21-64693.orig/modules/linux/vmblock/Makefile  2007-11-21 08:10:18.000000000 +0000
10
 
+++ open-vm-tools-2007.11.21-64693/modules/linux/vmblock/Makefile       2007-11-26 11:38:27.000000000 +0000
11
 
@@ -26,7 +26,7 @@
12
 
 ####
13
 
 SRCROOT = .
14
 
 
15
 
-VM_UNAME = $(shell uname -r)
16
 
+VM_UNAME = $(KVERS)
17
 
 
18
 
 # Header directory for the running kernel
19
 
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
20
 
diff -Naur open-vm-tools-2007.11.21-64693.orig/modules/linux/vmhgfs/Makefile open-vm-tools-2007.11.21-64693/modules/linux/vmhgfs/Makefile
21
 
--- open-vm-tools-2007.11.21-64693.orig/modules/linux/vmhgfs/Makefile   2007-11-21 08:10:20.000000000 +0000
22
 
+++ open-vm-tools-2007.11.21-64693/modules/linux/vmhgfs/Makefile        2007-11-26 11:38:30.000000000 +0000
23
 
@@ -26,7 +26,7 @@
24
 
 ####
25
 
 SRCROOT = .
26
 
 
27
 
-VM_UNAME = $(shell uname -r)
28
 
+VM_UNAME = $(KVERS)
29
 
 
30
 
 # Header directory for the running kernel
31
 
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
32
 
diff -Naur open-vm-tools-2007.11.21-64693.orig/modules/linux/vmmemctl/Makefile open-vm-tools-2007.11.21-64693/modules/linux/vmmemctl/Makefile
33
 
--- open-vm-tools-2007.11.21-64693.orig/modules/linux/vmmemctl/Makefile 2007-11-21 08:10:21.000000000 +0000
34
 
+++ open-vm-tools-2007.11.21-64693/modules/linux/vmmemctl/Makefile      2007-11-26 11:38:34.000000000 +0000
35
 
@@ -26,7 +26,7 @@
36
 
 ####
37
 
 SRCROOT = .
38
 
 
39
 
-VM_UNAME = $(shell uname -r)
40
 
+VM_UNAME = $(KVERS)
41
 
 
42
 
 # Header directory for the running kernel
43
 
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
44
 
diff -Naur open-vm-tools-2007.11.21-64693.orig/modules/linux/vmsync/Makefile open-vm-tools-2007.11.21-64693/modules/linux/vmsync/Makefile
45
 
--- open-vm-tools-2007.11.21-64693.orig/modules/linux/vmsync/Makefile   2007-11-21 08:10:23.000000000 +0000
46
 
+++ open-vm-tools-2007.11.21-64693/modules/linux/vmsync/Makefile        2007-11-26 11:38:36.000000000 +0000
47
 
@@ -26,7 +26,7 @@
48
 
 ####
49
 
 SRCROOT = .
50
 
 
51
 
-VM_UNAME = $(shell uname -r)
52
 
+VM_UNAME = $(KVERS)
53
 
 
54
 
 # Header directory for the running kernel
55
 
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
56
 
diff -Naur open-vm-tools-2007.11.21-64693.orig/modules/linux/vmxnet/Makefile open-vm-tools-2007.11.21-64693/modules/linux/vmxnet/Makefile
57
 
--- open-vm-tools-2007.11.21-64693.orig/modules/linux/vmxnet/Makefile   2007-11-21 08:10:22.000000000 +0000
58
 
+++ open-vm-tools-2007.11.21-64693/modules/linux/vmxnet/Makefile        2007-11-26 11:38:39.000000000 +0000
 
8
diff -Naurp open-vm-tools.orig/modules/linux/vmblock/Makefile open-vm-tools/modules/linux/vmblock/Makefile
 
9
--- open-vm-tools.orig/modules/linux/vmblock/Makefile   2008-10-16 07:38:58.000000000 +0200
 
10
+++ open-vm-tools/modules/linux/vmblock/Makefile        2008-10-16 07:37:43.000000000 +0200
 
11
@@ -26,7 +26,7 @@
 
12
 ####
 
13
 SRCROOT = .
 
14
 
 
15
-VM_UNAME = $(shell uname -r)
 
16
+VM_UNAME = $(KVERS)
 
17
 
 
18
 # Header directory for the running kernel
 
19
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
 
20
diff -Naurp open-vm-tools.orig/modules/linux/vmci/Makefile open-vm-tools/modules/linux/vmci/Makefile
 
21
--- open-vm-tools.orig/modules/linux/vmci/Makefile      2008-10-16 07:38:58.000000000 +0200
 
22
+++ open-vm-tools/modules/linux/vmci/Makefile   2008-10-16 07:37:43.000000000 +0200
 
23
@@ -26,7 +26,7 @@
 
24
 ####
 
25
 SRCROOT = .
 
26
 
 
27
-VM_UNAME = $(shell uname -r)
 
28
+VM_UNAME = $(KVERS)
 
29
 
 
30
 # Header directory for the running kernel
 
31
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
 
32
diff -Naurp open-vm-tools.orig/modules/linux/vmhgfs/Makefile open-vm-tools/modules/linux/vmhgfs/Makefile
 
33
--- open-vm-tools.orig/modules/linux/vmhgfs/Makefile    2008-10-16 07:38:58.000000000 +0200
 
34
+++ open-vm-tools/modules/linux/vmhgfs/Makefile 2008-10-16 07:37:43.000000000 +0200
 
35
@@ -26,7 +26,7 @@
 
36
 ####
 
37
 SRCROOT = .
 
38
 
 
39
-VM_UNAME = $(shell uname -r)
 
40
+VM_UNAME = $(KVERS)
 
41
 
 
42
 # Header directory for the running kernel
 
43
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
 
44
diff -Naurp open-vm-tools.orig/modules/linux/vmmemctl/Makefile open-vm-tools/modules/linux/vmmemctl/Makefile
 
45
--- open-vm-tools.orig/modules/linux/vmmemctl/Makefile  2008-10-16 07:38:58.000000000 +0200
 
46
+++ open-vm-tools/modules/linux/vmmemctl/Makefile       2008-10-16 07:37:43.000000000 +0200
 
47
@@ -26,7 +26,7 @@
 
48
 ####
 
49
 SRCROOT = .
 
50
 
 
51
-VM_UNAME = $(shell uname -r)
 
52
+VM_UNAME = $(KVERS)
 
53
 
 
54
 # Header directory for the running kernel
 
55
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
 
56
diff -Naurp open-vm-tools.orig/modules/linux/vmsync/Makefile open-vm-tools/modules/linux/vmsync/Makefile
 
57
--- open-vm-tools.orig/modules/linux/vmsync/Makefile    2008-10-16 07:38:58.000000000 +0200
 
58
+++ open-vm-tools/modules/linux/vmsync/Makefile 2008-10-16 07:37:43.000000000 +0200
 
59
@@ -26,7 +26,7 @@
 
60
 ####
 
61
 SRCROOT = .
 
62
 
 
63
-VM_UNAME = $(shell uname -r)
 
64
+VM_UNAME = $(KVERS)
 
65
 
 
66
 # Header directory for the running kernel
 
67
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
 
68
diff -Naurp open-vm-tools.orig/modules/linux/vmxnet/Makefile open-vm-tools/modules/linux/vmxnet/Makefile
 
69
--- open-vm-tools.orig/modules/linux/vmxnet/Makefile    2008-10-16 07:38:58.000000000 +0200
 
70
+++ open-vm-tools/modules/linux/vmxnet/Makefile 2008-10-16 07:37:43.000000000 +0200
 
71
@@ -26,7 +26,7 @@
 
72
 ####
 
73
 SRCROOT = .
 
74
 
 
75
-VM_UNAME = $(shell uname -r)
 
76
+VM_UNAME = $(KVERS)
 
77
 
 
78
 # Header directory for the running kernel
 
79
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
 
80
diff -Naurp open-vm-tools.orig/modules/linux/vmxnet3/Makefile open-vm-tools/modules/linux/vmxnet3/Makefile
 
81
--- open-vm-tools.orig/modules/linux/vmxnet3/Makefile   2008-10-16 07:38:58.000000000 +0200
 
82
+++ open-vm-tools/modules/linux/vmxnet3/Makefile        2008-10-16 07:38:06.000000000 +0200
 
83
@@ -26,7 +26,7 @@
 
84
 ####
 
85
 SRCROOT = .
 
86
 
 
87
-VM_UNAME = $(shell uname -r)
 
88
+VM_UNAME = $(KVERS)
 
89
 
 
90
 # Header directory for the running kernel
 
91
 HEADER_DIR = /lib/modules/$(VM_UNAME)/build/include
 
92
diff -Naurp open-vm-tools.orig/modules/linux/vsock/Makefile open-vm-tools/modules/linux/vsock/Makefile
 
93
--- open-vm-tools.orig/modules/linux/vsock/Makefile     2008-10-16 07:38:58.000000000 +0200
 
94
+++ open-vm-tools/modules/linux/vsock/Makefile  2008-10-16 07:37:43.000000000 +0200
59
95
@@ -26,7 +26,7 @@
60
96
 ####
61
97
 SRCROOT = .