~hypodermia/ubuntu/oneiric/compiz/fix-for-bug-301174

« back to all changes in this revision

Viewing changes to debian/patches/10_git_set_vp_before_window_initialization.patch

  • Committer: Bazaar Package Importer
  • Author(s): Didier Roche
  • Date: 2011-02-24 17:31:29 UTC
  • mfrom: (0.167.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20110224173129-hsczyk7yw7s21flf
Tags: 1:0.9.4-0ubuntu1
* New upstream release:
  - Fix no windows receiving the focus if someone got the focus then was
    destroyed
  - Fix crash when resizing using keybindings
  - Fix unresponsive inactive decorations (LP: #703755) 
  - Fix the long awaited gconf crash (LP: #691561)
  - gtk-window-decorator doesn't respect special decoration styles
    (LP: #290835)
* debian/compiz-core.links,
  debian/source_compiz.py,
  debian/compiz-core.install:
  - install again a richer apport hook to redirect nux/libunity/unityshell
    crash. It also asks the user to redirect unity issues against unity (still
    incuding xorg info when needed)
* Removed a bunch of patches either cherry-picked or pushed upstream. With the
  other fixes, the gconf workaround is hopefully not needed anymore.
* refresh existing patches to still apply
* debian/control:
  - rename dep on compiz-fusion* to compiz*
* debian/patches/085_add_grid_plugin.patch:
  - refresh the grid plugin from new release
* debian/patches/086_new_grid_defaults.patch
  - separate tweaking the default settings to only have the effect that were
    specified:
    top -> maximize, left (top or bottom left) -> window half left of the
    screen, right (top or bottom right) -> window half right of the screen,
    bottom -> do nothing

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From 26e17cd0bd0ff0035fb098ff5c5333a95e641b0f Mon Sep 17 00:00:00 2001
2
 
From: Sam Spilsbury <sam.spilsbury@canonical.com>
3
 
Date: Tue, 25 Jan 2011 16:04:54 +0000
4
 
Subject: Set the vp size before initializing windows
5
 
 
6
 
---
7
 
diff --git a/src/screen.cpp b/src/screen.cpp
8
 
index 63e0c96..2c25c07 100644
9
 
--- a/src/screen.cpp
10
 
+++ b/src/screen.cpp
11
 
@@ -4597,6 +4597,9 @@ CompScreen::init (const char *name)
12
 
        }
13
 
     }
14
 
 
15
 
+    priv->vpSize.setWidth (priv->optionGetHsize ());
16
 
+    priv->vpSize.setHeight (priv->optionGetVsize ());
17
 
+
18
 
     /* enforce restack on all windows */
19
 
     for (CompWindowList::reverse_iterator rit = priv->windows.rbegin ();
20
 
         rit != priv->windows.rend (); rit++)
21
 
@@ -4612,9 +4615,6 @@ CompScreen::init (const char *name)
22
 
            w->priv->activeNum = priv->activeNum++;
23
 
     }
24
 
 
25
 
-    priv->vpSize.setWidth (priv->optionGetHsize ());
26
 
-    priv->vpSize.setHeight (priv->optionGetVsize ());
27
 
-
28
 
     XGetInputFocus (dpy, &focus, &revertTo);
29
 
 
30
 
     /* move input focus to root window so that we get a FocusIn event when
31
 
--
32
 
cgit v0.8.3.1-30-gff3a