~hypodermia/ubuntu/oneiric/compiz/fix-for-bug-301174

« back to all changes in this revision

Viewing changes to debian/patches/12_fix_warning.patch

  • Committer: Bazaar Package Importer
  • Author(s): Didier Roche
  • Date: 2011-02-24 17:31:29 UTC
  • mfrom: (0.167.1 upstream)
  • Revision ID: james.westby@ubuntu.com-20110224173129-hsczyk7yw7s21flf
Tags: 1:0.9.4-0ubuntu1
* New upstream release:
  - Fix no windows receiving the focus if someone got the focus then was
    destroyed
  - Fix crash when resizing using keybindings
  - Fix unresponsive inactive decorations (LP: #703755) 
  - Fix the long awaited gconf crash (LP: #691561)
  - gtk-window-decorator doesn't respect special decoration styles
    (LP: #290835)
* debian/compiz-core.links,
  debian/source_compiz.py,
  debian/compiz-core.install:
  - install again a richer apport hook to redirect nux/libunity/unityshell
    crash. It also asks the user to redirect unity issues against unity (still
    incuding xorg info when needed)
* Removed a bunch of patches either cherry-picked or pushed upstream. With the
  other fixes, the gconf workaround is hopefully not needed anymore.
* refresh existing patches to still apply
* debian/control:
  - rename dep on compiz-fusion* to compiz*
* debian/patches/085_add_grid_plugin.patch:
  - refresh the grid plugin from new release
* debian/patches/086_new_grid_defaults.patch
  - separate tweaking the default settings to only have the effect that were
    specified:
    top -> maximize, left (top or bottom left) -> window half left of the
    screen, right (top or bottom right) -> window half right of the screen,
    bottom -> do nothing

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From f3262eed20ce32f1162586df511d559bace4008c Mon Sep 17 00:00:00 2001
2
 
From: Sam Spilsbury <sam.spilsbury@canonical.com>
3
 
Date: Wed, 26 Jan 2011 14:54:54 +0800
4
 
Subject: [PATCH 2/3] Fix warning
5
 
 
6
 
---
7
 
 src/event.cpp |    2 +-
8
 
 1 files changed, 1 insertions(+), 1 deletions(-)
9
 
 
10
 
diff --git a/src/event.cpp b/src/event.cpp
11
 
index 7ab5843..ddded38 100644
12
 
--- a/src/event.cpp
13
 
+++ b/src/event.cpp
14
 
@@ -1057,7 +1057,7 @@ CompScreen::handleEvent (XEvent *event)
15
 
         * the window to the window list as we might get configure requests
16
 
         * which require us to stack other windows relative to it. Setting
17
 
         * some default values if this is the case. */
18
 
-       if (failure = !XGetWindowAttributes (priv->dpy, event->xcreatewindow.window, &wa))
19
 
+       if ((failure = !XGetWindowAttributes (priv->dpy, event->xcreatewindow.window, &wa)))
20
 
            priv->setDefaultWindowAttributes (&wa);
21
 
 
22
 
        w = findTopLevelWindow (event->xcreatewindow.window, true);
23
 
1.7.2.3
24