~kklimonda/ubuntu/lucid/rxvt-unicode/lp-514821

« back to all changes in this revision

Viewing changes to debian/patches/make-doc.patch

  • Committer: Bazaar Package Importer
  • Author(s): Decklin Foster
  • Date: 2006-09-01 14:44:58 UTC
  • mfrom: (1.1.8 upstream) (3.1.1 etch)
  • Revision ID: james.westby@ubuntu.com-20060901144458-98hrz8zg01w8a3vy
Tags: 7.9-2
* Edit the comments in the app-defaults file, and disable all settings by
  default. If font autoselection fails, I would prefer to open a new bug
  specifically for that. (Closes: #385481)
* Reorganize and edit README.Debian, pushing as much as possible into FAQ
  format (with resource setting issues first).

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: rxvt-unicode-7.7/doc/Makefile.in
2
 
===================================================================
3
 
--- rxvt-unicode-7.7.orig/doc/Makefile.in       2006-03-12 14:07:22.000000000 -0500
4
 
+++ rxvt-unicode-7.7/doc/Makefile.in    2006-03-12 14:08:10.000000000 -0500
5
 
@@ -36,7 +36,7 @@
6
 
 
7
 
 #-------------------------------------------------------------------------
8
 
 
9
 
-all:
10
 
+all: alldoc
11
 
 
12
 
 SEDREPLACE = -e 's%@@RXVT_VERSION@@%$(VERSION)%g;'     \
13
 
             -e 's%@@RXVT_NAME@@%$(RXVTNAME)%g;'        \
14
 
@@ -50,14 +50,14 @@
15
 
 %.tbl: %.pod
16
 
        ./podtbl <$< >$@
17
 
 
18
 
-%.1.man.in: %.1.tbl
19
 
-       pod2man -n rxvt -r"$(VERSION)" -q\" -s1 -c "RXVT-UNICODE" <$< >$@
20
 
+%.1.man: %.1.tbl
21
 
+       $(SED) $(SEDREPLACE) <$< | pod2man -n rxvt -r"$(VERSION)" -q\" -s1 -c "RXVT-UNICODE" >$@
22
 
 
23
 
-%.3.man.in: %.3.tbl
24
 
-       pod2man -n rxvt -r"$(VERSION)" -q\" -s3 -c "RXVT-UNICODE" <$< >$@
25
 
+%.3.man: %.3.tbl
26
 
+       $(SED) $(SEDREPLACE) <$< | pod2man -n rxvt -r"$(VERSION)" -q\" -s3 -c "RXVT-UNICODE" >$@
27
 
 
28
 
-%.7.man.in: %.7.tbl
29
 
-       pod2man -n rxvt -r"$(VERSION)" -q\" -s7 -c "RXVT-UNICODE" <$< >$@
30
 
+%.7.man: %.7.tbl
31
 
+       $(SED) $(SEDREPLACE) <$< | pod2man -n rxvt -r"$(VERSION)" -q\" -s7 -c "RXVT-UNICODE" >$@
32
 
 
33
 
 %.html: %.tbl
34
 
        $(SED) $(SEDREPLACE) <$< | pod2html >$@
35
 
@@ -73,39 +73,34 @@
36
 
 
37
 
 tags allbin:
38
 
 
39
 
-alldoc:        rxvt.1.man.in rxvt.7.man.in rxvtc.1.man.in rxvtd.1.man.in rxvtperl.3.man.in \
40
 
-       rxvt.1.txt    rxvt.7.txt    rxvtc.1.txt    rxvtd.1.txt    rxvtperl.3.txt \
41
 
-       rxvt.1.html   rxvt.7.html   rxvtc.1.html   rxvtd.1.html   rxvtperl.3.html \
42
 
+alldoc:        rxvt.1.man  rxvt.7.man  rxvtc.1.man  rxvtd.1.man  rxvtperl.3.man \
43
 
+       rxvt.1.txt  rxvt.7.txt  rxvtc.1.txt  rxvtd.1.txt  rxvtperl.3.txt \
44
 
+       rxvt.1.html rxvt.7.html rxvtc.1.html rxvtd.1.html rxvtperl.3.html \
45
 
        ../README.configure ../README.FAQ
46
 
        infocmp -C rxvt-unicode >etc/rxvt-unicode.termcap
47
 
 
48
 
 clean:
49
 
-       rm -f *~
50
 
+       rm -f pod*.tmp *~
51
 
 
52
 
 realclean: clean
53
 
-       rm -f tags ../README.configure ../README.FAQ
54
 
-       rm -f rxvt.1.man.in rxvt.7.man.in rxvtc.1.man.in rxvtd.1.man.in
55
 
-       rm -f rxvt.1.man    rxvt.7.man    rxvtc.1.man    rxvtd.1.man   
56
 
-       rm -f rxvt.1.txt    rxvt.7.txt    rxvtc.1.txt    rxvtd.1.txt
57
 
-       rm -f rxvt.1.html   rxvt.7.html   rxvtc.1.html   rxvtd.1.html
58
 
+       rm -f tags ../README.configure ../README.FAQ rxvtperl.3.pod
59
 
+       rm -f rxvt.1.tbl  rxvt.7.tbl  rxvtc.1.tbl  rxvtd.1.tbl  rxvtperl.3.tbl
60
 
+       rm -f rxvt.1.man  rxvt.7.man  rxvtc.1.man  rxvtd.1.man  rxvtperl.3.man
61
 
+       rm -f rxvt.1.txt  rxvt.7.txt  rxvtc.1.txt  rxvtd.1.txt  rxvtperl.3.txt
62
 
+       rm -f rxvt.1.html rxvt.7.html rxvtc.1.html rxvtd.1.html rxvtperl.3.html
63
 
 
64
 
 cleandir: realclean
65
 
 
66
 
-distclean:
67
 
+distclean: realclean
68
 
 
69
 
-install:
70
 
+install: alldoc
71
 
        $(INSTALL) -d $(DESTDIR)$(man1dir)
72
 
-       $(SED) $(SEDREPLACE) < rxvt.1.man.in >rxvt.1.man
73
 
        $(INSTALL_DATA) rxvt.1.man $(DESTDIR)$(man1dir)/$(RXVTNAME).$(man1ext)
74
 
-       $(SED) $(SEDREPLACE) < rxvtc.1.man.in >rxvtc.1.man
75
 
        $(INSTALL_DATA) rxvtc.1.man $(DESTDIR)$(man1dir)/$(RXVTNAME)c.$(man1ext)
76
 
-       $(SED) $(SEDREPLACE) < rxvtd.1.man.in >rxvtd.1.man
77
 
        $(INSTALL_DATA) rxvtd.1.man $(DESTDIR)$(man1dir)/$(RXVTNAME)d.$(man1ext)
78
 
        $(INSTALL) -d $(DESTDIR)$(man7dir)
79
 
-       $(SED) $(SEDREPLACE) < rxvt.7.man.in >rxvt.7.man
80
 
        $(INSTALL_DATA) rxvt.7.man $(DESTDIR)$(man7dir)/$(RXVTNAME).$(man7ext)
81
 
 @IF_PERL@      $(INSTALL) -d $(DESTDIR)$(man3dir)
82
 
-@IF_PERL@      $(SED) $(SEDREPLACE) < rxvtperl.3.man.in >rxvtperl.3.man
83
 
 @IF_PERL@      $(INSTALL_DATA) rxvtperl.3.man $(DESTDIR)$(man3dir)/$(RXVTNAME)perl.$(man3ext)
84
 
        if test -x "@TIC@"; then if test -n "@TIC@"; then @TIC@ etc/rxvt-unicode.terminfo; fi; fi
85