~laney/gnome-control-center/3.5.4

« back to all changes in this revision

Viewing changes to debian/patches/04_new_appearance_settings.patch

  • Committer: Iain Lane
  • Date: 2012-07-09 16:34:27 UTC
  • Revision ID: iain.lane@canonical.com-20120709163427-hs2plim0hxw00yyz
* New upstream release.
* Refresh all patches to apply cleanly. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: gnome-control-center-3.5.2/configure.ac
 
1
Index: b/configure.ac
2
2
===================================================================
3
 
--- gnome-control-center-3.5.2.orig/configure.ac        2012-06-05 16:02:33.000000000 +1200
4
 
+++ gnome-control-center-3.5.2/configure.ac     2012-06-08 16:38:31.980354987 +1200
5
 
@@ -95,7 +95,7 @@
 
3
--- a/configure.ac
 
4
+++ b/configure.ac
 
5
@@ -96,7 +96,7 @@
6
6
 PKG_CHECK_MODULES(SHELL, $COMMON_MODULES libgnome-menu-3.0 gio-unix-2.0 x11 clutter-gtk-1.0 
7
7
                   clutter-1.0 >= $CLUTTER_REQUIRED_VERSION)
8
8
 PKG_CHECK_MODULES(BACKGROUND_PANEL, $COMMON_MODULES libxml-2.0 gnome-desktop-3.0
11
11
 PKG_CHECK_MODULES(DATETIME_PANEL, $COMMON_MODULES
12
12
                   gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
13
13
                   polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION
14
 
Index: gnome-control-center-3.5.2/panels/background/background.ui
 
14
Index: b/panels/background/background.ui
15
15
===================================================================
16
 
--- gnome-control-center-3.5.2.orig/panels/background/background.ui     2011-11-16 04:30:35.000000000 +1300
17
 
+++ gnome-control-center-3.5.2/panels/background/background.ui  2012-06-08 16:38:31.984354989 +1200
 
16
--- a/panels/background/background.ui
 
17
+++ b/panels/background/background.ui
18
18
@@ -1,7 +1,6 @@
19
19
-<?xml version="1.0"?>
20
20
+<?xml version="1.0" encoding="UTF-8"?>
82
82
         <property name="visible">True</property>
83
83
-        <property name="orientation">vertical</property>
84
84
-        <property name="spacing">0</property>
85
 
-        <child>
 
85
+        <property name="can_focus">True</property>
 
86
+        <property name="border_width">12</property>
 
87
         <child>
86
88
-          <object class="GtkComboBox" id="sources-combobox">
87
 
-            <property name="visible">True</property>
 
89
+          <object class="GtkBox" id="background-panel">
 
90
             <property name="visible">True</property>
88
91
-            <property name="model">sources-liststore</property>
89
92
-            <child>
90
93
-              <object class="GtkCellRendererText" id="cellrenderertext2"/>
99
102
-            <property name="padding">6</property>
100
103
-          </packing>
101
104
-        </child>
102
 
+        <property name="can_focus">True</property>
103
 
+        <property name="border_width">12</property>
104
 
         <child>
 
105
-        <child>
105
106
-          <object class="GtkScrolledWindow" id="scrolledwindow1">
106
107
-            <property name="width_request">220</property>
107
108
-            <property name="height_request">380</property>
108
 
+          <object class="GtkBox" id="background-panel">
109
 
             <property name="visible">True</property>
 
109
-            <property name="visible">True</property>
110
110
-            <property name="can_focus">True</property>
111
111
-            <property name="hscrollbar_policy">automatic</property>
112
112
-            <property name="vscrollbar_policy">automatic</property>
1134
1134
+            <child>
1135
1135
+              <placeholder/>
1136
1136
+            </child>
 
1137
+          </object>
 
1138
+          <packing>
 
1139
+            <property name="position">1</property>
 
1140
+          </packing>
 
1141
+        </child>
 
1142
+        <child type="tab">
 
1143
+          <object class="GtkLabel" id="behavior_label">
 
1144
+            <property name="visible">True</property>
 
1145
+            <property name="can_focus">False</property>
 
1146
+            <property name="label" translatable="yes">Behavior</property>
1137
1147
           </object>
1138
1148
           <packing>
1139
1149
-            <property name="expand">False</property>
1140
1150
-            <property name="position">2</property>
1141
1151
+            <property name="position">1</property>
1142
 
+          </packing>
1143
 
+        </child>
1144
 
+        <child type="tab">
1145
 
+          <object class="GtkLabel" id="behavior_label">
1146
 
+            <property name="visible">True</property>
1147
 
+            <property name="can_focus">False</property>
1148
 
+            <property name="label" translatable="yes">Behavior</property>
1149
 
+          </object>
1150
 
+          <packing>
1151
 
+            <property name="position">1</property>
1152
1152
+            <property name="tab_fill">False</property>
1153
1153
           </packing>
1154
1154
         </child>
1172
1172
-    </columns>
1173
1173
-    <data>
1174
1174
-      <row>
1175
 
-        <col id="0" translatable="yes">Tile</col>
 
1175
-        <col id="0" translatable="yes" context="background, style">Tile</col>
1176
1176
-        <col id="1">1</col>
1177
1177
-      </row>
1178
1178
-      <row>
1179
 
-        <col id="0" translatable="yes">Zoom</col>
 
1179
-        <col id="0" translatable="yes" context="background, style">Zoom</col>
1180
1180
-        <col id="1">5</col>
1181
1181
-      </row>
1182
1182
-      <row>
1183
 
-        <col id="0" translatable="yes">Center</col>
 
1183
-        <col id="0" translatable="yes" context="background, style">Center</col>
1184
1184
-        <col id="1">2</col>
1185
1185
-      </row>
1186
1186
-      <row>
1187
 
-        <col id="0" translatable="yes">Scale</col>
 
1187
-        <col id="0" translatable="yes" context="background, style">Scale</col>
1188
1188
-        <col id="1">3</col>
1189
1189
-      </row>
1190
1190
-      <row>
1191
 
-        <col id="0" translatable="yes">Fill</col>
 
1191
-        <col id="0" translatable="yes" context="background, style">Fill</col>
1192
1192
-        <col id="1">4</col>
1193
1193
-      </row>
1194
1194
-      <row>
1195
 
-        <col id="0" translatable="yes">Span</col>
 
1195
-        <col id="0" translatable="yes" context="background, style">Span</col>
1196
1196
-        <col id="1">6</col>
1197
1197
-      </row>
1198
1198
-    </data>
1199
1199
-  </object>
1200
1200
 </interface>
1201
 
Index: gnome-control-center-3.5.2/panels/background/cc-background-panel.c
 
1201
Index: b/panels/background/cc-background-panel.c
1202
1202
===================================================================
1203
 
--- gnome-control-center-3.5.2.orig/panels/background/cc-background-panel.c     2012-05-19 14:16:16.000000000 +1200
1204
 
+++ gnome-control-center-3.5.2/panels/background/cc-background-panel.c  2012-06-08 16:38:31.984354989 +1200
 
1203
--- a/panels/background/cc-background-panel.c
 
1204
+++ b/panels/background/cc-background-panel.c
1205
1205
@@ -24,6 +24,7 @@
1206
1206
 #include <string.h>
1207
1207
 #include <glib/gi18n-lib.h>
1309
1309
   G_OBJECT_CLASS (cc_background_panel_parent_class)->dispose (object);
1310
1310
 }
1311
1311
 
1312
 
@@ -349,12 +407,21 @@
 
1312
@@ -349,16 +407,25 @@
1313
1313
   if (priv->current_background)
1314
1314
     {
1315
1315
       GdkColor pcolor, scolor;
1316
1316
+      const char* bgsize = NULL;
1317
 
 
1318
 
-      markup = g_strdup_printf ("<b>%s</b>", cc_background_item_get_name (priv->current_background));
1319
 
+      markup = g_strdup_printf ("<i>%s</i>", cc_background_item_get_name (priv->current_background));
 
1317
       char *escaped;
 
1318
 
 
1319
       escaped = g_markup_escape_text (cc_background_item_get_name (priv->current_background), -1);
 
1320
-      markup = g_strdup_printf ("<b>%s</b>", escaped);
 
1321
+      markup = g_strdup_printf ("<i>%s</i>", escaped);
 
1322
       g_free (escaped);
 
1323
 
1320
1324
       gtk_label_set_markup (GTK_LABEL (WID ("background-label")), markup);
1321
1325
       g_free (markup);
1322
1326
 
1333
1337
 
1334
1338
       gdk_color_parse (cc_background_item_get_pcolor (priv->current_background), &pcolor);
1335
1339
       gdk_color_parse (cc_background_item_get_scolor (priv->current_background), &scolor);
1336
 
@@ -1175,12 +1242,503 @@
 
1340
@@ -1179,12 +1246,503 @@
1337
1341
   g_strfreev(uris);
1338
1342
 }
1339
1343
 
1838
1842
   GError *err = NULL;
1839
1843
   GtkWidget *widget;
1840
1844
   GtkListStore *store;
1841
 
@@ -1190,9 +1748,14 @@
 
1845
@@ -1194,9 +1752,14 @@
1842
1846
 
1843
1847
   priv->builder = gtk_builder_new ();
1844
1848
 
1856
1860
 
1857
1861
   if (err)
1858
1862
     {
1859
 
@@ -1243,7 +1806,10 @@
 
1863
@@ -1247,7 +1810,10 @@
1860
1864
 
1861
1865
 
1862
1866
   /* add the top level widget */
1868
1872
 
1869
1873
   gtk_container_add (GTK_CONTAINER (self), widget);
1870
1874
   gtk_widget_show_all (GTK_WIDGET (self));
1871
 
@@ -1314,6 +1880,18 @@
 
1875
@@ -1318,6 +1884,18 @@
1872
1876
 
1873
1877
   /* Setup the edit box with our current settings */
1874
1878
   source_update_edit_box (priv, TRUE);
1887
1891
 }
1888
1892
 
1889
1893
 void
1890
 
Index: gnome-control-center-3.5.2/panels/background/gnome-background-panel.desktop.in.in
 
1894
Index: b/panels/background/gnome-background-panel.desktop.in.in
1891
1895
===================================================================
1892
 
--- gnome-control-center-3.5.2.orig/panels/background/gnome-background-panel.desktop.in.in      2011-12-20 18:11:50.000000000 +1300
1893
 
+++ gnome-control-center-3.5.2/panels/background/gnome-background-panel.desktop.in.in   2012-06-08 16:38:31.984354989 +1200
 
1896
--- a/panels/background/gnome-background-panel.desktop.in.in
 
1897
+++ b/panels/background/gnome-background-panel.desktop.in.in
1894
1898
@@ -1,6 +1,6 @@
1895
1899
 [Desktop Entry]
1896
1900
-_Name=Background