~laney/gnome-control-center/3.5.4

« back to all changes in this revision

Viewing changes to debian/patches/51_unity_options_in_display_panel.patch

  • Committer: Iain Lane
  • Date: 2012-07-09 16:34:27 UTC
  • Revision ID: iain.lane@canonical.com-20120709163427-hs2plim0hxw00yyz
* New upstream release.
* Refresh all patches to apply cleanly. 

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: gnome-control-center-3.5.2/configure.ac
 
1
Index: b/configure.ac
2
2
===================================================================
3
 
--- gnome-control-center-3.5.2.orig/configure.ac        2012-06-08 16:38:31.980354987 +1200
4
 
+++ gnome-control-center-3.5.2/configure.ac     2012-06-08 16:40:23.204351140 +1200
5
 
@@ -100,7 +100,7 @@
 
3
--- a/configure.ac
 
4
+++ b/configure.ac
 
5
@@ -101,7 +101,7 @@
6
6
                   gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
7
7
                   polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION
8
8
                   gdk-pixbuf-2.0 >= $GDKPIXBUF_REQUIRED_VERSION)
11
11
 PKG_CHECK_MODULES(INFO_PANEL, $COMMON_MODULES libgtop-2.0
12
12
                  polkit-gobject-1 >= $POLKIT_REQUIRED_VERSION)
13
13
 PKG_CHECK_MODULES(KEYBOARD_PANEL, $COMMON_MODULES x11)
14
 
Index: gnome-control-center-3.5.2/panels/display/cc-display-panel.c
 
14
Index: b/panels/display/cc-display-panel.c
15
15
===================================================================
16
 
--- gnome-control-center-3.5.2.orig/panels/display/cc-display-panel.c   2012-05-19 14:16:16.000000000 +1200
17
 
+++ gnome-control-center-3.5.2/panels/display/cc-display-panel.c        2012-06-08 16:40:23.208351140 +1200
 
16
--- a/panels/display/cc-display-panel.c
 
17
+++ b/panels/display/cc-display-panel.c
18
18
@@ -36,6 +36,7 @@
19
19
 #include <X11/Xlib.h>
20
20
 #include <glib/gi18n.h>
235
235
+static GdkPixbuf*
236
236
+get_monitor_pixbuf (CcDisplayPanel *self, GnomeRROutputInfo *output)
237
237
+{
238
 
+  GdkColor color;
 
238
+  GdkRGBA color;
239
239
+  cairo_surface_t *cairo_surface;
240
240
+  cairo_t *cr;
241
241
+  int monitor_width = 30;
242
242
+  int monitor_height = 15;
243
243
+
244
 
+  gnome_rr_labeler_get_color_for_output (self->priv->labeler, output, &color);
 
244
+  gnome_rr_labeler_get_rgba_for_output (self->priv->labeler, output, &color);
245
245
+
246
246
+  cairo_surface = cairo_image_surface_create (CAIRO_FORMAT_RGB24, monitor_width, monitor_height);
247
247
+  cr = cairo_create (cairo_surface);
250
250
+  cairo_paint (cr);
251
251
+
252
252
+  cairo_set_operator (cr, CAIRO_OPERATOR_OVER);
253
 
+  cairo_set_source_rgb (cr, color.red / 65535.0, color.green / 65535.0, color.blue / 65535.0);
 
253
+  cairo_set_source_rgb (cr, color.red, color.green, color.blue);
254
254
+  cairo_rectangle (cr, 0.5, 0.5, monitor_width - 1, monitor_height - 1);
255
255
+  cairo_fill (cr);
256
256
+
454
454
                                   "display", 0);
455
455
 }
456
456
-
457
 
Index: gnome-control-center-3.5.2/panels/display/display-capplet.ui
 
457
Index: b/panels/display/display-capplet.ui
458
458
===================================================================
459
 
--- gnome-control-center-3.5.2.orig/panels/display/display-capplet.ui   2011-12-20 18:11:50.000000000 +1300
460
 
+++ gnome-control-center-3.5.2/panels/display/display-capplet.ui        2012-06-08 16:40:23.208351140 +1200
 
459
--- a/panels/display/display-capplet.ui
 
460
+++ b/panels/display/display-capplet.ui
461
461
@@ -1,6 +1,14 @@
462
462
 <?xml version="1.0"?>
463
463
 <interface>