~matttbe/ubuntu/raring/poppler/lp1072129

« back to all changes in this revision

Viewing changes to debian/patches/11_set-font-weight-medium.patch

  • Committer: Package Import Robot
  • Author(s): Sebastien Bacher
  • Date: 2011-12-05 17:23:02 UTC
  • mfrom: (1.7.1)
  • Revision ID: package-import@ubuntu.com-20111205172302-tmhrk7s9hikjsa79
Tags: 0.18.2-0ubuntu1
* New upstream version, bugs fixed in the new version (lp: #869850):
  - lines and graphics wrongly rendered (lp: #603929) (lp: #780169)
  - rendering issues on some documents (lp: #784154)
  - some pages are displayed blank (lp: #817626)
* debian/control, debian/rules:
  - updated for the libpoppler and libpoppler-glib soname changes
* drop patches included in the new version
* debian/libpoppler-glib-dev.install:
  - drop deprecated test-poppler-glib
* debian/rules: 
  - drop deprecated qt3 and abiword configure options

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
## Description: set FC_WEIGHT_MEDIUM when the font name contains "Medium"
2
 
## Author: Nobuto MURATA <nobuto@nobuto-murata.org>
3
 
## Bug-Ubuntu: https://launchpad.net/bugs/769827
4
 
## Bug: https://bugs.freedesktop.org/show_bug.cgi?id=36474
5
 
## Forwarded: no
6
 
Index: poppler-0.16.4/poppler/GlobalParams.cc
7
 
===================================================================
8
 
--- poppler-0.16.4.orig/poppler/GlobalParams.cc 2011-04-19 21:13:10.662154002 +0900
9
 
+++ poppler-0.16.4/poppler/GlobalParams.cc      2011-04-19 21:13:00.102154000 +0900
10
 
@@ -1055,6 +1055,8 @@
11
 
     slant = FC_SLANT_ITALIC;
12
 
   if (findModifier(modifiers, "Bold", &start))
13
 
     weight = FC_WEIGHT_BOLD;
14
 
+  if (findModifier(modifiers, "Medium", &start))
15
 
+    weight = FC_WEIGHT_MEDIUM;
16
 
   if (findModifier(modifiers, "Light", &start))
17
 
     weight = FC_WEIGHT_LIGHT;
18
 
   if (findModifier(modifiers, "Condensed", &start))