~ressu/+junk/xen-debian

« back to all changes in this revision

Viewing changes to debian/patches/config-prefix.diff

  • Committer: sami at haahtinen
  • Author(s): Bastian Blank
  • Date: 2011-03-17 14:12:45 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: sami@haahtinen.name-20110317141245-owgqox0l0p3g5857
Tags: 4.1.0~rc6-1
* New upstream release candidate.
* Build documentation using pdflatex.
* Use python 2.6. (closes: #596545)
* Fix lintian override.
* Install new tools: xl, xenpaging.
* Enable blktap2.
  - Use own md5 implementation.
  - Fix includes.
  - Fix linking of blktap2 binaries.
  - Remove optimization setting.
* Temporarily disable hvmloader, wants to download ipxe.
* Remove xenstored pid check from xl.

Show diffs side-by-side

added added

removed removed

Lines of Context:
6
6
 INCLUDEDIR = $(PREFIX)/include
7
7
-LIBLEAFDIR = lib
8
8
-LIBLEAFDIR_x86_32 = lib
9
 
-LIBLEAFDIR_x86_64 = lib64
 
9
-LIBLEAFDIR_x86_64 ?= lib64
10
10
-LIBDIR = $(PREFIX)/$(LIBLEAFDIR)
11
11
-LIBDIR_x86_32 = $(PREFIX)/$(LIBLEAFDIR_x86_32)
12
12
-LIBDIR_x86_64 = $(PREFIX)/$(LIBLEAFDIR_x86_64)
24
24
 PRIVATE_BINDIR = $(PRIVATE_PREFIX)/bin
25
25
+PRIVATE_LIBDIR = $(PRIVATE_PREFIX)/lib
26
26
+
 
27
+LIBEXEC = $(PRIVATE_LIBDIR)
27
28
+XENFIRMWAREDIR = $(PRIVATE_PREFIX)/boot
28
 
+LIBEXEC = $(PRIVATE_LIBDIR)
29
29
 
30
30
 ifeq ($(PREFIX),/usr)
31
31
 CONFIG_DIR = /etc
45
45
 LDFLAGS_DIRECT += -melf_x86_64_obsd
46
46
--- a/Config.mk
47
47
+++ b/Config.mk
48
 
@@ -32,14 +32,14 @@
 
48
@@ -49,14 +49,14 @@
49
49
 
50
50
 ifneq ($(EXTRA_PREFIX),)
51
51
 EXTRA_INCLUDES += $(EXTRA_PREFIX)/include