~ressu/+junk/xen-debian

« back to all changes in this revision

Viewing changes to debian/patches/tools-blktap2-libs.patch

  • Committer: sami at haahtinen
  • Author(s): Bastian Blank
  • Date: 2011-03-17 14:12:45 UTC
  • mfrom: (1.1.1 upstream)
  • Revision ID: sami@haahtinen.name-20110317141245-owgqox0l0p3g5857
Tags: 4.1.0~rc6-1
* New upstream release candidate.
* Build documentation using pdflatex.
* Use python 2.6. (closes: #596545)
* Fix lintian override.
* Install new tools: xl, xenpaging.
* Enable blktap2.
  - Use own md5 implementation.
  - Fix includes.
  - Fix linking of blktap2 binaries.
  - Remove optimization setting.
* Temporarily disable hvmloader, wants to download ipxe.
* Remove xenstored pid check from xl.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
--- a/tools/blktap2/Makefile
2
 
+++ b/tools/blktap2/Makefile
3
 
@@ -1,9 +1,6 @@
4
 
 XEN_ROOT = ../..
5
 
 include $(XEN_ROOT)/tools/Rules.mk
6
 
 
7
 
-CFLAGS  += $(CFLAGS_libxenctrl)
8
 
-LDFLAGS += $(LDFLAGS_libxenctrl)
9
 
-
10
 
 SUBDIRS-y :=
11
 
 SUBDIRS-y += include
12
 
 SUBDIRS-y += lvm
13
 
--- a/tools/blktap2/vhd/Makefile
14
 
+++ b/tools/blktap2/vhd/Makefile
15
 
@@ -12,6 +12,7 @@
16
 
 CFLAGS            += -Wno-unused
17
 
 CFLAGS            += -I../include
18
 
 CFLAGS            += -D_GNU_SOURCE
19
 
+CFLAGS  += $(CFLAGS_libxenctrl)
20
 
 
21
 
 ifeq ($(CONFIG_X86_64),y)
22
 
 CFLAGS            += -fPIC
23
 
--- a/tools/blktap2/vhd/lib/Makefile
24
 
+++ b/tools/blktap2/vhd/lib/Makefile
25
 
@@ -16,10 +16,12 @@
26
 
 CFLAGS          += -D_GNU_SOURCE
27
 
 CFLAGS          += -fPIC
28
 
 CFLAGS          += -g
29
 
+CFLAGS  += $(CFLAGS_libxenctrl)
30
 
 
31
 
 ifeq ($(CONFIG_Linux),y)
32
 
 LIBS            := -luuid
33
 
 endif
34
 
+LDFLAGS += $(LDFLAGS_libxenctrl)
35
 
 
36
 
 # Get gcc to generate the dependencies for us.
37
 
 CFLAGS          += -Wp,-MD,.$(@F).d