~saiarcot895/ubuntu/trusty/openscenegraph/armhf-support

« back to all changes in this revision

Viewing changes to debian/patches/bug-580081-change-openthreads-version.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Alberto Luaces
  • Date: 2010-05-03 21:42:01 UTC
  • mfrom: (1.1.9 upstream) (2.1.11 sid)
  • Revision ID: james.westby@ubuntu.com-20100503214201-iy060qxb94vsfv87
Tags: 2.8.3-3
* Added README.source. Thanks Manuel Montecelo.
* Removed FindGDAL.cmake file supplied by upstream since it does not
  detect current libgdal1-1.6.0. The script provided by CMake works
  fine.
* Removed openthreads-doc since OpenThreads documentation is shared with
  OpenSceneGraph's, hence this package was empty.
* Now ccache handling is being done automatically by CMake.
* Drop conflict dependencies with previous versions to let them coexist
  with current ones (Closes: #580079 #580081).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## bug-580081-change-openthreads-version.dpatch by  <alberto@negro>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: No description.
 
6
 
 
7
@DPATCH@
 
8
diff -urNad '--exclude=CVS' '--exclude=.svn' '--exclude=.git' '--exclude=.arch' '--exclude=.hg' '--exclude=_darcs' '--exclude=.bzr' openscenegraph-2.8.3~/OpenSceneGraph/src/OpenThreads/CMakeLists.txt openscenegraph-2.8.3/OpenSceneGraph/src/OpenThreads/CMakeLists.txt
 
9
--- openscenegraph-2.8.3~/OpenSceneGraph/src/OpenThreads/CMakeLists.txt 2010-05-03 22:02:52.000000000 +0200
 
10
+++ openscenegraph-2.8.3/OpenSceneGraph/src/OpenThreads/CMakeLists.txt  2010-05-03 22:03:02.000000000 +0200
 
11
@@ -4,7 +4,7 @@
 
12
 
 
13
 SET(OPENTHREADS_MAJOR_VERSION 2)
 
14
 SET(OPENTHREADS_MINOR_VERSION 4)
 
15
-SET(OPENTHREADS_PATCH_VERSION 0)
 
16
+SET(OPENTHREADS_PATCH_VERSION 1)
 
17
 IF(NOT OPENTHREADS_SOVERSION)
 
18
     SET(OPENTHREADS_SOVERSION 11)
 
19
 ENDIF (NOT OPENTHREADS_SOVERSION)