~showard314/ubuntu/utopic/qtiplot/utopic_1311721

« back to all changes in this revision

Viewing changes to debian/patches/03_build_conf.patch

  • Committer: Bazaar Package Importer
  • Author(s): Scott Howard
  • Date: 2011-05-07 17:00:26 UTC
  • mfrom: (1.1.9 upstream) (2.1.10 sid)
  • Revision ID: james.westby@ubuntu.com-20110507170026-77wvcv8uc6955fff
* moved debian/build.conf into debian/patches/03_build_conf.patch
  to track changes to build.conf between releases. Updated
  debian/rules accordingly.
* New upstream release. (Closes: #599450)
* Refreshed patches.
* debian/control B-D on libalglib-dev, libtamuanova-dev,
  libqtexengine-dev
* debian/rules allows for parallel builds
* Byte compile python modules with dh_python2, removed debian/*.post{rm,inst}
  dropped dependency on depricated python-central (Closes: #587669)
* Added shared-mime-info xml data in debian/qtiplot.sharedmimeinfo
  (LP: #184307)
* 04_qwtplot3d_static.patch added to build a modified static
  library of qwt3dplot
* 05_link_gl2ps.patch added to use Debian gl2ps library.
* Policy 3.9.2, no changes

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Edits build.conf to look for Debian system libraries.
 
2
Author: Scott Howard <showard@debian.org>
 
3
Index: qtiplot/build.conf.example
 
4
===================================================================
 
5
--- qtiplot.orig/build.conf.example     2011-05-02 08:48:46.813181092 -0400
 
6
+++ qtiplot/build.conf.example  2011-05-02 09:45:00.371115371 -0400
 
7
@@ -7,39 +7,39 @@
 
8
 ##########################################################
 
9
 
 
10
 # Global include path which is always added at the end of the INCLUDEPATH
 
11
-SYS_INCLUDEPATH = /opt/local/include
 
12
+SYS_INCLUDEPATH = /usr/include
 
13
 # Global lib path and libs which is ls always added at the end of LIBS
 
14
-SYS_LIBS = -L/opt/local/lib
 
15
+SYS_LIBS = -L/usr/lib
 
16
 
 
17
 ##########################################################
 
18
 ## zlib (http://www.zlib.net/)
 
19
 ##########################################################
 
20
 
 
21
 # include path. leave it blank to use SYS_INCLUDE
 
22
-ZLIB_INCLUDEPATH = $$QTI_ROOT/3rdparty/zlib/
 
23
+#ZLIB_INCLUDEPATH = $$QTI_ROOT/3rdparty/zlib/
 
24
 
 
25
 ##########################################################
 
26
 ## muParser (http://muparser.sourceforge.net/)
 
27
 ##########################################################
 
28
 
 
29
 # include path. leave it blank to use SYS_INCLUDE
 
30
-MUPARSER_INCLUDEPATH = $$QTI_ROOT/3rdparty/muparser/include
 
31
+MUPARSER_INCLUDEPATH = /usr/include/muParser
 
32
 # link statically against a copy in 3rdparty/
 
33
-MUPARSER_LIBS = $$QTI_ROOT/3rdparty/muparser/lib/libmuparser.a
 
34
+#MUPARSER_LIBS = $$QTI_ROOT/3rdparty/muparser/lib/libmuparser.a
 
35
 # or dynamically against a system-wide installation
 
36
-#MUPARSER_LIBS = -lmuparser
 
37
+MUPARSER_LIBS = -lmuparser
 
38
 
 
39
 ##########################################################
 
40
 ## GNU Sientific Library (http://www.gnu.org/software/gsl/)
 
41
 ##########################################################
 
42
 
 
43
 # include path. leave it blank to use SYS_INCLUDE
 
44
-GSL_INCLUDEPATH = $$QTI_ROOT/3rdparty/gsl/include
 
45
+#GSL_INCLUDEPATH = $$QTI_ROOT/3rdparty/gsl/include
 
46
 # link statically against a copy in 3rdparty/
 
47
-GSL_LIBS = $$QTI_ROOT/3rdparty/gsl/lib/libgsl.a \
 
48
-           $$QTI_ROOT/3rdparty/gsl/lib/libgslcblas.a
 
49
+#GSL_LIBS = $$QTI_ROOT/3rdparty/gsl/lib/libgsl.a \
 
50
+#           $$QTI_ROOT/3rdparty/gsl/lib/libgslcblas.a
 
51
 # or dynamically against a system-wide installation
 
52
-#GSL_LIBS = -lgsl -lgslcblas
 
53
+GSL_LIBS = -lgsl -lgslcblas
 
54
 
 
55
 ##########################################################
 
56
 ## QWT - use local copy till upstream catches up
 
57
@@ -67,11 +67,11 @@
 
58
 ##########################################################
 
59
 
 
60
 # include path. leave it blank to use SYS_INCLUDE
 
61
-LIBPNG_INCLUDEPATH = $$QTI_ROOT/3rdparty/libpng/
 
62
+#LIBPNG_INCLUDEPATH = $$QTI_ROOT/3rdparty/libpng/
 
63
 # link statically against a copy in 3rdparty/
 
64
-LIBPNG_LIBS = $$QTI_ROOT/3rdparty/libpng/libpng.a
 
65
+#LIBPNG_LIBS = $$QTI_ROOT/3rdparty/libpng/libpng.a
 
66
 # or dynamically against a system-wide installation
 
67
-#LIBPNG_LIBS = -lpng
 
68
+LIBPNG_LIBS = -lpng
 
69
 
 
70
 ##########################################################
 
71
 ## QTeXEngine - optional. you don't have to set these variables
 
72
@@ -79,9 +79,9 @@
 
73
 ##########################################################
 
74
 
 
75
 # include path.
 
76
-TEX_ENGINE_INCLUDEPATH = $$QTI_ROOT/3rdparty/QTeXEngine/src
 
77
+#TEX_ENGINE_INCLUDEPATH = $$QTI_ROOT/3rdparty/QTeXEngine/src
 
78
 # link locally against a copy in 3rdparty/
 
79
-TEX_ENGINE_LIBS = $$QTI_ROOT/3rdparty/QTeXEngine/libQTeXEngine.a
 
80
+TEX_ENGINE_LIBS = -lQTeXEngine
 
81
 
 
82
 ##########################################################
 
83
 ## ALGLIB (2.6) - optional. you don't have to set these variables
 
84
@@ -89,9 +89,9 @@
 
85
 ##########################################################
 
86
 
 
87
 # include path.
 
88
-ALGLIB_INCLUDEPATH = $$QTI_ROOT/3rdparty/alglib/
 
89
+#ALGLIB_INCLUDEPATH = $$QTI_ROOT/3rdparty/alglib/
 
90
 # link locally against a copy in 3rdparty/
 
91
-ALGLIB_LIBS = $$QTI_ROOT/3rdparty/alglib/libalglib.a
 
92
+ALGLIB_LIBS = -lalglib
 
93
 
 
94
 ##########################################################
 
95
 ## TAMUANOVA - optional. you don't have to set these variables
 
96
@@ -99,9 +99,9 @@
 
97
 ##########################################################
 
98
 
 
99
 # include path.
 
100
-TAMUANOVA_INCLUDEPATH = $$QTI_ROOT/3rdparty/tamu_anova/
 
101
+TAMUANOVA_INCLUDEPATH = /usr/include/tamu_anova/
 
102
 # link locally against a copy in 3rdparty/
 
103
-TAMUANOVA_LIBS = $$QTI_ROOT/3rdparty/tamu_anova/libtamuanova.a
 
104
+TAMUANOVA_LIBS = -ltamuanova
 
105
 
 
106
 ##########################################################
 
107
 ## python - only used if python is needed
 
108
@@ -134,7 +134,7 @@
 
109
   #DEFINES         += QTIPLOT_DEMO
 
110
 
 
111
   # Uncomment the following line if you want to perform a custom installation using the *.path variables defined in ./qtiplot.pro.
 
112
-  #CONFIG          += CustomInstall
 
113
+  CONFIG          += CustomInstall
 
114
 
 
115
   # Uncomment the following line if you want to build QtiPlot as a browser plugin (not working on Internet Explorer).
 
116
   #CONFIG          += BrowserPlugin