~statik/ubuntu/maverick/erlang/erlang-merge-testing

« back to all changes in this revision

Viewing changes to debian/patches/docs.patch

  • Committer: Elliot Murphy
  • Date: 2010-06-08 03:55:44 UTC
  • mfrom: (3.5.6 squeeze)
  • Revision ID: elliot@elliotmurphy.com-20100608035544-dd8zh2swk7jr5rz2
* Merge with Debian unstable; remaining Ubuntu changes:
  - Drop libwxgtk2.8-dev build dependency. Wx isn't in main, and not
    supposed to. (LP #438365)
  - Drop erlang-wx binary.
  - Drop erlang-wx dependency from -megaco, -common-test, and -reltool, they
    do not really need wx. Also drop it from -debugger; the GUI needs wx,
    but it apparently has CLI bits as well, and is also needed by -megaco,
    so let's keep the package for now.
* Added missing symlinks to /usr/include for a few new header files.
* Fixed generation of ${erlang-base:Depends} and ${erlang-x11:Depends}
  substitution variables.
* Added a fix for a re:compile/2 crash on a long regular expression.
* Changed urgency to medium as the change fixes a security bug.
* Manpages in section 1 are needed even if only arch-dependent packages are
  built. So, re-enabled them.
* Fixed HiPE architecture recognition for powerpc Debian architecture.
* Moved xsltproc and fop to build-depends-indep and do not build
  documentation if only architecture-specific packages are built.
* Refreshed all patches.
* Made Emacs look in man5 and man7 for Erlang manpages and added code
  skeleton files to erlang-mode package.
* New upstream release.
* Moved manpages from incorrect sections 4 and 6 to correct 5 and 7
  (closes: #498492).
* Made manpages regexp in Emacs mode match only 3erl pages in section 3.
* Removed docb_gen script which is no longer needed to build manpages.
* Added erlang-doc package which contains documentation in HTML and PDF
  formats. This package replaces erlang-doc-html package and it's easier
  to synchronize it with the main Erlang packages as it's built from
  a single source package (closes: #558451).
* Removed RPATH from ssl and crypto application binaries as required by
  Debian policy.
* Added libwxgtk2.4-dev and libwxgtk2.6-dev to build conflicts.
* Added a few dpendencies for erlang-dialyzer, erlang-et, erlang-observer
  and erlang-examples packages which now call functions from more modules
  than in 1:13.b.3.
* Added a workaround which disables vfork() for hppa architecture
  (closes: #562218).
* Strictened check for JDK 1.5 adding a call to String(int[], int, int)
  because GCJ 4.4 doesn't implement it and OpenJDK isn't available for all
  architectures.
* Fixed erlang-manpages package section.
* Made erlang-depends add only substvars which are requested in
  debian/control file. This minimizes number of warnings from dh_gencontrol.
  Also, improved descriptions of the functions in erlang-depends escript.
* Added erlang-erl-docgen package to erlang-nox dependencies.
* Made dummy packages erlang-nox and erlang-x11 architecture all.
* Cleaned up working with custom substitution variables in debian/rules.
* Reorganized debian/rules to ensure that manpages arent built twice, and
  aren't built at all if only architecture-dependent packages are requested.
* Fixed project links in README.Debian.
* Added a new package erlang-jinterface which provides tools for
  communication of Java programs with Erlang processes. This adds build
  depandency on default-jdk and as a result enables Java module for IDL
  compiler.
* Bumped standards version to 3.8.4.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Patch by sergei Golovan fixes several bugs with . and ' at the
2
 
beginning of a line in Erlang manpages. It simply escapes all dots
3
 
and apostrophes by adding \& before them. Also, it fixes whatis entries
4
 
for module and application definitions.
 
1
Author: Sergei Golovan <sgolovan@debian.org>
 
2
Description: Fixes a bug with .RE macro in the Erlang manpages.
 
3
Last-modified:Sat, 27 Feb 2010 09:35:21 +0300
5
4
 
6
 
--- erlang-13.b.3-dfsg.orig/lib/erl_docgen/priv/xsl/db_man.xsl
7
 
+++ erlang-13.b.3-dfsg/lib/erl_docgen/priv/xsl/db_man.xsl
8
 
@@ -192,7 +192,7 @@
9
 
   <!-- Erlref -->
10
 
   <xsl:template match="/erlref">
11
 
       <xsl:text>.TH </xsl:text><xsl:value-of select="module"/><xsl:text> 3 "</xsl:text><xsl:value-of select="$appname"/><xsl:text> </xsl:text><xsl:value-of select="$appver"/><xsl:text>" "Ericsson AB" "Erlang Module Definition"&#10;</xsl:text>
12
 
-      <xsl:text>.SH MODULE&#10;</xsl:text>
13
 
+      <xsl:text>.SH NAME&#10;</xsl:text>
14
 
       <xsl:value-of select="module"/><xsl:text> \- </xsl:text><xsl:value-of select="modulesummary"/><xsl:text>&#10;</xsl:text>  
15
 
       <xsl:apply-templates/>
16
 
   </xsl:template>
17
 
@@ -225,7 +225,7 @@
18
 
   <xsl:template match="/appref">
19
 
       <xsl:text>.TH </xsl:text><xsl:value-of select="app"/><xsl:text> 6 "</xsl:text><xsl:value-of select="$appname"/><xsl:text> </xsl:text><xsl:value-of select="$appver"/><xsl:text>" "Ericsson AB" "Erlang Application Definition"&#10;</xsl:text>
20
 
       <xsl:text>.SH NAME&#10;</xsl:text>
21
 
-      <xsl:value-of select="file"/><xsl:text> \- </xsl:text><xsl:value-of select="filesummary"/><xsl:text>&#10;</xsl:text>  
22
 
+      <xsl:value-of select="app"/><xsl:text> \- </xsl:text><xsl:value-of select="appsummary"/><xsl:text>&#10;</xsl:text>  
23
 
       <xsl:apply-templates/>
 
5
--- erlang-13.b.4-dfsg.orig/lib/erl_docgen/priv/xsl/db_man.xsl
 
6
+++ erlang-13.b.4-dfsg/lib/erl_docgen/priv/xsl/db_man.xsl
 
7
@@ -53,7 +53,7 @@
 
8
   <xsl:template match="list">
 
9
     <xsl:text>&#10;.RS 2</xsl:text>
 
10
     <xsl:apply-templates/>
 
11
-    <xsl:text>&#10;.RE</xsl:text>
 
12
+    <xsl:text>&#10;.RE&#10;</xsl:text>
24
13
   </xsl:template>
25
14
 
26
 
@@ -268,7 +268,7 @@
 
15
   <xsl:template match="list/item">
 
16
@@ -66,7 +66,7 @@
 
17
   <xsl:template match="taglist">
 
18
     <xsl:text>&#10;.RS 2</xsl:text>
 
19
     <xsl:apply-templates select="tag|item"/>
 
20
-    <xsl:text>&#10;.RE</xsl:text>
 
21
+    <xsl:text>&#10;.RE&#10;</xsl:text>
 
22
   </xsl:template>
 
23
   
 
24
   <xsl:template match="taglist/tag">
 
25
@@ -91,7 +91,7 @@
 
26
         <xsl:text>&#10;.RS 2</xsl:text>     
 
27
         <xsl:text>&#10;.LP&#10;&#10;.LP&#10;</xsl:text>     
 
28
         <xsl:value-of select="$content"/>
 
29
-        <xsl:text>&#10;.RE</xsl:text>     
 
30
+        <xsl:text>&#10;.RE&#10;</xsl:text>     
 
31
       </xsl:otherwise>
 
32
     </xsl:choose>
 
33
   </xsl:template>
 
34
@@ -287,7 +287,7 @@
27
35
     <xsl:text>&#10;.TP</xsl:text>
28
36
     <xsl:text>&#10;Types</xsl:text>
29
37
     <xsl:apply-templates/>
30
38
-    <xsl:text>&#10;.RE</xsl:text>
31
 
+    <xsl:text>&#10;.RE </xsl:text>
 
39
+    <xsl:text>&#10;.RE&#10;</xsl:text>
32
40
   </xsl:template>
33
41
 
34
42
 
35
 
@@ -288,7 +288,7 @@
 
43
@@ -307,7 +307,7 @@
36
44
   <xsl:template match="desc">
37
45
     <xsl:text>&#10;.RS</xsl:text>
38
46
     <xsl:apply-templates/>
39
47
-    <xsl:text>&#10;.RE</xsl:text>
40
 
+    <xsl:text>&#10;.RE </xsl:text>
41
 
   </xsl:template>
42
 
 
43
 
 
44
 
@@ -305,4 +305,60 @@
45
 
     <xsl:value-of select="normalize-space()"/>
46
 
   </xsl:template>
47
 
 
48
 
+  <!-- Authors -->
49
 
+  <xsl:template match="authors">
50
 
+    <xsl:text>&#10;.SH AUTHORS</xsl:text>
51
 
+    <xsl:apply-templates/>
52
 
+  </xsl:template>
53
 
+
54
 
+  <!-- Aname -->
55
 
+  <xsl:template match="authors/aname">
56
 
+    <xsl:text>&#10;.LP&#10;</xsl:text>
57
 
+    <xsl:apply-templates/>
58
 
+  </xsl:template>
59
 
+
60
 
+  <!-- Email -->
61
 
+  <xsl:template match="authors/email">
62
 
+    <xsl:text>&#10;.I&#10;&lt;</xsl:text>
63
 
+    <xsl:apply-templates/>
64
 
+    <xsl:text>&gt;</xsl:text>
65
 
+  </xsl:template>
66
 
+
67
 
+  <!-- Replace ' by \&' ans . by \&. -->
68
 
+  <xsl:template match="text()">
69
 
+    <xsl:variable name="rep1">
70
 
+      <xsl:call-template name="replace-string">
71
 
+        <xsl:with-param name="text" select="." />
72
 
+        <xsl:with-param name="replace" select="&quot;&apos;&quot;" />
73
 
+        <xsl:with-param name="with" select="&quot;\&amp;&apos;&quot;" />
74
 
+      </xsl:call-template>
75
 
+    </xsl:variable>
76
 
+    <xsl:call-template name="replace-string">
77
 
+      <xsl:with-param name="text" select="$rep1" />
78
 
+      <xsl:with-param name="replace" select="&quot;.&quot;" />
79
 
+      <xsl:with-param name="with" select="&quot;\&amp;.&quot;" />
80
 
+    </xsl:call-template>
81
 
+  </xsl:template>
82
 
+
83
 
+  <!-- Template replace-string is borrowed at http://www.dpawson.co.uk/xsl/sect2/replace.html -->
84
 
+  <xsl:template name="replace-string">
85
 
+    <xsl:param name="text"/>
86
 
+    <xsl:param name="replace"/>
87
 
+    <xsl:param name="with"/>
88
 
+    <xsl:choose>
89
 
+      <xsl:when test="contains($text,$replace)">
90
 
+        <xsl:value-of select="substring-before($text,$replace)"/>
91
 
+        <xsl:value-of select="$with"/>
92
 
+        <xsl:call-template name="replace-string">
93
 
+          <xsl:with-param name="text" select="substring-after($text,$replace)"/>
94
 
+          <xsl:with-param name="replace" select="$replace"/>
95
 
+          <xsl:with-param name="with" select="$with"/>
96
 
+        </xsl:call-template>
97
 
+      </xsl:when>
98
 
+      <xsl:otherwise>
99
 
+        <xsl:value-of select="$text"/>
100
 
+      </xsl:otherwise>
101
 
+    </xsl:choose>
102
 
+  </xsl:template>
103
 
+
104
 
 </xsl:stylesheet>
105
 
--- erlang-13.b.3-dfsg.orig/lib/stdlib/doc/src/re.xml
106
 
+++ erlang-13.b.3-dfsg/lib/stdlib/doc/src/re.xml
 
48
+    <xsl:text>&#10;.RE&#10;</xsl:text>
 
49
   </xsl:template>
 
50
 
 
51
 
 
52
--- erlang-13.b.4-dfsg.orig/lib/megaco/doc/src/Makefile
 
53
+++ erlang-13.b.4-dfsg/lib/megaco/doc/src/Makefile
 
54
@@ -241,8 +241,6 @@
 
55
        $(INSTALL_DATA) $(INFO_FILE) $(RELSYSDIR)
 
56
        $(INSTALL_DIR) $(RELEASE_PATH)/man/man3
 
57
        $(INSTALL_DATA) $(MAN3DIR)/* $(RELEASE_PATH)/man/man3
 
58
-       $(INSTALL_DIR)  $(RELSYSDIR)/doc/standard
 
59
-       $(INSTALL_DATA) $(STANDARDS) $(RELSYSDIR)/doc/standard
 
60
 
 
61
 else
 
62
 
 
63
@@ -264,8 +262,6 @@
 
64
        $(INSTALL_DIR)  $(RELEASE_PATH)/man/man3
 
65
        $(INSTALL_DATA) $(MAN3_FILES) $(RELEASE_PATH)/man/man3
 
66
        $(INSTALL_DATA) $(TOP_HTML_FILES) $(RELSYSDIR)/doc
 
67
-       $(INSTALL_DIR)  $(RELSYSDIR)/doc/standard
 
68
-       $(INSTALL_DATA) $(STANDARDS) $(RELSYSDIR)/doc/standard
 
69
 endif
 
70
 endif
 
71
 
 
72
--- erlang-13.b.4-dfsg.orig/lib/stdlib/doc/src/re.xml
 
73
+++ erlang-13.b.4-dfsg/lib/stdlib/doc/src/re.xml
107
74
@@ -349,7 +349,7 @@
108
75
       metacharacter should not match before it. Setting this without
109
76
       <c>multiline</c> (at compile time) causes circumflex never to