~statik/ubuntu/maverick/erlang/erlang-merge-testing

« back to all changes in this revision

Viewing changes to debian/patches/gnu.patch

  • Committer: Elliot Murphy
  • Date: 2010-06-08 03:55:44 UTC
  • mfrom: (3.5.6 squeeze)
  • Revision ID: elliot@elliotmurphy.com-20100608035544-dd8zh2swk7jr5rz2
* Merge with Debian unstable; remaining Ubuntu changes:
  - Drop libwxgtk2.8-dev build dependency. Wx isn't in main, and not
    supposed to. (LP #438365)
  - Drop erlang-wx binary.
  - Drop erlang-wx dependency from -megaco, -common-test, and -reltool, they
    do not really need wx. Also drop it from -debugger; the GUI needs wx,
    but it apparently has CLI bits as well, and is also needed by -megaco,
    so let's keep the package for now.
* Added missing symlinks to /usr/include for a few new header files.
* Fixed generation of ${erlang-base:Depends} and ${erlang-x11:Depends}
  substitution variables.
* Added a fix for a re:compile/2 crash on a long regular expression.
* Changed urgency to medium as the change fixes a security bug.
* Manpages in section 1 are needed even if only arch-dependent packages are
  built. So, re-enabled them.
* Fixed HiPE architecture recognition for powerpc Debian architecture.
* Moved xsltproc and fop to build-depends-indep and do not build
  documentation if only architecture-specific packages are built.
* Refreshed all patches.
* Made Emacs look in man5 and man7 for Erlang manpages and added code
  skeleton files to erlang-mode package.
* New upstream release.
* Moved manpages from incorrect sections 4 and 6 to correct 5 and 7
  (closes: #498492).
* Made manpages regexp in Emacs mode match only 3erl pages in section 3.
* Removed docb_gen script which is no longer needed to build manpages.
* Added erlang-doc package which contains documentation in HTML and PDF
  formats. This package replaces erlang-doc-html package and it's easier
  to synchronize it with the main Erlang packages as it's built from
  a single source package (closes: #558451).
* Removed RPATH from ssl and crypto application binaries as required by
  Debian policy.
* Added libwxgtk2.4-dev and libwxgtk2.6-dev to build conflicts.
* Added a few dpendencies for erlang-dialyzer, erlang-et, erlang-observer
  and erlang-examples packages which now call functions from more modules
  than in 1:13.b.3.
* Added a workaround which disables vfork() for hppa architecture
  (closes: #562218).
* Strictened check for JDK 1.5 adding a call to String(int[], int, int)
  because GCJ 4.4 doesn't implement it and OpenJDK isn't available for all
  architectures.
* Fixed erlang-manpages package section.
* Made erlang-depends add only substvars which are requested in
  debian/control file. This minimizes number of warnings from dh_gencontrol.
  Also, improved descriptions of the functions in erlang-depends escript.
* Added erlang-erl-docgen package to erlang-nox dependencies.
* Made dummy packages erlang-nox and erlang-x11 architecture all.
* Cleaned up working with custom substitution variables in debian/rules.
* Reorganized debian/rules to ensure that manpages arent built twice, and
  aren't built at all if only architecture-dependent packages are requested.
* Fixed project links in README.Debian.
* Added a new package erlang-jinterface which provides tools for
  communication of Java programs with Erlang processes. This adds build
  depandency on default-jdk and as a result enables Java module for IDL
  compiler.
* Bumped standards version to 3.8.4.

Show diffs side-by-side

added added

removed removed

Lines of Context:
10
10
 
11
11
(4) Skips building SSL certificate examples for GNU/Hurd (Debian GNU/Hurd has
12
12
    no a random translator yet).
13
 
--- erlang-13.b.3-dfsg.orig/erts/configure.in
14
 
+++ erlang-13.b.3-dfsg/erts/configure.in
15
 
@@ -339,7 +339,7 @@
 
13
--- erlang-13.b.4-dfsg.orig/erts/configure.in
 
14
+++ erlang-13.b.4-dfsg/erts/configure.in
 
15
@@ -377,7 +377,7 @@
16
16
 
17
17
 dnl NOTE: CPPFLAGS will be included in CFLAGS at the end
18
18
 case $host_os in
21
21
     win32)
22
22
        # The ethread library requires _WIN32_WINNT of at least 0x0403.
23
23
        # -D_WIN32_WINNT=* from CPPFLAGS is saved in ETHR_DEFS.
24
 
@@ -996,7 +996,7 @@
 
24
@@ -1119,7 +1119,7 @@
25
25
            solaris*)
26
26
                enable_child_waiter_thread=yes
27
27
                ;;
30
30
                AC_DEFINE(USE_RECURSIVE_MALLOC_MUTEX,[1],
31
31
                        [Define if malloc should use a recursive mutex])
32
32
                AC_MSG_CHECKING([whether dlopen() needs to be called before first call to dlerror()])
33
 
--- erlang-13.b.3-dfsg.orig/lib/common_test/Makefile
34
 
+++ erlang-13.b.3-dfsg/lib/common_test/Makefile
 
33
--- erlang-13.b.4-dfsg.orig/lib/common_test/Makefile
 
34
+++ erlang-13.b.4-dfsg/lib/common_test/Makefile
35
35
@@ -30,9 +30,13 @@
36
36
 ifeq ($(findstring solaris,$(TARGET)),solaris)
37
37
 SUB_DIRECTORIES = doc/src src priv
46
46
 
47
47
 include vsn.mk
48
48
 VSN = $(COMMON_TEST_VSN)
49
 
--- erlang-13.b.3-dfsg.orig/lib/common_test/priv/Makefile.in
50
 
+++ erlang-13.b.3-dfsg/lib/common_test/priv/Makefile.in
 
49
--- erlang-13.b.4-dfsg.orig/lib/common_test/priv/Makefile.in
 
50
+++ erlang-13.b.4-dfsg/lib/common_test/priv/Makefile.in
51
51
@@ -43,9 +43,13 @@
52
52
 ifeq ($(findstring solaris,$(TARGET)),solaris)
53
53
 XNIX = true
62
62
 
63
63
 ifneq ($(findstring win32,$(TARGET)),win32)
64
64
 
65
 
--- erlang-13.b.3-dfsg.orig/lib/os_mon/c_src/memsup.c
66
 
+++ erlang-13.b.3-dfsg/lib/os_mon/c_src/memsup.c
 
65
--- erlang-13.b.4-dfsg.orig/lib/os_mon/c_src/memsup.c
 
66
+++ erlang-13.b.4-dfsg/lib/os_mon/c_src/memsup.c
67
67
@@ -110,6 +110,11 @@
68
68
 #include <memLib.h>
69
69
 #endif
76
76
 #ifdef BSD4_4
77
77
 #include <sys/types.h>
78
78
 #include <sys/sysctl.h>
79
 
--- erlang-13.b.3-dfsg.orig/lib/ssl/Makefile
80
 
+++ erlang-13.b.3-dfsg/lib/ssl/Makefile
 
79
--- erlang-13.b.4-dfsg.orig/lib/ssl/Makefile
 
80
+++ erlang-13.b.4-dfsg/lib/ssl/Makefile
81
81
@@ -32,8 +32,15 @@
82
82
 SKIP_BUILDING_BINARIES := true
83
83
 endif