~ubuntu-branches/debian/experimental/nzbget/experimental

« back to all changes in this revision

Viewing changes to debian/patches/ac_lang_source.patch

  • Committer: Package Import Robot
  • Author(s): Andreas Moog
  • Date: 2013-07-18 14:50:28 UTC
  • mfrom: (1.1.1)
  • Revision ID: package-import@ubuntu.com-20130718145028-qhxse81w1sj5w424
Tags: 11.0+dfsg-1
* New upstream release (Closes: #701896)
* Repackage original tarball to remove copies of jquery and twitter-
  bootstrap
* debian/watch: Update for new versioning scheme
* debian/patches: Remove all old patches, add one patch:
  - dont-embed-libraries.patch: Don't install embedded jquery and bootstrap 
    libraries
* debian/combat: Upgrade to debhelper combat 9
* debian/control:
  - Fix Vcs-Git field
  - Adjust debhelper version for combat level 9
  - Add jquery and bootstrap to depends for integrated webserver
  - Add python to recommends for post-processing scripts
  - Bump build-depends on libpar2-dev to support the cancel function
* debian/links:
  - Use the system jquery and bootstrap libraries
* debian/rules:
  - Add get-orig-source target to build modified upstream tarball
* Adjust sample nzbget.conf:
  - Only listen to 127.0.0.1 instead of 0.0.0.0
  - Use nzbget.conf as template for webui configuration
* Adjust sample nzbgetd init file:
  - Point to correct location of nzbget binary

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: http://git.savannah.gnu.org/gitweb/?p=autoconf.git;a=commitdiff;h=1e604ecfb2d49e6073c445623d894e9709e91b35
2
 
 introduced a check wheter AC_LANG_SOURCE/AC_LANG_PROGRAM have been called 
3
 
 correctly, this ensures that the generated conftest has all necessary
4
 
 definitions for it's programming language.
5
 
Author: Andreas Moog <amoog@ubuntu.com>
6
 
Forwarded: https://sourceforge.net/tracker.php?aid=3368041
7
 
Last-Update: 2011-07-15
8
 
 
9
 
--- nzbget-0.7.0.orig/configure.ac
10
 
+++ nzbget-0.7.0/configure.ac
11
 
@@ -502,14 +502,14 @@ dnl
12
 
 dnl variadic macros
13
 
 dnl 
14
 
 AC_MSG_CHECKING(for variadic macros)
15
 
-AC_COMPILE_IFELSE([
16
 
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([
17
 
        #define macro(...)   macrofunc(__VA_ARGS__)
18
 
        int macrofunc(int a, int b) { return a + b; }
19
 
        int test() { return macro(1, 2); }
20
 
        ],
21
 
        AC_MSG_RESULT([yes])
22
 
        AC_DEFINE([HAVE_VARIADIC_MACROS], 1, Define to 1 if variadic macros are supported),
23
 
-       AC_MSG_RESULT([no]))
24
 
+       AC_MSG_RESULT([no]))])
25
 
 
26
 
 
27
 
 dnl