~ubuntu-branches/debian/experimental/nzbget/experimental

« back to all changes in this revision

Viewing changes to debian/patches/link-order.patch

  • Committer: Package Import Robot
  • Author(s): Andreas Moog
  • Date: 2013-07-18 14:50:28 UTC
  • mfrom: (1.1.1)
  • Revision ID: package-import@ubuntu.com-20130718145028-qhxse81w1sj5w424
Tags: 11.0+dfsg-1
* New upstream release (Closes: #701896)
* Repackage original tarball to remove copies of jquery and twitter-
  bootstrap
* debian/watch: Update for new versioning scheme
* debian/patches: Remove all old patches, add one patch:
  - dont-embed-libraries.patch: Don't install embedded jquery and bootstrap 
    libraries
* debian/combat: Upgrade to debhelper combat 9
* debian/control:
  - Fix Vcs-Git field
  - Adjust debhelper version for combat level 9
  - Add jquery and bootstrap to depends for integrated webserver
  - Add python to recommends for post-processing scripts
  - Bump build-depends on libpar2-dev to support the cancel function
* debian/links:
  - Use the system jquery and bootstrap libraries
* debian/rules:
  - Add get-orig-source target to build modified upstream tarball
* Adjust sample nzbget.conf:
  - Only listen to 127.0.0.1 instead of 0.0.0.0
  - Use nzbget.conf as template for webui configuration
* Adjust sample nzbgetd init file:
  - Point to correct location of nzbget binary

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Description: Put Libraries into LDADD instead of LDFLAGS, this fixes an
2
 
 issue with ld --as-needed.
3
 
Author: Andreas Moog <amoog@ubuntu.com>
4
 
Forwarded: http://sourceforge.net/support/tracker.php?aid=3298386
5
 
Last-Update: 2011-07-13
6
 
 
7
 
--- nzbget-0.7.0.orig/configure.ac
8
 
+++ nzbget-0.7.0/configure.ac
9
 
@@ -204,7 +204,8 @@ AC_ARG_WITH(libxml2_libraries,
10
 
        [LIBVAL="no"])
11
 
 if test "$INCVAL" = "no" -o "$LIBVAL" = "no"; then
12
 
        PKG_CHECK_MODULES(libxml2, libxml-2.0,
13
 
-               [LDFLAGS="${LDFLAGS} $libxml2_LIBS"]
14
 
+               [LDFLAGS="${LDFLAGS}"]
15
 
+               [nzbget_LDADD="${nzbget_LDADD} $libxml2_LIBS"]
16
 
                [CPPFLAGS="${CPPFLAGS} $libxml2_CFLAGS"]
17
 
                [CFLAGS="${CFLAGS} $libxml2_CFLAGS"])
18
 
 fi
19
 
@@ -290,7 +291,8 @@ if test "$ENABLEPARCHECK" = "yes"; then
20
 
                [LIBVAL="no"])
21
 
        if test "$INCVAL" = "no" -o "$LIBVAL" = "no"; then
22
 
                PKG_CHECK_MODULES(libsigc, sigc++-2.0,
23
 
-                       [LDFLAGS="${LDFLAGS} $libsigc_LIBS"]
24
 
+                       [LDFLAGS="${LDFLAGS}"]
25
 
+                       [nzbget_LDADD="${nzbget_LDADD} $libsigc_LIBS"]
26
 
                        [CPPFLAGS="${CPPFLAGS} $libsigc_CFLAGS"])
27
 
        fi
28
 
        
29
 
@@ -549,6 +551,7 @@ dnl Substitute flags.
30
 
 AC_SUBST(CFLAGS)
31
 
 AC_SUBST(CPPFLAGS)
32
 
 AC_SUBST(LDFLAGS)
33
 
+AC_SUBST(nzbget_LDADD)
34
 
 AC_SUBST(CXXFLAGS)
35
 
 AC_SUBST(TAR)
36
 
 AC_SUBST(AR)