~ubuntu-branches/debian/jessie/ufsutils/jessie

« back to all changes in this revision

Viewing changes to debian/patches/02_tunefs.ufs.patch

  • Committer: Bazaar Package Importer
  • Author(s): Guillem Jover, Robert Millan, Guillem Jover, Peter Pentchev
  • Date: 2011-05-31 03:50:05 UTC
  • mfrom: (1.1.4 upstream)
  • Revision ID: james.westby@ubuntu.com-20110531035005-wyiyk25p99ivd0k0
Tags: 8.2-1
[ Robert Millan ]
* Set ufsutils-udeb to kfreebsd-any.

[ Guillem Jover ]
* New upstream version (based on FreeBSD 8.2)
* Now using Standards-Version 3.9.2 (no changes needed).
* Switch to source format “3.0 (quilt)”.
  - Remove quilt from Build-Depends.
  - Remove patch target in debian/rules.
  - Remove now unneeded README.source.
  - Refresh all patches.
* Reorganize source code:
  - Switch from debian/upstream.sh to debian/rules get-orig-source target.
  - Switch from CVS to Subversion to retrieve the source code.
  - Use the same source layout as upstream (no more relocations),
    i.e. lib/, sbin/, sys/sys, sys/ufs.
  - Move libport/ to port/.
  - Merge libdisklabel/ into port/.
* Remove unneeded linking against libtermcap, thus removing the need for
  ncurses.
* Add an empty debian/watch file explaining that there's no packaged
  upstream releases. Suggested by Peter Pentchev.
* Update CVS to Subversion reference to upstream source code in
  debian/copyright.
* Remove unused lib variable from debian/rules.
* Use dpkg-buildflags to set CPPFLAGS, CFLAGS and LDFLAGS.
  Based on a patch by Peter Pentchev.
* Remove bogus reference to BSD license in /usr/share/common-licenses.
* Always set -I../../sys, even on GNU/kFreeBSD systems.

[ Peter Pentchev ]
* Remove duplicate section “utils” from ufsutils binary package.
* Remove XC- prefix from Package-Type.
* Honour CPPFLAGS and LDFLAGS and do not link with CFLAGS.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: ufsutils/tunefs.ufs/tunefs.c
2
 
===================================================================
3
 
--- ufsutils.orig/tunefs.ufs/tunefs.c
4
 
+++ ufsutils/tunefs.ufs/tunefs.c
5
 
@@ -48,8 +48,15 @@
 
1
---
 
2
 sbin/tunefs/Makefile |   13 ++++++++-----
 
3
 sbin/tunefs/tunefs.c |   15 +++++++++++++++
 
4
 2 files changed, 23 insertions(+), 5 deletions(-)
 
5
 
 
6
--- a/sbin/tunefs/tunefs.c
 
7
+++ b/sbin/tunefs/tunefs.c
 
8
@@ -48,8 +48,15 @@ __FBSDID("$FreeBSD$");
6
9
 #include <sys/mount.h>
7
10
 #include <sys/disklabel.h>
8
11
 #include <sys/stat.h>
18
21
 #include <ufs/ufs/dinode.h>
19
22
 #include <ufs/ffs/fs.h>
20
23
 
21
 
@@ -84,8 +91,12 @@
22
 
        int mflag, mvalue, nflag, oflag, ovalue, pflag, sflag, svalue;
 
24
@@ -84,8 +91,12 @@ main(int argc, char *argv[])
 
25
        int mflag, mvalue, Nflag, nflag, oflag, ovalue, pflag, sflag, svalue;
23
26
        int ch, found_arg, i;
24
27
        const char *chg[2];
25
28
+#ifdef HAVE_BSD_MOUNT
31
34
 
32
35
        if (argc < 3)
33
36
                usage();
34
 
@@ -241,9 +252,11 @@
 
37
@@ -253,9 +264,11 @@ main(int argc, char *argv[])
35
38
                goto err;
36
39
        if (disk.d_name != special) {
37
40
                special = disk.d_name;
43
46
        }
44
47
 
45
48
        if (pflag) {
46
 
@@ -402,6 +415,7 @@
 
49
@@ -440,6 +453,7 @@ main(int argc, char *argv[])
47
50
        if (sbwrite(&disk, Aflag) == -1)
48
51
                goto err;
49
52
        ufs_disk_close(&disk);
51
54
        if (active) {
52
55
                bzero(&args, sizeof(args));
53
56
                if (mount("ufs", on,
54
 
@@ -409,6 +423,7 @@
 
57
@@ -447,6 +461,7 @@ main(int argc, char *argv[])
55
58
                        err(9, "%s: reload", special);
56
59
                warnx("file system reloaded");
57
60
        }
59
62
        exit(0);
60
63
 err:
61
64
        if (disk.d_error != NULL)
62
 
Index: ufsutils/tunefs.ufs/Makefile
63
 
===================================================================
64
 
--- ufsutils.orig/tunefs.ufs/Makefile
65
 
+++ ufsutils/tunefs.ufs/Makefile
 
65
--- a/sbin/tunefs/Makefile
 
66
+++ b/sbin/tunefs/Makefile
66
67
@@ -1,9 +1,12 @@
67
68
 #      @(#)Makefile    8.1 (Berkeley) 6/5/93
68
 
 # $FreeBSD: src/sbin/tunefs/Makefile,v 1.8 2003/01/23 08:15:05 ru Exp $
 
69
 # $FreeBSD$
69
70
 
70
71
-PROG=  tunefs
71
72
-DPADD= ${LIBUFS}
75
76
+SRCS = tunefs.c
76
77
+MAN = tunefs.8:tunefs.ufs.8
77
78
+
78
 
+LDADD += -L../libufs -lufs -lbsd
79
 
+INCLUDES = -I../libufs
 
79
+LDADD += -L../../lib/libufs -lufs -lbsd
 
80
+INCLUDES = -I../../lib/libufs
80
81
+
81
 
+include ../Makefile.common
 
82
+include ../../Makefile.common
82
83
 
83
84
-.include <bsd.prog.mk>