~ubuntu-branches/debian/sid/gdal/sid

« back to all changes in this revision

Viewing changes to debian/patches/dods

  • Committer: Package Import Robot
  • Author(s): Francesco Paolo Lovergine
  • Date: 2012-05-07 15:04:42 UTC
  • mfrom: (5.5.16 experimental)
  • Revision ID: package-import@ubuntu.com-20120507150442-2eks97loeh6rq005
Tags: 1.9.0-1
* Ready for sid, starting transition.
* All symfiles updated to latest builds.
* Added dh_numpy call in debian/rules to depend on numpy ABI.
* Policy bumped to 3.9.3, no changes required.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: gdal/frmts/dods/dodsdataset2.cpp
2
 
===================================================================
3
 
--- gdal.orig/frmts/dods/dodsdataset2.cpp       2011-08-31 12:17:13.000000000 +0200
4
 
+++ gdal/frmts/dods/dodsdataset2.cpp    2011-08-31 12:49:08.000000000 +0200
5
 
@@ -50,7 +50,16 @@
6
 
 #include <Sequence.h>
7
 
 #include <Grid.h>
8
 
 
9
 
+#define LIBDAP_310 /* This is supposed to build with OpeNDAP 3.10+ a better general fix is present in recent upstream sources */
10
 
+
11
 
+#ifdef LIBDAP_310
12
 
+/* AISConnect.h/AISConnect class was renamed to Connect.h/Connect in libdap 3.10 */
13
 
+#include <Connect.h>           
14
 
+#define AISConnect Connect 
15
 
+#else
16
 
 #include <AISConnect.h>                
17
 
+#endif
18
 
+
19
 
 #include <DDS.h>
20
 
 #include <DAS.h>
21
 
 #include <BaseTypeFactory.h>
22
 
Index: gdal/ogr/ogrsf_frmts/dods/ogr_dods.h
23
 
===================================================================
24
 
--- gdal.orig/ogr/ogrsf_frmts/dods/ogr_dods.h   2011-08-31 12:17:13.000000000 +0200
25
 
+++ gdal/ogr/ogrsf_frmts/dods/ogr_dods.h        2011-08-31 12:49:48.000000000 +0200
26
 
@@ -61,7 +61,14 @@
27
 
 #include <Sequence.h>
28
 
 #include <Grid.h>
29
 
 
30
 
+#define LIBDAP_310 /* This is supposed to be linked only against 3.10+ a better fix is included upstream */
31
 
+#ifdef LIBDAP_310
32
 
+#include <Connect.h>
33
 
+#define AISConnect Connect 
34
 
+#else
35
 
 #include <AISConnect.h>                
36
 
+#endif
37
 
+
38
 
 #include <DDS.h>
39
 
 #include <DAS.h>
40
 
 #include <BaseTypeFactory.h>