~ubuntu-branches/debian/sid/gdal/sid

« back to all changes in this revision

Viewing changes to debian/patches/epsilon

  • Committer: Package Import Robot
  • Author(s): Francesco Paolo Lovergine
  • Date: 2012-05-07 15:04:42 UTC
  • mfrom: (5.5.16 experimental)
  • Revision ID: package-import@ubuntu.com-20120507150442-2eks97loeh6rq005
Tags: 1.9.0-1
* Ready for sid, starting transition.
* All symfiles updated to latest builds.
* Added dh_numpy call in debian/rules to depend on numpy ABI.
* Policy bumped to 3.9.3, no changes required.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: gdal/frmts/epsilon/epsilondataset.cpp
2
 
===================================================================
3
 
--- gdal.orig/frmts/epsilon/epsilondataset.cpp  2011-05-12 11:50:58.000000000 +0200
4
 
+++ gdal/frmts/epsilon/epsilondataset.cpp       2011-05-12 11:53:19.000000000 +0200
5
 
@@ -237,8 +237,8 @@
6
 
         return CE_Failure;
7
 
     }
8
 
     
9
 
-    int w = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.gs.w : hdr.tc.w;
10
 
-    int h = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.gs.h : hdr.tc.h;
11
 
+    int w = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.hdr_data.gs.w : hdr.hdr_data.tc.w;
12
 
+    int h = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.hdr_data.gs.h : hdr.hdr_data.tc.h;
13
 
     int i;
14
 
 
15
 
     if (poGDS->nBands == 1)
16
 
@@ -505,12 +505,12 @@
17
 
             continue;
18
 
         }
19
 
         
20
 
-        int W = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.gs.W : hdr.tc.W;
21
 
-        int H = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.gs.H : hdr.tc.H;
22
 
-        int x = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.gs.x : hdr.tc.x;
23
 
-        int y = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.gs.y : hdr.tc.y;
24
 
-        int w = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.gs.w : hdr.tc.w;
25
 
-        int h = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.gs.h : hdr.tc.h;
26
 
+        int W = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.hdr_data.gs.W : hdr.hdr_data.tc.W;
27
 
+        int H = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.hdr_data.gs.H : hdr.hdr_data.tc.H;
28
 
+        int x = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.hdr_data.gs.x : hdr.hdr_data.tc.x;
29
 
+        int y = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.hdr_data.gs.y : hdr.hdr_data.tc.y;
30
 
+        int w = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.hdr_data.gs.w : hdr.hdr_data.tc.w;
31
 
+        int h = (hdr.block_type == EPS_GRAYSCALE_BLOCK) ? hdr.hdr_data.gs.h : hdr.hdr_data.tc.h;
32
 
 
33
 
         //CPLDebug("EPSILON", "W=%d,H=%d,x=%d,y=%d,w=%d,h=%d,offset=" CPL_FRMT_GUIB,
34
 
         //                    W, H, x, y, w, h, nStartBlockFileOff);