~ubuntu-branches/debian/sid/ocaml/sid

« back to all changes in this revision

Viewing changes to debian/patches/dumpobj.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Stefano Zacchiroli
  • Date: 2009-02-22 08:49:13 UTC
  • mfrom: (12.1.1 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090222084913-3i0uw2bhd0lgw0ok
* Uploading to unstable
* debian/control: bump dh-ocaml to (>= 0.4) to avoid buggy ocamlinit.mk

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh /usr/share/dpatch/dpatch-run
2
 
## dumpobj.dpatch by Samuel Mimram <smimram@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: Ship ocamldumpobj and add a manpage for it.
6
 
 
7
 
@DPATCH@
8
 
diff -urNad ocaml-3.09.1~/man/ocamlc.m ocaml-3.09.1/man/ocamlc.m
9
 
--- ocaml-3.09.1~/man/ocamlc.m  2006-01-04 20:35:35.000000000 +0100
10
 
+++ ocaml-3.09.1/man/ocamlc.m   2006-01-04 20:37:08.000000000 +0100
11
 
@@ -243,7 +243,8 @@
12
 
 .SH SEE ALSO
13
 
 .BR ocaml (1),
14
 
 .BR ocamlrun (1),
15
 
-.BR ocamlobjinfo (1).
16
 
+.BR ocamlobjinfo (1),
17
 
+.BR ocamldumpobj (1).
18
 
 .br
19
 
 .I The Objective Caml user's manual,
20
 
 chapter "Batch compilation".
21
 
diff -urNad ocaml-3.09.1~/man/ocamldumpobj.m ocaml-3.09.1/man/ocamldumpobj.m
22
 
--- ocaml-3.09.1~/man/ocamldumpobj.m    1970-01-01 01:00:00.000000000 +0100
23
 
+++ ocaml-3.09.1/man/ocamldumpobj.m     2006-01-04 20:44:49.000000000 +0100
24
 
@@ -0,0 +1,20 @@
25
 
+.TH OCAMLDUMPOBJ 1 "January 4, 2006"
26
 
+.SH NAME
27
 
+ocamldumpobj \- disassembler for OCaml executable and .cmo object files
28
 
+.
29
 
+.SH SYNOPSIS
30
 
+.B ocamldumpobj
31
 
+.RI file\ ...
32
 
+.
33
 
+.SH DESCRIPTION
34
 
+Disassembler for executable and .cmo object files compiled by OCaml.
35
 
+.
36
 
+.SH SEE ALSO
37
 
+.BR ocamlc (1),
38
 
+.BR ocamlopt (1),
39
 
+.BR ocamlobjinfo (1).
40
 
+.br
41
 
+.
42
 
+.SH AUTHOR
43
 
+This manual page was written by Samuel Mimram <smimram@debian.org>,
44
 
+for the Debian GNU/Linux system (but may be used by others).
45
 
diff -urNad ocaml-3.09.1~/man/ocamlopt.m ocaml-3.09.1/man/ocamlopt.m
46
 
--- ocaml-3.09.1~/man/ocamlopt.m        2006-01-04 20:35:35.000000000 +0100
47
 
+++ ocaml-3.09.1/man/ocamlopt.m 2006-01-04 20:39:46.000000000 +0100
48
 
@@ -226,7 +226,8 @@
49
 
 
50
 
 .SH SEE ALSO
51
 
 .BR ocamlc (1),
52
 
-.BR ocamlobjinfo (1).
53
 
+.BR ocamlobjinfo (1),
54
 
+.BR ocamldumpobj (1).
55
 
 .br
56
 
 .I The Objective Caml user's manual,
57
 
 chapter "Native-code compilation".
58
 
diff -urNad ocaml-3.09.1~/tools/Makefile ocaml-3.09.1/tools/Makefile
59
 
--- ocaml-3.09.1~/tools/Makefile        2006-01-04 20:35:35.000000000 +0100
60
 
+++ ocaml-3.09.1/tools/Makefile 2006-01-04 20:36:07.000000000 +0100
61
 
@@ -71,6 +71,7 @@
62
 
        cp ocamlcp $(BINDIR)/ocamlcp$(EXE)
63
 
        cp profiling.cmi profiling.cmo $(LIBDIR)
64
 
        cp objinfo $(BINDIR)/ocamlobjinfo$(EXE)
65
 
+       cp dumpobj $(BINDIR)/ocamldumpobj$(EXE)
66
 
 
67
 
 clean::
68
 
        rm -f ocamlprof ocamlcp