~ubuntu-branches/debian/sid/ocaml/sid

« back to all changes in this revision

Viewing changes to debian/patches/install_ocamlbuild.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Stefano Zacchiroli
  • Date: 2009-02-22 08:49:13 UTC
  • mfrom: (12.1.1 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090222084913-3i0uw2bhd0lgw0ok
* Uploading to unstable
* debian/control: bump dh-ocaml to (>= 0.4) to avoid buggy ocamlinit.mk

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
## DP: install ocamlbuild as a link on either .native or .byte.
6
6
 
7
7
@DPATCH@
8
 
diff -urNad trunk~/build/partial-install.sh trunk/build/partial-install.sh
9
 
--- trunk~/build/partial-install.sh     2007-06-17 15:13:23.000000000 +0100
10
 
+++ trunk/build/partial-install.sh      2007-06-17 15:15:11.000000000 +0100
11
 
@@ -47,6 +47,21 @@
 
8
diff -urNad ocaml~/build/partial-install.sh ocaml/build/partial-install.sh
 
9
--- ocaml~/build/partial-install.sh     2008-11-29 11:32:25.000000000 +0100
 
10
+++ ocaml/build/partial-install.sh      2008-11-29 11:32:25.000000000 +0100
 
11
@@ -60,6 +60,21 @@
12
12
   [ -x "$3" ] || chmod +x "$3"
13
13
 }
14
14
 
30
30
 installlib() {
31
31
   if [ -f "$1" ]; then
32
32
     dest="$2/`basename $1`"
33
 
@@ -143,7 +158,7 @@
 
33
@@ -156,7 +171,7 @@
34
34
 cd ocamlbuild
35
35
 installbin ocamlbuild.byte$EXE $BINDIR/ocamlbuild.byte$EXE
36
36
 installbin ocamlbuild.native$EXE $BINDIR/ocamlbuild.native$EXE