~ubuntu-branches/debian/sid/openchange/sid

« back to all changes in this revision

Viewing changes to debian/patches/01_symlinks

  • Committer: Package Import Robot
  • Author(s): Jelmer Vernooij
  • Date: 2012-04-12 20:07:57 UTC
  • mfrom: (11 sid)
  • mto: This revision was merged to the branch mainline in revision 12.
  • Revision ID: package-import@ubuntu.com-20120412200757-k933d9trljmxj1l4
Tags: 1:1.0-4
* openchangeserver: Add dependency on openchangeproxy.
* Rebuild against newer version of Samba 4.
* Use dpkg-buildflags.
* Migrate to Git, update Vcs-Git header.
* Switch to debhelper 9.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Jelmer Vernooij <jelmer@openchange.org>
 
2
Status: cherry-picked from upstream
 
3
Description: Fix symbolic link creation for shared libaries (which have a somewhat inconsistent soversion)
 
4
 
 
5
=== modified file 'Makefile'
 
6
--- old/Makefile        2012-03-16 01:32:07 +0000
 
7
+++ new/Makefile        2012-03-19 13:21:55 +0000
 
8
@@ -736,6 +736,9 @@
 
9
 libmapiproxy-install:
 
10
        $(INSTALL) -m 0755 mapiproxy/libmapiproxy.$(SHLIBEXT).$(PACKAGE_VERSION) $(DESTDIR)$(libdir)
 
11
        ln -sf libmapiproxy.$(SHLIBEXT).$(PACKAGE_VERSION) $(DESTDIR)$(libdir)/libmapiproxy.$(SHLIBEXT)
 
12
+ifeq ($(MANUALLY_CREATE_SYMLINKS), yes)
 
13
+       ln -sf libmapiproxy.$(SHLIBEXT).$(PACKAGE_VERSION) $(DESTDIR)$(libdir)/libmapiproxy.$(SHLIBEXT).$(LIBMAPIPROXY_SO_VERSION)
 
14
+endif
 
15
        $(INSTALL) -m 0644 mapiproxy/libmapiproxy/libmapiproxy.h $(DESTDIR)$(includedir)/
 
16
        $(INSTALL) -m 0644 mapiproxy/libmapiproxy.pc $(DESTDIR)$(libdir)/pkgconfig
 
17
 
 
18
@@ -783,6 +786,9 @@
 
19
 libmapiserver-install:
 
20
        $(INSTALL) -m 0755 mapiproxy/libmapiserver.$(SHLIBEXT).$(PACKAGE_VERSION) $(DESTDIR)$(libdir)
 
21
        ln -sf libmapiserver.$(SHLIBEXT).$(PACKAGE_VERSION) $(DESTDIR)$(libdir)/libmapiserver.$(SHLIBEXT)
 
22
+ifeq ($(MANUALLY_CREATE_SYMLINKS), yes)
 
23
+       ln -sf libmapiserver.$(SHLIBEXT).$(PACKAGE_VERSION) $(DESTDIR)$(libdir)/libmapiserver.$(SHLIBEXT).$(LIBMAPISERVER_SO_VERSION)
 
24
+endif
 
25
        $(INSTALL) -m 0644 mapiproxy/libmapiserver/libmapiserver.h $(DESTDIR)$(includedir)/
 
26
        $(INSTALL) -m 0644 mapiproxy/libmapiserver.pc $(DESTDIR)$(libdir)/pkgconfig
 
27
        @$(SED) $(DESTDIR)$(includedir)/*.h
 
28
@@ -855,6 +861,9 @@
 
29
 libmapistore-install:  $(OC_MAPISTORE_INSTALL)
 
30
        $(INSTALL) -m 0755 mapiproxy/libmapistore.$(SHLIBEXT).$(PACKAGE_VERSION) $(DESTDIR)$(libdir)
 
31
        ln -sf libmapistore.$(SHLIBEXT).$(PACKAGE_VERSION) $(DESTDIR)$(libdir)/libmapistore.$(SHLIBEXT)
 
32
+ifeq ($(MANUALLY_CREATE_SYMLINKS), yes)
 
33
+       ln -sf libmapistore.$(SHLIBEXT).$(PACKAGE_VERSION) $(DESTDIR)$(libdir)/libmapistore.$(SHLIBEXT).$(LIBMAPISTORE_SO_VERSION)
 
34
+endif
 
35
        $(INSTALL) -d $(DESTDIR)$(includedir)/mapistore
 
36
        $(INSTALL) -m 0644 mapiproxy/libmapistore/mapistore.h $(DESTDIR)$(includedir)/mapistore/
 
37
        $(INSTALL) -m 0644 mapiproxy/libmapistore/mapistore_errors.h $(DESTDIR)$(includedir)/mapistore/
 
38