~ubuntu-branches/debian/sid/openchange/sid

« back to all changes in this revision

Viewing changes to debian/patches/02_mapiproxy_dl

  • Committer: Package Import Robot
  • Author(s): Jelmer Vernooij
  • Date: 2012-04-12 20:07:57 UTC
  • mfrom: (11 sid)
  • mto: This revision was merged to the branch mainline in revision 12.
  • Revision ID: package-import@ubuntu.com-20120412200757-k933d9trljmxj1l4
Tags: 1:1.0-4
* openchangeserver: Add dependency on openchangeproxy.
* Rebuild against newer version of Samba 4.
* Use dpkg-buildflags.
* Migrate to Git, update Vcs-Git header.
* Switch to debhelper 9.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Author: Jelmer Vernooij <jelmer@openchange.org>
 
2
Description: Link mapiproxy against -ldl to prevent missing symbol errors
 
3
Status: cherry-picked from upstream
 
4
 
 
5
=== modified file 'Makefile'
 
6
--- old/Makefile        2012-03-19 13:23:38 +0000
 
7
+++ new/Makefile        2012-03-19 13:40:08 +0000
 
8
@@ -771,7 +771,7 @@
 
9
                                                        mapiproxy/libmapiproxy/modules.po                       \
 
10
                                                        libmapi.$(SHLIBEXT).$(PACKAGE_VERSION)
 
11
        @echo "Linking $@"
 
12
-       @$(CC) -o $@ $(DSOOPT) $(LDFLAGS) -Wl,-soname,libmapiproxy.$(SHLIBEXT).$(LIBMAPIPROXY_SO_VERSION) $^ -L. $(LIBS) $(TDB_LIBS)
 
13
+       @$(CC) -o $@ $(DSOOPT) $(LDFLAGS) -Wl,-soname,libmapiproxy.$(SHLIBEXT).$(LIBMAPIPROXY_SO_VERSION) $^ -L. $(LIBS) $(TDB_LIBS) $(DL_LIBS)
 
14
 
 
15
 mapiproxy/libmapiproxy.$(SHLIBEXT).$(LIBMAPIPROXY_SO_VERSION): libmapiproxy.$(SHLIBEXT).$(PACKAGE_VERSION)
 
16
        ln -fs $< $@
 
17