~ubuntu-branches/debian/sid/ppp/sid

« back to all changes in this revision

Viewing changes to debian/patches/pppdump_use_zlib

  • Committer: Bazaar Package Importer
  • Author(s): Eddy Petrișor
  • Date: 2007-03-17 22:31:45 UTC
  • mfrom: (1.1.3 upstream)
  • Revision ID: james.westby@ubuntu.com-20070317223145-felzh5yrmh8fwi8t
Tags: 2.4.4rel-8
* urgency high since fixes an RC bug
* make sure the /etc/resolv.conf file is world readable (Closes: #415077)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -ruNp ppp-2.4.4.orig/pppdump/Makefile.linux ppp-2.4.4/pppdump/Makefile.linux
 
2
--- ppp-2.4.4.orig/pppdump/Makefile.linux       2006-06-04 07:04:14.000000000 +0200
 
3
+++ ppp-2.4.4/pppdump/Makefile.linux    2006-10-22 23:44:23.000000000 +0200
 
4
@@ -2,15 +2,40 @@ DESTDIR = $(INSTROOT)@DESTDIR@
 
5
 BINDIR = $(DESTDIR)/sbin
 
6
 MANDIR = $(DESTDIR)/share/man/man8
 
7
 
 
8
-CFLAGS= -O -I../include/net
 
9
-OBJS = pppdump.o bsd-comp.o deflate.o zlib.o
 
10
+DO_DEFLATE=y
 
11
+DO_BSD_COMPRESS=y
 
12
+HAVE_ZLIB=y
 
13
+
 
14
+OPTS := -O2 -Wall
 
15
+CFLAGS := -I../include/net
 
16
+OBJS := pppdump.o
 
17
+LIBS :=
 
18
+
 
19
+ifdef DO_DEFLATE
 
20
+CFLAGS += -DDO_DEFLATE=1
 
21
+OBJS += deflate.o
 
22
+ifdef HAVE_ZLIB
 
23
+LIBS += -lz
 
24
+else
 
25
+OBJS += zlib.o
 
26
+endif
 
27
+else
 
28
+CFLAGS += -DDO_DEFLATE=0
 
29
+endif
 
30
+
 
31
+ifdef DO_BSD_COMPRESS
 
32
+CFLAGS += -DDO_BSD_COMPRESS=1
 
33
+OBJS += bsd-comp.o
 
34
+else
 
35
+CFLAGS += -DDO_BSD_COMPRESS=0
 
36
+endif
 
37
 
 
38
 INSTALL= install
 
39
 
 
40
 all:   pppdump
 
41
 
 
42
 pppdump: $(OBJS)
 
43
-       $(CC) -o pppdump $(OBJS)
 
44
+       $(CC) $(CFLAGS) $(OPTS) -o pppdump $(OBJS) $(LIBS)
 
45
 
 
46
 clean:
 
47
        rm -f pppdump $(OBJS) *~