~ubuntu-branches/debian/squeeze/erlang/squeeze

« back to all changes in this revision

Viewing changes to debian/patches/gnu.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sergei Golovan
  • Date: 2009-08-05 20:54:29 UTC
  • mfrom: (6.1.2 sid)
  • Revision ID: james.westby@ubuntu.com-20090805205429-pm4pnwew8axraosl
Tags: 1:13.b.1-dfsg-5
* Fixed parentheses in Emacs mode (closes: #536891).
* Removed unnecessary conflicts with erlang-manpages package.
* Added workaround for #475459: disabled threads on sparc architecture.
  This breaks wxErlang, so it's only a temporary solution.

Show diffs side-by-side

added added

removed removed

Lines of Context:
10
10
 
11
11
(4) Skips building SSL certificate examples for GNU/Hurd (Debian GNU/Hurd has
12
12
    no a random translator yet).
13
 
--- erlang-13.b-dfsg.orig/erts/configure.in
14
 
+++ erlang-13.b-dfsg/erts/configure.in
 
13
--- erlang-13.b.1-dfsg.orig/erts/configure.in
 
14
+++ erlang-13.b.1-dfsg/erts/configure.in
15
15
@@ -315,7 +315,7 @@
16
16
 
17
17
 dnl NOTE: CPPFLAGS will be included in CFLAGS at the end
21
21
     win32)
22
22
        # The ethread library requires _WIN32_WINNT of at least 0x0403.
23
23
        # -D_WIN32_WINNT=* from CPPFLAGS is saved in ETHR_DEFS.
24
 
@@ -913,7 +913,7 @@
 
24
@@ -926,7 +926,7 @@
25
25
            solaris*)
26
26
                enable_child_waiter_thread=yes
27
27
                ;;
30
30
                AC_DEFINE(USE_RECURSIVE_MALLOC_MUTEX,[1],
31
31
                        [Define if malloc should use a recursive mutex])
32
32
                AC_MSG_CHECKING([whether dlopen() needs to be called before first call to dlerror()])
33
 
--- erlang-13.b-dfsg.orig/lib/common_test/Makefile
34
 
+++ erlang-13.b-dfsg/lib/common_test/Makefile
 
33
--- erlang-13.b.1-dfsg.orig/lib/common_test/Makefile
 
34
+++ erlang-13.b.1-dfsg/lib/common_test/Makefile
35
35
@@ -30,9 +30,13 @@
36
36
 ifeq ($(findstring solaris,$(TARGET)),solaris)
37
37
 SUB_DIRECTORIES = doc/src src priv
46
46
 
47
47
 include vsn.mk
48
48
 VSN = $(COMMON_TEST_VSN)
49
 
--- erlang-13.b-dfsg.orig/lib/common_test/priv/Makefile.in
50
 
+++ erlang-13.b-dfsg/lib/common_test/priv/Makefile.in
 
49
--- erlang-13.b.1-dfsg.orig/lib/common_test/priv/Makefile.in
 
50
+++ erlang-13.b.1-dfsg/lib/common_test/priv/Makefile.in
51
51
@@ -43,9 +43,13 @@
52
52
 ifeq ($(findstring solaris,$(TARGET)),solaris)
53
53
 XNIX = true
62
62
 
63
63
 ifneq ($(findstring win32,$(TARGET)),win32)
64
64
 
65
 
--- erlang-13.b-dfsg.orig/lib/os_mon/c_src/memsup.c
66
 
+++ erlang-13.b-dfsg/lib/os_mon/c_src/memsup.c
 
65
--- erlang-13.b.1-dfsg.orig/lib/os_mon/c_src/memsup.c
 
66
+++ erlang-13.b.1-dfsg/lib/os_mon/c_src/memsup.c
67
67
@@ -110,6 +110,11 @@
68
68
 #include <memLib.h>
69
69
 #endif
76
76
 #ifdef BSD4_4
77
77
 #include <sys/types.h>
78
78
 #include <sys/sysctl.h>
79
 
--- erlang-13.b-dfsg.orig/lib/ssl/Makefile
80
 
+++ erlang-13.b-dfsg/lib/ssl/Makefile
 
79
--- erlang-13.b.1-dfsg.orig/lib/ssl/Makefile
 
80
+++ erlang-13.b.1-dfsg/lib/ssl/Makefile
81
81
@@ -32,8 +32,15 @@
82
82
 SKIP_BUILDING_BINARIES := true
83
83
 endif