~ubuntu-branches/debian/squeeze/erlang/squeeze

« back to all changes in this revision

Viewing changes to debian/patches/sparc.patch

  • Committer: Bazaar Package Importer
  • Author(s): Sergei Golovan
  • Date: 2009-08-05 20:54:29 UTC
  • mfrom: (6.1.2 sid)
  • Revision ID: james.westby@ubuntu.com-20090805205429-pm4pnwew8axraosl
Tags: 1:13.b.1-dfsg-5
* Fixed parentheses in Emacs mode (closes: #536891).
* Removed unnecessary conflicts with erlang-manpages package.
* Added workaround for #475459: disabled threads on sparc architecture.
  This breaks wxErlang, so it's only a temporary solution.

Show diffs side-by-side

added added

removed removed

Lines of Context:
5
5
 
6
6
(2) Fixes FTBFS(see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=328031).
7
7
 
8
 
--- erlang-13.b-dfsg.orig/erts/configure.in
9
 
+++ erlang-13.b-dfsg/erts/configure.in
 
8
--- erlang-13.b.1-dfsg.orig/erts/configure.in
 
9
+++ erlang-13.b.1-dfsg/erts/configure.in
10
10
@@ -473,7 +473,7 @@
11
11
     chk_arch_=`uname -m`
12
12
 fi
16
16
     sparc64)   ARCH=sparc64;;
17
17
     sun4v)     ARCH=ultrasparc;;
18
18
     i86pc)     ARCH=x86;;
19
 
--- erlang-13.b-dfsg.orig/erts/emulator/beam/beam_emu.c
20
 
+++ erlang-13.b-dfsg/erts/emulator/beam/beam_emu.c
21
 
@@ -1005,16 +1005,6 @@
 
19
--- erlang-13.b.1-dfsg.orig/erts/emulator/beam/beam_emu.c
 
20
+++ erlang-13.b.1-dfsg/erts/emulator/beam/beam_emu.c
 
21
@@ -976,16 +976,6 @@
22
22
  * in registers.
23
23
  */
24
24
 
35
35
 #  define REG_x0
36
36
 #  define REG_xregs
37
37
 #  define REG_htop
38
 
@@ -1023,7 +1013,6 @@
 
38
@@ -994,7 +984,6 @@
39
39
 #  define REG_fcalls
40
40
 #  define REG_tmp_arg1
41
41
 #  define REG_tmp_arg2