~ubuntu-branches/debian/squeeze/sword/squeeze

« back to all changes in this revision

Viewing changes to debian/patches/02_libver.diff

  • Committer: Bazaar Package Importer
  • Author(s): Jonathan Marsden, Jonathan Marsden, Dmitrijs Ledkovs, Closed Bugs
  • Date: 2009-05-30 11:55:55 UTC
  • mfrom: (1.3.1 upstream) (6.1.1 experimental)
  • Revision ID: james.westby@ubuntu.com-20090530115555-r427zsn3amivdpfu
Tags: 1.6.0+dfsg-1
[ Jonathan Marsden ]
* New upstream release. (Closes: #507960) (LP: #320558)
* debian/patches/02_libver.diff:
  - Bump SONAME to 8 -- SWORD 1.6 is not backward compatible with 1.5.11.
* debian/patches/series:
  - Remove 10_diatheke.diff -- included in upstream source.
* debian/patches/:
  - Remove several old unused .diff files.
  - Add 11_regex_only_when_needed.diff to conditionally include regex lib.
  - Add 12_fix_compiler_warnings.diff to remove all compiler warnings.
  - Add 13_fix_osis2mod_compression_default.diff from upstream svn.
  - Add 14_closing_section_not_chapter.diff from upstream svn.
* debian/libsword7.*: 
  - Rename to libsword8.*
  - Change libsword7 to libsword8 within files.
* debian/rules: 
  - SONAME bump to 8.
  - Set library version check to >= 1.6
* debian/control:
  - Change libsword7 to libsword8.
  - Add libsword7 to Conflicts.
  - Fix case of sword to SWORD in package descriptions.
  - Bump Standards-Version to 3.8.1 (no changes needed).
  - Fix section for libsword-dbg to avoid lintian warning.
* debian/rules:
  - Add DFSG get-orig-source target.
* debian/copyright:
  - Fix various mistakes in initial attempt to document copyrights.

[ Dmitrijs Ledkovs ]
* debian/rules: Added utils.mk to use missing-files target and call it on
  each build.
* debian/libsword-dev.install: Added libsword.la, previously missing.
* debian/libsword7.install: Added missing libicu translit files.
* debian/control:
  - Updated all uses of SWORD version to 1.6
  - Added libsword-dbg package
* debian/watch: Fixed a small mistake which was resulting in extra "."
  in final version name.
* debian/rules: simplified manpage processing.
* debian/libsword8.lintian-overrides: added override for module
  installation directory.
* debian/copyright: Updated with information about everyfile.
  Closes: #513448 LP: #322638
* debian/diatheke.examples: moved examples here from the diatheke.install
* debian/rules:
  - enabled shell script based testsuite
  - added commented out cppunit testsuite
* debian/patches/40_missing_includes.diff: 
  - added several missing stdio.h includes to prevent FTBFS of testsuite.

[ Closed Bugs ]
* FTBFS on intrepid (LP: #305172)

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Index: sword-1.5.9/lib/Makefile.am
 
1
This patch changes the upstream SO name to Debian/Ubuntu SO name.
 
2
 
 
3
Index: main/lib/Makefile.am
2
4
===================================================================
3
 
--- sword-1.5.9.orig/lib/Makefile.am    2007-09-01 11:16:04.000000000 +0100
4
 
+++ sword-1.5.9/lib/Makefile.am 2007-09-01 11:17:05.000000000 +0100
5
 
@@ -34,9 +34,9 @@
6
 
 endif
7
 
 
8
 
 
9
 
-libsword_la_LIBADD = $(ICULIBADD) $(IMGRLIBADD) 
10
 
+libsword_la_LIBADD = $(ICULIBADD) $(IMGRLIBADD) $(CLUCENE_LIBS)
 
5
--- main.orig/lib/Makefile.am   2009-05-25 10:23:38.000000000 -0700
 
6
+++ main/lib/Makefile.am        2009-05-25 10:41:16.000000000 -0700
 
7
@@ -36,7 +36,7 @@
 
8
 
 
9
 libsword_la_LIBADD = $(ICULIBADD) $(IMGRLIBADD) $(CLUCENE_LIBS)
11
10
 
12
11
-libsword_la_LDFLAGS = -release $(VERSION)
13
 
+libsword_la_LDFLAGS = -version-info 6
 
12
+libsword_la_LDFLAGS = -version-info 8
14
13
 
15
14
 include ../src/keys/Makefile.am
16
15
 include ../src/utilfuns/Makefile.am
17
 
Index: sword-1.5.9/lib/Makefile.in
 
16
Index: main/lib/Makefile.in
18
17
===================================================================
19
 
--- sword-1.5.9.orig/lib/Makefile.in    2007-09-01 11:16:04.000000000 +0100
20
 
+++ sword-1.5.9/lib/Makefile.in 2007-09-01 11:18:27.000000000 +0100
21
 
@@ -277,6 +277,7 @@
22
 
 GENCCODE = @GENCCODE@
23
 
 GENCMN = @GENCMN@
24
 
 GENRB = @GENRB@
25
 
+GREP = @GREP@
26
 
 HAVE_CPPUNIT_FALSE = @HAVE_CPPUNIT_FALSE@
27
 
 HAVE_CPPUNIT_TRUE = @HAVE_CPPUNIT_TRUE@
28
 
 ICUSWORD_FALSE = @ICUSWORD_FALSE@
29
 
@@ -335,15 +336,9 @@
30
 
 XML_LIBS = @XML_LIBS@
31
 
 ZLIB_FALSE = @ZLIB_FALSE@
32
 
 ZLIB_TRUE = @ZLIB_TRUE@
33
 
-ac_ct_AR = @ac_ct_AR@
34
 
-ac_ct_AS = @ac_ct_AS@
35
 
 ac_ct_CC = @ac_ct_CC@
36
 
 ac_ct_CXX = @ac_ct_CXX@
37
 
-ac_ct_DLLTOOL = @ac_ct_DLLTOOL@
38
 
 ac_ct_F77 = @ac_ct_F77@
39
 
-ac_ct_OBJDUMP = @ac_ct_OBJDUMP@
40
 
-ac_ct_RANLIB = @ac_ct_RANLIB@
41
 
-ac_ct_STRIP = @ac_ct_STRIP@
42
 
 am__fastdepCC_FALSE = @am__fastdepCC_FALSE@
43
 
 am__fastdepCC_TRUE = @am__fastdepCC_TRUE@
44
 
 am__fastdepCXX_FALSE = @am__fastdepCXX_FALSE@
45
 
@@ -360,7 +355,10 @@
46
 
 build_os = @build_os@
47
 
 build_vendor = @build_vendor@
48
 
 datadir = @datadir@
49
 
+datarootdir = @datarootdir@
50
 
 dir_confdef = @dir_confdef@
51
 
+docdir = @docdir@
52
 
+dvidir = @dvidir@
53
 
 enable_debug = @enable_debug@
54
 
 enable_profile = @enable_profile@
55
 
 exec_prefix = @exec_prefix@
56
 
@@ -369,17 +367,21 @@
57
 
 host_cpu = @host_cpu@
58
 
 host_os = @host_os@
59
 
 host_vendor = @host_vendor@
60
 
+htmldir = @htmldir@
61
 
 includedir = @includedir@
62
 
 infodir = @infodir@
63
 
 install_sh = @install_sh@
64
 
 libdir = @libdir@
65
 
 libexecdir = @libexecdir@
66
 
+localedir = @localedir@
67
 
 localstatedir = @localstatedir@
68
 
 mandir = @mandir@
69
 
 mkdir_p = @mkdir_p@
70
 
 oldincludedir = @oldincludedir@
71
 
+pdfdir = @pdfdir@
72
 
 prefix = @prefix@
73
 
 program_transform_name = @program_transform_name@
74
 
+psdir = @psdir@
75
 
 sbindir = @sbindir@
76
 
 sharedstatedir = @sharedstatedir@
77
 
 sysconfdir = @sysconfdir@
78
 
@@ -450,8 +452,8 @@
79
 
 
 
18
--- main.orig/lib/Makefile.in   2009-05-25 10:23:38.000000000 -0700
 
19
+++ main/lib/Makefile.in        2009-05-25 10:41:37.000000000 -0700
 
20
@@ -452,7 +452,7 @@
80
21
 #if WITHCURL
81
22
 @INSTALLMGR_TRUE@IMGRLIBADD = -lcurl $(CURL_LIBS)
82
 
-libsword_la_LIBADD = $(ICULIBADD) $(IMGRLIBADD) 
 
23
 libsword_la_LIBADD = $(ICULIBADD) $(IMGRLIBADD) $(CLUCENE_LIBS)
83
24
-libsword_la_LDFLAGS = -release $(VERSION)
84
 
+libsword_la_LIBADD = $(ICULIBADD) $(IMGRLIBADD) $(CLUCENE_LIBS)
85
 
+libsword_la_LDFLAGS = -version-info 6
 
25
+libsword_la_LDFLAGS = -version-info 8
86
26
 keysdir = $(top_srcdir)/src/keys
87
27
 utilfunsdir = $(top_srcdir)/src/utilfuns
88
28
 @INTERNALFTPLIB_FALSE@ftpsrc =