~ubuntu-branches/debian/wheezy/calibre/wheezy

« back to all changes in this revision

Viewing changes to debian/patches/disable_plugins.py

  • Committer: Package Import Robot
  • Author(s): Martin Pitt
  • Date: 2012-01-07 11:22:54 UTC
  • mfrom: (29.4.10 precise)
  • Revision ID: package-import@ubuntu.com-20120107112254-n1syr437o46ds802
Tags: 0.8.34+dfsg-1
* New upstream version. (Closes: #654751)
* debian/rules: Do not install calibre copy of chardet; instead, add
  build/binary python-chardet dependency.
* Add disable_plugins.py: Disable plugin dialog. It uses a totally
  non-authenticated and non-trusted way of installing arbitrary code.
  (Closes: #640026)
* debian/rules: Install with POSIX locale, to avoid installing translated
  manpages into the standard locations. (Closes: #646674)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Description: Disable plugin dialog. It uses a totally non-authenticated and non-trusted way of installing arbitrary code.
 
2
Author: Martin Pitt <mpitt@debian.org>
 
3
Bug-Debian: http://bugs.debian.org/640026
 
4
 
 
5
Index: calibre-0.8.29+dfsg/src/calibre/gui2/actions/preferences.py
 
6
===================================================================
 
7
--- calibre-0.8.29+dfsg.orig/src/calibre/gui2/actions/preferences.py    2011-12-16 05:49:14.000000000 +0100
 
8
+++ calibre-0.8.29+dfsg/src/calibre/gui2/actions/preferences.py 2011-12-20 19:29:04.798468930 +0100
 
9
@@ -28,8 +28,6 @@
 
10
             pm.addAction(QIcon(I('config.png')), _('Preferences'), self.do_config)
 
11
         cm('welcome wizard', _('Run welcome wizard'),
 
12
                 icon='wizard.png', triggered=self.gui.run_wizard)
 
13
-        cm('plugin updater', _('Get plugins to enhance calibre'),
 
14
-                icon='plugins/plugin_updater.png', triggered=self.get_plugins)
 
15
         if not DEBUG:
 
16
             pm.addSeparator()
 
17
             cm('restart', _('Restart in debug mode'), icon='debug.png',