~ubuntu-branches/ubuntu/dapper/php5/dapper-proposed

« back to all changes in this revision

Viewing changes to debian/patches/053-extension_api.patch

  • Committer: Bazaar Package Importer
  • Author(s): Adam Conrad
  • Date: 2005-10-09 03:14:32 UTC
  • Revision ID: james.westby@ubuntu.com-20051009031432-5agt5xkcnt5q2kmt
Tags: 5.0.5-2ubuntu1
Resync with Debian, bringing in two security fixes, a file conflict fix,
and two 64-bit memory corruption and segfault fixes (no other changes).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -ur php-5.0.4/configure.in php5-5.0.4/configure.in
 
2
--- php-5.0.4/configure.in      2005-03-31 07:43:12.000000000 +1000
 
3
+++ php5-5.0.4/configure.in     2005-07-31 02:35:46.000000000 +1000
 
4
@@ -1044,8 +1044,10 @@
 
5
 
 
6
 ZEND_MODULE_API_NO=`egrep '#define ZEND_MODULE_API_NO ' $srcdir/Zend/zend_modules.h|sed 's/#define ZEND_MODULE_API_NO //'`
 
7
 
 
8
+DEBIAN_PHP_API=`egrep -h '^#define ZEND_EXTENSION_API_NO|^#define ZEND_MODULE_API_NO|#define PHP_API_VERSION' $srcdir/Zend/zend_extensions.h $srcdir/Zend/zend_modules.h $srcdir/main/php.h | awk '{print $3}' | sed -e 's/^2200/200/' | sort -n | tail -n 1`
 
9
+
 
10
 if test -z "$EXTENSION_DIR"; then
 
11
-  extbasedir=$ZEND_MODULE_API_NO
 
12
+  extbasedir=$DEBIAN_PHP_API
 
13
   if test "$oldstyleextdir" = "yes"; then
 
14
     if test "$PHP_DEBUG" = "1"; then
 
15
       part1=debug
 
16
@@ -1176,6 +1178,7 @@
 
17
 PHP_SUBST(CXXFLAGS_CLEAN)
 
18
 PHP_SUBST(CXX_PHP_COMPILE)
 
19
 PHP_SUBST_OLD(DEBUG_CFLAGS)
 
20
+PHP_SUBST_OLD(DEBIAN_PHP_API)
 
21
 PHP_SUBST_OLD(EXTENSION_DIR)
 
22
 PHP_SUBST_OLD(EXTRA_LDFLAGS)
 
23
 PHP_SUBST_OLD(EXTRA_LDFLAGS_PROGRAM)
 
24
diff -ur php-5.0.4/scripts/php-config.in php5-5.0.4/scripts/php-config.in
 
25
--- php-5.0.4/scripts/php-config.in     2005-03-16 17:36:54.000000000 +1100
 
26
+++ php5-5.0.4/scripts/php-config.in    2005-07-31 02:34:52.000000000 +1000
 
27
@@ -7,6 +7,7 @@
 
28
 ldflags="@PHP_LDFLAGS@"
 
29
 libs="@EXTRA_LIBS@"
 
30
 extension_dir='@EXTENSION_DIR@'
 
31
+phpapi="@DEBIAN_PHP_API@"
 
32
 
 
33
 case "$1" in
 
34
 --prefix)
 
35
@@ -21,8 +22,10 @@
 
36
        echo $extension_dir;;
 
37
 --version)
 
38
        echo $version;;
 
39
+--phpapi)
 
40
+       echo $phpapi;;
 
41
 *)
 
42
-       echo "Usage: $0 [--prefix|--includes|--ldflags|--libs|--extension-dir|--version]"
 
43
+       echo "Usage: $0 [--prefix|--includes|--ldflags|--libs|--extension-dir|--version|--phpapi]"
 
44
        exit 1;;
 
45
 esac
 
46