~ubuntu-branches/ubuntu/edgy/hwinfo/edgy

« back to all changes in this revision

Viewing changes to debian/patches/sparc_kioc

  • Committer: Bazaar Package Importer
  • Author(s): James Vega
  • Date: 2006-09-28 20:56:06 UTC
  • mfrom: (1.1.4 upstream)
  • Revision ID: james.westby@ubuntu.com-20060928205606-bgxl69hts04xbx51
Tags: 13.4-1
* New upstream version.
* Switch from dbs to quilt
  - Revamp debian/rules
  - Add quilt and remove dbs from Build-Depends in debian/control
* Remove reference to hwscan(8) from manpage. (closes: #388245)
* Re-wrote manpage from scratch.  Drop docbook-to-man from Build-Depends.
* Remove NEWS.Debian since it is no longer applicable.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
Index: src/hd/kbd.c
 
2
===================================================================
 
3
--- src/hd/kbd.c.orig
 
4
+++ src/hd/kbd.c
 
5
@@ -45,7 +45,6 @@
 
6
 typedef unsigned int u_int;
 
7
 #endif
 
8
 
 
9
-#include <asm/kbio.h>
 
10
 #include <asm/openpromio.h>
 
11
 #endif
 
12
 
 
13
@@ -254,8 +253,6 @@
 
14
 
 
15
   if((fd = open(DEV_KBD, O_RDWR | O_NONBLOCK | O_NOCTTY)) >= 0)
 
16
     {
 
17
-      if(ioctl(fd, KIOCTYPE, &kid)) kid = -1;
 
18
-      if(ioctl(fd, KIOCLAYOUT, &klay)) klay = -1;
 
19
       close(fd);
 
20
 
 
21
       if(kid != -1)