~ubuntu-branches/ubuntu/edgy/logrotate/edgy

« back to all changes in this revision

Viewing changes to debian/patches/30-config-h.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Paul Martin
  • Date: 2004-06-11 13:51:34 UTC
  • mfrom: (1.1.1 upstream)
  • mto: This revision was merged to the branch mainline in revision 3.
  • Revision ID: james.westby@ubuntu.com-20040611135134-xwwlztb186794ikt
Tags: 3.7-2
* Added commented out stuff in debian/rules to build a 
  logrotate-selinux package should Russell's move to get libselinux1 
  made "base" fail.
* Patch: 21-taboo-to-debug, reduces the "Ignoring..." messages of
  the taboo filter from ERROR to DEBUG. (Closes: #249073)
* Patch: 30-config-h, changed to fix upstream bug with mailing
  logs. (Closes: #253837)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#!/bin/sh -e
 
2
## 30-config-h.dpatch by Paul Martin <pm@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: No description.
 
6
 
 
7
if [ $# -lt 1 ]; then
 
8
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
9
    exit 1
 
10
fi
 
11
 
 
12
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
 
13
patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
 
14
 
 
15
case "$1" in
 
16
       -patch) patch $patch_opts -p1 < $0;;
 
17
       -unpatch) patch $patch_opts -p1 -R < $0;;
 
18
        *)
 
19
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
20
                exit 1;;
 
21
esac
 
22
 
 
23
exit 0
 
24
 
 
25
@DPATCH@
 
26
diff -urNad /home/pm/deb/logrotate/logrotate-3.7/config.h logrotate-3.7/config.h
 
27
--- /home/pm/deb/logrotate/logrotate-3.7/config.h       2004-06-11 13:48:48.000000000 +0100
 
28
+++ logrotate-3.7/config.h      2004-06-11 13:51:03.000000000 +0100
 
29
@@ -20,7 +20,7 @@
 
30
  * Default settings for Linux - leave these last.
 
31
  */
 
32
 #ifndef DEFAULT_MAIL_COMMAND
 
33
-    #define DEFAULT_MAIL_COMMAND "/bin/mail -s"
 
34
+    #define DEFAULT_MAIL_COMMAND "/usr/bin/mail"
 
35
 #endif
 
36
 
 
37
 #ifndef COMPRESS_COMMAND
 
38
@@ -36,6 +36,6 @@
 
39
 #endif
 
40
 
 
41
 #ifndef STATEFILE
 
42
-    #define STATEFILE "/var/lib/logrotate.status"
 
43
+    #define STATEFILE "/var/lib/logrotate/status"
 
44
 #endif
 
45