~ubuntu-branches/ubuntu/edgy/logrotate/edgy

« back to all changes in this revision

Viewing changes to debian/patches/40-datehack.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Paul Martin
  • Date: 2004-06-11 13:51:34 UTC
  • mfrom: (1.1.1 upstream)
  • mto: This revision was merged to the branch mainline in revision 3.
  • Revision ID: james.westby@ubuntu.com-20040611135134-xwwlztb186794ikt
Tags: 3.7-2
* Added commented out stuff in debian/rules to build a 
  logrotate-selinux package should Russell's move to get libselinux1 
  made "base" fail.
* Patch: 21-taboo-to-debug, reduces the "Ignoring..." messages of
  the taboo filter from ERROR to DEBUG. (Closes: #249073)
* Patch: 30-config-h, changed to fix upstream bug with mailing
  logs. (Closes: #253837)

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#!/bin/sh -e
 
2
## 40-datehack.dpatch by Paul Martin <pm@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: No description.
 
6
 
 
7
if [ $# -lt 1 ]; then
 
8
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
9
    exit 1
 
10
fi
 
11
 
 
12
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
 
13
patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
 
14
 
 
15
case "$1" in
 
16
       -patch) patch $patch_opts -p1 < $0;;
 
17
       -unpatch) patch $patch_opts -p1 -R < $0;;
 
18
        *)
 
19
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
 
20
                exit 1;;
 
21
esac
 
22
 
 
23
exit 0
 
24
 
 
25
@DPATCH@
 
26
diff -urNad /home/pm/deb/logrotate/logrotate-3.7/logrotate.c logrotate-3.7/logrotate.c
 
27
--- /home/pm/deb/logrotate/logrotate-3.7/logrotate.c    2004-02-11 18:34:51.000000000 +0000
 
28
+++ logrotate-3.7/logrotate.c   2004-02-11 18:43:28.000000000 +0000
 
29
@@ -981,7 +981,7 @@
 
30
        }
 
31
        
 
32
        /* Hack to hide earlier bug */
 
33
-       if ((year != 1900) && (year < 1996 || year > 2100)) {
 
34
+       if ((year != 1900) && (year < 1970 || year > 2100)) {
 
35
            message(MESS_ERROR, "bad year %d for file %s in state file %s\n",
 
36
                    year, argv[0], stateFilename);
 
37
            fclose(f);