~ubuntu-branches/ubuntu/gutsy/plotutils/gutsy

« back to all changes in this revision

Viewing changes to debian/patches/01_plotter.h.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Floris Bruynooghe
  • Date: 2006-06-10 22:30:09 UTC
  • mfrom: (3.1.1 dapper)
  • Revision ID: james.westby@ubuntu.com-20060610223009-lfgb9ceyzjykj3z1
Tags: 2.4.1-15
* 14_manpage_spline.dpatch: correct long option of -n (Closes: #247208).
* debian/control: changed maintainer email address, old will expire soon.
* Changed libpng12-0-dev (virtual) to libpng12-dev (real) in Build-Depends.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 03_plotter.h.dpatch by  <Floris Bruynooghe <fb102@soton.ac.uk>>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Patch of plotter.h for new C++.
 
6
 
 
7
@DPATCH@
 
8
diff -urNad plotutils-2.4.1/include/plotter.h /tmp/dpep.7ena0g/plotutils-2.4.1/include/plotter.h
 
9
--- plotutils-2.4.1/include/plotter.h   2006-05-31 13:58:37.000000000 +0100
 
10
+++ /tmp/dpep.7ena0g/plotutils-2.4.1/include/plotter.h  2006-06-06 13:11:41.265536701 +0100
 
11
@@ -58,8 +58,9 @@
 
12
 /* Include iostream, stdio support if this is libplotter rather than
 
13
    libplot. */
 
14
 #ifndef NOT_LIBPLOTTER
 
15
-#include <iostream.h>
 
16
+#include <iostream>
 
17
 #include <stdio.h>
 
18
+using namespace std;
 
19
 #endif
 
20
 
 
21
 /* THE GLOBAL VARIABLES IN GNU LIBPLOTTER */