~ubuntu-branches/ubuntu/gutsy/plotutils/gutsy

« back to all changes in this revision

Viewing changes to debian/patches/07_configure_in.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Floris Bruynooghe
  • Date: 2006-06-10 22:30:09 UTC
  • mfrom: (3.1.1 dapper)
  • Revision ID: james.westby@ubuntu.com-20060610223009-lfgb9ceyzjykj3z1
Tags: 2.4.1-15
* 14_manpage_spline.dpatch: correct long option of -n (Closes: #247208).
* debian/control: changed maintainer email address, old will expire soon.
* Changed libpng12-0-dev (virtual) to libpng12-dev (real) in Build-Depends.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh /usr/share/dpatch/dpatch-run
 
2
## 07_configure_in.dpatch by  <Floris Bruynooghe <fb102@soton.ac.uk>>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Update configure.in.
 
6
 
 
7
@DPATCH@
 
8
diff -urNad plotutils-2.4.1/configure.in /tmp/dpep.73LAfS/plotutils-2.4.1/configure.in
 
9
--- plotutils-2.4.1/configure.in        2005-05-09 20:53:19.259115574 +0100
 
10
+++ /tmp/dpep.73LAfS/plotutils-2.4.1/configure.in       2005-05-09 20:53:32.092786951 +0100
 
11
@@ -2,9 +2,11 @@
 
12
 dnl Copyright (C) 1989-2000 Free Software Foundation, Inc.
 
13
 dnl Process this file with autoconf to produce a configure script.
 
14
 
 
15
-AC_INIT(graph/graph.c)
 
16
-AM_INIT_AUTOMAKE(plotutils, 2.4.1)
 
17
-AM_CONFIG_HEADER(config.h)
 
18
+AC_INIT([plotutils], [2.4.1])
 
19
+AC_CONFIG_SRCDIR([graph/graph.c])
 
20
+AM_INIT_AUTOMAKE([no-define])
 
21
+AC_CONFIG_HEADERS([config.h])
 
22
+AM_MAINTAINER_MODE
 
23
 
 
24
 dnl Did installer set the CFLAGS and CXXFLAGS environ variables before
 
25
 dnl running configure?  Our default CFLAGS and CXXFLAGS differ from
 
26
@@ -32,7 +34,7 @@
 
27
 
 
28
 dnl Compiler characteristics and typedefs.
 
29
 AC_MSG_CHECKING(for void)
 
30
-AC_TRY_COMPILE(, [void *foo = 0;], [AC_MSG_RESULT(yes); AC_DEFINE(HAVE_VOID)], [AC_MSG_RESULT(no)])
 
31
+AC_TRY_COMPILE(, [void *foo = 0;], [AC_MSG_RESULT(yes); AC_DEFINE(HAVE_VOID, 1, [Define to signal compiler support for void and void * types.])], [AC_MSG_RESULT(no)])
 
32
 AC_C_CONST
 
33
 AC_TYPE_SIZE_T
 
34
 AC_TYPE_PID_T
 
35
@@ -55,16 +57,18 @@
 
36
     exit (1);
 
37
   else
 
38
     exit(0); }], 
 
39
-[AC_MSG_RESULT(yes); AC_DEFINE(HAVE_NULL_FLUSH)], [AC_MSG_RESULT(no); AC_DEFINE(DONT_HAVE_NULL_FLUSH)], [AC_MSG_RESULT(no); AC_DEFINE(DONT_HAVE_NULL_FLUSH)])
 
40
+[AC_MSG_RESULT(yes); AC_DEFINE(HAVE_NULL_FLUSH, 1, [Define to signal that fflush(NULL) works: it flushes all outstreams.])], [AC_MSG_RESULT(no); AC_DEFINE(DONT_HAVE_NULL_FLUSH, 1, [Redundant and unused: Define to signal that fflush(NULL) doesn't work.])], [AC_MSG_RESULT(no); AC_DEFINE(DONT_HAVE_NULL_FLUSH, 1, [Redundant and unused: Define to signal that fflush(NULL) doesn't work.])])
 
41
 
 
42
 dnl Checks for header files: ANSI C, POSIX, and nonstandard Unix headers.
 
43
 AC_HEADER_STDC
 
44
-AC_CHECK_HEADERS(string.h limits.h float.h)
 
45
-AC_CHECK_HEADERS(malloc.h pthread.h strings.h unistd.h values.h sys/select.h sys/stdtypes.h sys/time.h sys/types.h sys/wait.h)
 
46
 AC_HEADER_TIME
 
47
+AC_CHECK_HEADERS([string.h limits.h float.h malloc.h pthread.h \
 
48
+                strings.h unistd.h values.h sys/select.h \
 
49
+                sys/stdtypes.h sys/time.h sys/types.h sys/wait.h])
 
50
+
 
51
 
 
52
 dnl HP/UX needs a cpp definition for math.h to define matherr-related things
 
53
-AC_EGREP_HEADER(_HPUX_SOURCE, math.h, AC_EGREP_HEADER(matherr, math.h, AC_DEFINE(_HPUX_SOURCE)))
 
54
+AC_EGREP_HEADER(_HPUX_SOURCE, math.h, AC_EGREP_HEADER(matherr, math.h, AC_DEFINE(_HPUX_SOURCE, 1, [Define under HP/UX to get matherr-related things from math.h.])))
 
55
 
 
56
 dnl Sui generis.
 
57
 AC_FUNC_ALLOCA
 
58
@@ -82,7 +86,8 @@
 
59
 dnl that executables may be linked with a library that uses mutexes without
 
60
 dnl also linking with -lpthread.  (This is the case with glibc under
 
61
 dnl Linux.)
 
62
-AC_CHECK_LIB(c, pthread_mutex_init, AC_DEFINE(PTHREAD_SUPPORT))
 
63
+AH_TEMPLATE(PTHREAD_SUPPORT)
 
64
+AC_CHECK_LIB(c, pthread_mutex_init, [AC_DEFINE(PTHREAD_SUPPORT, 1, [Define to signal support in libc for the pthread threads library.])])
 
65
 
 
66
 dnl Do we have the thread-safe library functions ctime_r(), localtime_r()?
 
67
 AC_CHECK_FUNCS(ctime_r localtime_r)
 
68
@@ -93,8 +98,9 @@
 
69
 dnl Other non-X library functions and auxiliary libraries.
 
70
 dnl 
 
71
 dnl SGI's have matherr in libmx.a, not libm.a
 
72
-AC_CHECK_LIB(mx, matherr, LIBS="$LIBS -lmx", LIBS="$LIBS -lm")
 
73
+AC_SEARCH_LIBS(matherr, [mx m])
 
74
 AC_CHECK_FUNCS(memcpy memmove strchr strcasecmp strerror matherr j0 erf)
 
75
+
 
76
 dnl lgamma() and gamma() both compute the log of the gamma function.  There
 
77
 dnl are old systems out there which do not have lgamma (the name was
 
78
 dnl introduced after BSD 4.2), but which do have gamma.  Also some systems,
 
79
@@ -128,7 +134,7 @@
 
80
 dnl pthread support in libc, but no thread support in libXt/libX11.
 
81
 our_saved_LDFLAGS="$LDFLAGS"
 
82
 LDFLAGS="$X_LIBS $LDFLAGS"
 
83
-AC_CHECK_LIB(Xt, XtToolkitThreadInitialize, AC_DEFINE(X_THREAD_SUPPORT), , $X_PRE_LIBS $X_BASIC_LIBS $X_EXTRA_LIBS)
 
84
+AC_CHECK_LIB(Xt, XtToolkitThreadInitialize, [AC_DEFINE(X_THREAD_SUPPORT, 1, [Define to signal support in libXt/libX11 for multithreading.])], , [$X_PRE_LIBS $X_BASIC_LIBS $X_EXTRA_LIBS])
 
85
 LDFLAGS="$our_saved_LDFLAGS"
 
86
 
 
87
 dnl Check in -lXext for double buffering extensions to X11, and check
 
88
@@ -136,13 +142,14 @@
 
89
 dnl but not the other.)
 
90
 our_saved_LDFLAGS="$LDFLAGS"
 
91
 LDFLAGS="$X_LIBS $LDFLAGS"
 
92
-AC_CHECK_LIB(Xext, XdbeQueryExtension, AC_DEFINE(HAVE_DBE_SUPPORT), , -lX11 "$X_EXTRA_LIBS")
 
93
-AC_CHECK_LIB(Xext, XmbufQueryExtension, AC_DEFINE(HAVE_MBX_SUPPORT), , -lX11 "$X_EXTRA_LIBS")
 
94
+AC_CHECK_LIB(Xext, XdbeQueryExtension, [AC_DEFINE(HAVE_DBE_SUPPORT, 1, [Define to signal support in -lXext for the DBE X11 protocol extension.])], , [-lX11 "$X_EXTRA_LIBS"])
 
95
+AC_CHECK_LIB(Xext, XmbufQueryExtension, AC_DEFINE(HAVE_MBX_SUPPORT, 1, [Define to signal support in -lXext for the MBX X11 protocol extension.]), , -lX11 "$X_EXTRA_LIBS")
 
96
 LDFLAGS="$our_saved_LDFLAGS"
 
97
 
 
98
 our_saved_CPPFLAGS="$CPPFLAGS"
 
99
 CPPFLAGS="$X_CFLAGS $CPPFLAGS"
 
100
-AC_CHECK_HEADERS(X11/extensions/Xdbe.h X11/extensions/multibuf.h)
 
101
+AC_CHECK_HEADERS([X11/extensions/Xdbe.h X11/extensions/multibuf.h],
 
102
+       [], [], [#include <X11/Xlib.h>])
 
103
 CPPFLAGS="$our_saved_CPPFLAGS"
 
104
 
 
105
 dnl Allow installer to specify location of Athena widgets (i.e. location of
 
106
@@ -151,7 +158,9 @@
 
107
 dnl option to the head of X_LIBS and an `-I DIR/include' option to the head
 
108
 dnl of X_CFLAGS.
 
109
 
 
110
-AC_ARG_WITH(athena, [  --with-athena[=DIR]     use Athena widgets: includes and libraries in DIR])
 
111
+AC_ARG_WITH(athena,
 
112
+    AC_HELP_STRING([--with-athena[[=DIR]]],
 
113
+                       [use Athena widgets: includes and libraries in DIR]))
 
114
 
 
115
 dnl If --with-motif is specified, then `-lXm' will be added to the head of
 
116
 dnl X_TOOLKIT_LIBS, instead of `-lXaw -lXmu', and --with-athena will be
 
117
@@ -160,7 +169,9 @@
 
118
 dnl will be added to the head of X_LIBS and an `-I DIR/include' option to
 
119
 dnl the head of C_FLAGS.
 
120
 
 
121
-AC_ARG_WITH(motif, [  --with-motif[=DIR]      use Motif widgets: includes and libraries in DIR])
 
122
+AC_ARG_WITH(motif,
 
123
+    AC_HELP_STRING([--with-motif[[=DIR]]],
 
124
+                       [use Motif widgets: includes and libraries in DIR]))
 
125
 
 
126
 dnl If --with-motif is specified, we always check for the Xpm image
 
127
 dnl library, and if we find it, then we place it at the beginning of
 
128
@@ -169,7 +180,9 @@
 
129
 dnl for Xpm. If DIR is specified as an argument to --with-xpm, DIR/include
 
130
 dnl should contain xpm.h, and DIR/lib should contain the library libxpm.
 
131
 
 
132
-AC_ARG_WITH(xpm, [  --with-xpm[=DIR]        use Xpm with Motif: include and library in DIR])
 
133
+AC_ARG_WITH(xpm,
 
134
+    AC_HELP_STRING([--with-xpm[[=DIR]]],
 
135
+                       [use Xpm with Motif: include and library in DIR]))
 
136
 
 
137
 dnl NOTE: Motif 2.x also seems to require the extension library -lXp for
 
138
 dnl printing, so if --with-motif is specified we always check for libXp.
 
139
@@ -213,27 +226,27 @@
 
140
   our_saved_LDFLAGS="$LDFLAGS"
 
141
   LDFLAGS="$LDFLAGS $X_LIBS"
 
142
   case "x$with_xpm" in
 
143
-    xno|x)
 
144
-      AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, X_BASIC_LIBS="-lXpm $X_BASIC_LIBS", , -lXext -lX11) 
 
145
-      ;;
 
146
-    xyes)
 
147
-      AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, X_BASIC_LIBS="-lXpm $X_BASIC_LIBS", , -lXext -lX11) 
 
148
+    xyes|x)
 
149
+      AC_CHECK_LIB(Xpm, XpmReadFileToPixmap,
 
150
+                       [X_BASIC_LIBS="-lXpm $X_BASIC_LIBS"], [],
 
151
+                       [-lXext -lX11])
 
152
       ;;
 
153
+    xno) ;;
 
154
     *)
 
155
       LDFLAGS="$LDFLAGS -L$with_xpm/lib"
 
156
-      AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, X_CFLAGS="$X_CFLAGS -I$with_xpm/include"; X_LIBS="$X_LIBS -L$with_xpm/lib"; X_BASIC_LIBS="-lXpm $X_BASIC_LIBS", , -lXext -lX11) 
 
157
+      AC_CHECK_LIB(Xpm, XpmReadFileToPixmap,
 
158
+                       [X_CFLAGS="$X_CFLAGS -I$with_xpm/include"; X_LIBS="$X_LIBS -L$with_xpm/lib"; X_BASIC_LIBS="-lXpm $X_BASIC_LIBS"], [],
 
159
+                       [-lXext -lX11])
 
160
       ;;
 
161
   esac
 
162
-  LDFLAGS="$our_saved_LDFLAGS"
 
163
 
 
164
-  our_saved_LDFLAGS="$LDFLAGS"
 
165
-  LDFLAGS="$LDFLAGS $X_LIBS"
 
166
-  AC_CHECK_LIB(Xp, XpQueryExtension, X_BASIC_LIBS="-lXp $X_BASIC_LIBS", , -lXext -lX11) 
 
167
-  AC_CHECK_LIB(gen, regex, LIBS="$LIBS -lc -lgen", LIBS="$LIBS") 
 
168
-  AC_CHECK_LIB(PW, regex, LIBS="$LIBS -lc -lPW", LIBS="$LIBS") 
 
169
+  AC_CHECK_LIB(Xp, XpQueryExtension,
 
170
+                       [X_BASIC_LIBS="-lXp $X_BASIC_LIBS"], [],
 
171
+                       [-lXext -lX11])
 
172
+  AC_SEARCH_LIBS(regex, [gen PW])
 
173
   LDFLAGS="$our_saved_LDFLAGS"
 
174
 
 
175
-  AC_DEFINE(USE_MOTIF) 
 
176
+  AC_DEFINE(USE_MOTIF, 1, [Define to signal that Motif should be used, if X11 is used.])
 
177
   ;;
 
178
 esac
 
179
 
 
180
@@ -253,50 +266,70 @@
 
181
 dnl ALSO NOTE: the test for libpng automatically checks for zlib, since it
 
182
 dnl supplies the `-lz' argument to the linker.
 
183
 
 
184
-AC_CHECK_HEADERS(png.h, png_support="yes", png_support="no")
 
185
-AC_CHECK_LIB(png, png_set_tRNS, AC_DEFINE(HAVE_LIBPNG), png_support="no", -lz -lm)
 
186
-AC_ARG_WITH(libpng, [  --without-libpng        omit PNG support even if libpng and zlib are present], if test "x${with_libpng}" = "xno"; then png_support="no"; fi)
 
187
-if test "x${png_support}" = "xyes"; then AC_DEFINE(INCLUDE_PNG_SUPPORT) fi
 
188
-AM_CONDITIONAL(NO_PNG, test "x${png_support}" = "xno")
 
189
+AC_ARG_WITH(libpng,
 
190
+    AC_HELP_STRING([--without-libpng],
 
191
+       [omit PNG support even if libpng and zlib are present]))
 
192
+
 
193
+if test "${with_libpng:=yes}" = yes; then
 
194
+  AC_CHECK_HEADERS(png.h,
 
195
+    [AC_CHECK_LIB(png, png_set_tRNS,
 
196
+    [], [png_support="no"], [-lz -lm])],
 
197
+  [png_support="no"])
 
198
+fi
 
199
+if test "${png_support:=yes}" = "yes"; then
 
200
+  AC_DEFINE(INCLUDE_PNG_SUPPORT, 1, [Define to request PNG support (requires both HAVE_PNG_H and HAVE_LIBPNG).])
 
201
+fi
 
202
+AM_CONDITIONAL(NO_PNG, test "${png_support}" = no)
 
203
 
 
204
 dnl Font options.  The ps_fonts_in_pcl variable is used by test/plot2hpgl.test.
 
205
+AH_TEMPLATE(USE_PS_FONTS_IN_PCL)
 
206
 AC_ARG_ENABLE(ps-fonts-in-pcl,
 
207
-[  --enable-ps-fonts-in-pcl   enable use of PS fonts in PCL and HP-GL/2 output],
 
208
-[if test "x$enableval" = "xyes"; then
 
209
-  echo enabling support for the 35 PS fonts in PCL 5 and HP-GL/2 output
 
210
+    AC_HELP_STRING([--enable-ps-fonts-in-pcl],
 
211
+       [enable use of PS fonts in PCL and HP-GL/2 output]),
 
212
+  [
 
213
   ps_fonts_in_pcl=1
 
214
-  AC_DEFINE(USE_PS_FONTS_IN_PCL)
 
215
-else
 
216
-  ps_fonts_in_pcl=0
 
217
-fi],
 
218
-ps_fonts_in_pcl=0)
 
219
+  AC_DEFINE(USE_PS_FONTS_IN_PCL, 1, [Whether to use PS fonts in pcl output])
 
220
+  ],
 
221
+  [ps_fonts_in_pcl=0])
 
222
 AC_SUBST(ps_fonts_in_pcl)
 
223
 
 
224
+AH_TEMPLATE(USE_LJ_FONTS_IN_PS)
 
225
 AC_ARG_ENABLE(lj-fonts-in-ps,
 
226
-[  --enable-lj-fonts-in-ps    enable use of LaserJet fonts in PS output],
 
227
-[if test "x$enableval" = "xyes"; then
 
228
-  echo enabling support for the 45 LaserJet fonts in PS output
 
229
-  AC_DEFINE(USE_LJ_FONTS_IN_PS)
 
230
-fi])
 
231
+    AC_HELP_STRING([--enable-lj-fonts-in-ps],
 
232
+       [enable use of LaserJet fonts in PS output]),
 
233
+  [AC_DEFINE(USE_LJ_FONTS_IN_PS, 1, [Whether to use LaserJet fonts in PS output])])
 
234
 
 
235
+AH_TEMPLATE(USE_LJ_FONTS_IN_X)
 
236
 AC_ARG_ENABLE(lj-fonts-in-x,
 
237
-[  --enable-lj-fonts-in-x     enable use of LaserJet fonts on X displays],
 
238
-[if test "x$enableval" = "xyes"; then
 
239
-  echo enabling support for the 45 LaserJet fonts on X displays
 
240
-  AC_DEFINE(USE_LJ_FONTS_IN_X)
 
241
-fi])
 
242
+    AC_HELP_STRING([--enable-lj-fonts-in-x],
 
243
+       [enable use of LaserJet fonts on X displays]),
 
244
+  [AC_DEFINE(USE_LJ_FONTS_IN_X, 1, [Wheterh to use LaserJet fonts in X output])])
 
245
 
 
246
 dnl Do we build libplotter, the C++ library, and other C++ software?
 
247
-AC_LANG_SAVE
 
248
-AC_ARG_ENABLE(libplotter, [  --enable-libplotter     build the C++ Plotter class library and C++ software], echo enabling construction of the C++ class library; [AC_PROG_CXX] no_libplotter="no"; AC_MSG_CHECKING(whether ${CXX-g++} supports bool); [AC_LANG_CPLUSPLUS] AC_TRY_COMPILE(, [bool foo = true;], AC_MSG_RESULT(yes); AC_DEFINE(HAVE_BOOL), AC_MSG_RESULT(no)), no_libplotter="yes"; extralib="")
 
249
-AC_LANG_RESTORE
 
250
-AM_CONDITIONAL(NO_LIBPLOTTER, test "x$no_libplotter" = "xyes")
 
251
+AC_ARG_ENABLE(libplotter,
 
252
+    AC_HELP_STRING([--enable-libplotter],
 
253
+       [build the C++ Plotter class library and C++ software]))
 
254
+
 
255
+AC_PROG_CXX
 
256
+AC_LANG_PUSH(C++)
 
257
+AC_MSG_CHECKING(whether ${CXX-g++} supports bool)
 
258
+AH_TEMPLATE(HAVE_BOOL)
 
259
+AC_TRY_COMPILE(, [bool foo = true;],
 
260
+    [
 
261
+    AC_MSG_RESULT(yes)
 
262
+    AC_DEFINE(HAVE_BOOL, 1, [Define (if compiling as C++) to signal compiler support for bool type.])
 
263
+    ],
 
264
+    AC_MSG_RESULT(no))
 
265
+AC_LANG_POP
 
266
+AM_CONDITIONAL(ENABLE_LIBPLOTTER, [test "${enable_libplotter+set}" = set])
 
267
 
 
268
 dnl Do we build and install a standalone version of the libxmi
 
269
 dnl scan-conversion library?  (Not done by default because it's separately
 
270
 dnl distributed.)
 
271
-AC_ARG_ENABLE(libxmi, [  --enable-libxmi         build the libxmi scan-conversion library], echo enabling construction of the libxmi scan-conversion library; no_libxmi="no", no_libxmi="yes")
 
272
-AM_CONDITIONAL(NO_LIBXMI, test "x$no_libxmi" = "xyes")
 
273
+AC_ARG_ENABLE(libxmi,
 
274
+    AC_HELP_STRING([--enable-libxmi],
 
275
+       [build the libxmi scan-conversion library]))
 
276
+AM_CONDITIONAL(ENABLE_LIBXMI, [test "${enable_libxmi+set}" = set])
 
277
 
 
278
 dnl Override default autoconf value "-g -O2" or "-g" for CFLAGS and
 
279
 dnl CXXFLAGS, set by AC_PROG_CC and AC_PROG_CXX.  Provided, that is,
 
280
@@ -313,43 +346,28 @@
 
281
 dnl variable CFLAGS to "-O -belf" or "-O2 -belf".
 
282
 
 
283
 if test "x$CFLAGS_NOT_SET_BY_INSTALLER" = "xyes"; then
 
284
-if test "x$GCC" = "xyes"; then
 
285
-  CFLAGS="-O2"
 
286
-else
 
287
-  CFLAGS="-O"
 
288
-fi
 
289
+  if test "x$GCC" = "xyes"; then
 
290
+    CFLAGS="-O2"
 
291
+  else
 
292
+    CFLAGS="-O"
 
293
+  fi
 
294
 fi
 
295
 
 
296
 if test "x$CXXFLAGS_NOT_SET_BY_INSTALLER" = "xyes"; then
 
297
-if test "x$GXX" = "xyes"; then
 
298
-  CXXFLAGS="-O2"
 
299
-else
 
300
-  CXXFLAGS="-O"
 
301
-fi
 
302
-fi
 
303
-
 
304
-dnl Check for gcc strength-reduce bug (taken from WINE config).  Could do
 
305
-dnl the same for g++, but we'll assume anyone doing any C++ compiling has
 
306
-dnl installed a modern compiler.
 
307
-if test "x${GCC}" = "xyes"; then
 
308
-  AC_CACHE_CHECK("for gcc strength-reduce bug", ac_cv_c_gcc_strength_bug,
 
309
-                 AC_TRY_RUN([
 
310
-int main()
 
311
-{
 
312
-  static int Array[[3]];
 
313
-  unsigned int B = 3;
 
314
-  int i;
 
315
-  for (i=0; i < B; i++)
 
316
-    Array[[i]] = i - 3;
 
317
-  exit (Array[[1]] != -2);
 
318
-}],
 
319
-    ac_cv_c_gcc_strength_bug="no",
 
320
-    ac_cv_c_gcc_strength_bug="yes",
 
321
-    ac_cv_c_gcc_strength_bug="yes") )
 
322
-  if test "$ac_cv_c_gcc_strength_bug" = "yes"
 
323
-  then
 
324
-    CFLAGS="$CFLAGS -fno-strength-reduce"
 
325
+  if test "x$GXX" = "xyes"; then
 
326
+    CXXFLAGS="-O2"
 
327
+  else
 
328
+    CXXFLAGS="-O"
 
329
   fi
 
330
 fi
 
331
 
 
332
-AC_OUTPUT(Makefile double/Makefile graph/Makefile pic2plot/Makefile pic2plot/doc/Makefile pic2plot/libgroff/Makefile pic2plot/include/Makefile info/Makefile lib/Makefile libplot/Makefile libplotter/Makefile libxmi/Makefile libxmi/info/Makefile plot/Makefile tek2plot/Makefile tek2plot/teksamples/Makefile plotfont/Makefile spline/Makefile ode/Makefile ode-examples/Makefile include/Makefile doc/Makefile fonts/Makefile fonts/bdf/Makefile fonts/pcf/Makefile fonts/pfb/Makefile test/Makefile)
 
333
+AC_OUTPUT([Makefile double/Makefile graph/Makefile pic2plot/Makefile
 
334
+          pic2plot/doc/Makefile pic2plot/libgroff/Makefile
 
335
+          pic2plot/include/Makefile info/Makefile lib/Makefile
 
336
+          libplot/Makefile libplotter/Makefile libxmi/Makefile
 
337
+          libxmi/info/Makefile plot/Makefile tek2plot/Makefile
 
338
+          tek2plot/teksamples/Makefile plotfont/Makefile
 
339
+          spline/Makefile ode/Makefile ode-examples/Makefile
 
340
+          include/Makefile doc/Makefile fonts/Makefile
 
341
+          fonts/bdf/Makefile fonts/pcf/Makefile fonts/pfb/Makefile
 
342
+          test/Makefile])