~ubuntu-branches/ubuntu/hardy/ghostscript/hardy

« back to all changes in this revision

Viewing changes to debian/patches/09_ijs_krgb_support.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Till Kamppeter
  • Date: 2007-11-22 12:17:43 UTC
  • mfrom: (1.1.7 upstream)
  • Revision ID: james.westby@ubuntu.com-20071122121743-cd70s3ypq0r243mp
Tags: 8.61.dfsg.1-0ubtuntu1
* New upstream release
  o Final 8.61 release
* debian/patches/09_ijs_krgb_support.dpatch: Adapted to upstream changes.
* debian/rules: Updated CUPS-related variables for "make install" calls.
* debian/rules: Remove /usr/include/ghostscript from the ghostscript
  package, they go into lings-dev.

Show diffs side-by-side

added added

removed removed

Lines of Context:
77
77
    acquire an API for changing resolution. */
78
78
 int gdev_prn_maybe_realloc_memory(gx_device_printer *pdev,
79
79
@@ -49,6 +84,14 @@
80
 
 private dev_proc_put_params(gsijs_put_params);
81
 
 private dev_proc_finish_copydevice(gsijs_finish_copydevice);
 
80
 static dev_proc_put_params(gsijs_put_params);
 
81
 static dev_proc_finish_copydevice(gsijs_finish_copydevice);
82
82
 
83
83
+/* Following definitions are for krgb support. */
84
 
+private dev_proc_create_buf_device(gsijs_create_buf_device);
85
 
+private dev_proc_fill_rectangle(gsijs_fill_rectangle);
86
 
+private dev_proc_copy_mono(gsijs_copy_mono);
87
 
+private dev_proc_fill_mask(gsijs_fill_mask);
88
 
+private dev_proc_fill_path(gsijs_fill_path);
89
 
+private dev_proc_stroke_path(gsijs_stroke_path);
 
84
+static dev_proc_create_buf_device(gsijs_create_buf_device);
 
85
+static dev_proc_fill_rectangle(gsijs_fill_rectangle);
 
86
+static dev_proc_copy_mono(gsijs_copy_mono);
 
87
+static dev_proc_fill_mask(gsijs_fill_mask);
 
88
+static dev_proc_fill_path(gsijs_fill_path);
 
89
+static dev_proc_stroke_path(gsijs_stroke_path);
90
90
+
91
 
 private const gx_device_procs gsijs_procs = {
 
91
 static const gx_device_procs gsijs_procs = {
92
92
        gsijs_open,
93
93
        NULL,   /* get_initial_matrix */
94
94
@@ -123,6 +166,15 @@
141
141
+   0x01     /* 7 */
142
142
+};
143
143
+
144
 
+private int gsijs_fill_rectangle(gx_device * dev, int x, int y, int w, int h,
 
144
+static int gsijs_fill_rectangle(gx_device * dev, int x, int y, int w, int h,
145
145
+           gx_color_index color)
146
146
+{
147
147
+   gx_device_ijs *ijsdev = (gx_device_ijs *)((gx_device_forward *)dev)->target;
203
203
+   return (*ijsdev->prn_procs.fill_rectangle)(dev, x, y, w, h, color);
204
204
+}
205
205
+
206
 
+private int gsijs_copy_mono(gx_device * dev, const byte * data,
 
206
+static int gsijs_copy_mono(gx_device * dev, const byte * data,
207
207
+      int dx, int draster, gx_bitmap_id id,
208
208
+      int x, int y, int w, int height, gx_color_index zero, gx_color_index one)
209
209
+{
280
280
+
281
281
+/* ---------------- High-level graphic procedures ---------------- */
282
282
+
283
 
+private int gsijs_fill_mask(gx_device * dev,
 
283
+static int gsijs_fill_mask(gx_device * dev,
284
284
+      const byte * data, int dx, int raster, gx_bitmap_id id,
285
285
+      int x, int y, int w, int h,
286
286
+      const gx_drawing_color * pdcolor, int depth,
302
302
+   return code;
303
303
+}
304
304
+
305
 
+private int gsijs_fill_path(gx_device * dev, const gs_imager_state * pis,
 
305
+static int gsijs_fill_path(gx_device * dev, const gs_imager_state * pis,
306
306
+      gx_path * ppath, const gx_fill_params * params,
307
307
+      const gx_drawing_color * pdcolor,
308
308
+      const gx_clip_path * pcpath)
319
319
+   return 0;
320
320
+}
321
321
+
322
 
+private int gsijs_stroke_path(gx_device * dev, const gs_imager_state * pis,
 
322
+static int gsijs_stroke_path(gx_device * dev, const gs_imager_state * pis,
323
323
+        gx_path * ppath, const gx_stroke_params * params,
324
324
+        const gx_drawing_color * pdcolor,
325
325
+        const gx_clip_path * pcpath)
338
338
+
339
339
+/* ---------------- krgb banding playback procedures ---------------- */
340
340
+
341
 
+private int gsijs_get_bits(gx_device_printer * pdev, int y, byte * str, byte ** actual_data)
 
341
+static int gsijs_get_bits(gx_device_printer * pdev, int y, byte * str, byte ** actual_data)
342
342
+{
343
343
+   gx_device_ijs *ijsdev = (gx_device_ijs *)pdev;
344
344
+   gx_device_clist_common *cdev = (gx_device_clist_common *)pdev;
356
356
+   return gdev_prn_get_bits(pdev, y, str, actual_data);  /* get raster from regular band */
357
357
+}
358
358
+
359
 
+private int gsijs_k_get_bits(gx_device_printer * pdev, int y, byte ** actual_data)
 
359
+static int gsijs_k_get_bits(gx_device_printer * pdev, int y, byte ** actual_data)
360
360
+{
361
361
+   gx_device_ijs *ijsdev = (gx_device_ijs *)pdev;
362
362
+   gx_device_clist_common *cdev = (gx_device_clist_common *)pdev;
370
370
+   return 0;
371
371
+}
372
372
+
373
 
+private int gsijs_create_buf_device(gx_device **pbdev, gx_device *target,
 
373
+static int gsijs_create_buf_device(gx_device **pbdev, gx_device *target,
374
374
+            const gx_render_plane_t *render_plane, gs_memory_t *mem, gx_band_complexity_t *band_complexity)
375
375
+{
376
376
+   gx_device_ijs *ijsdev = (gx_device_ijs *)target;
393
393
+}
394
394
+
395
395
+/* See if IJS server supports krgb. */
396
 
+private int
 
396
+static int
397
397
+gsijs_set_krgb_mode(gx_device_ijs *ijsdev)
398
398
+{
399
399
+    char buf[256];
425
425
+
426
426
+/* ------ Private definitions ------ */
427
427
 
428
 
 private int
 
428
 static int
429
429
 gsijs_parse_wxh (const char *val, int size, double *pw, double *ph)
430
430
@@ -209,34 +554,6 @@
431
431
 }
436
436
- * This version is specialized for hpijs 1.0 through 1.0.2, and
437
437
- * accommodates a number of quirks.
438
438
- **/
439
 
-private int
 
439
-static int
440
440
-gsijs_set_generic_params_hpijs(gx_device_ijs *ijsdev)
441
441
-{
442
442
-    char buf[256];
461
461
-/**
462
462
  * gsijs_set_generic_params: Set generic IJS parameters.
463
463
  **/
464
 
 private int
 
464
 static int
465
465
@@ -247,9 +564,6 @@
466
466
     int i, j;
467
467
     char *value;
481
481
- * This version is specialized for hpijs 1.0 through 1.0.2, and
482
482
- * accommodates a number of quirks.
483
483
- **/
484
 
-private int
 
484
-static int
485
485
-gsijs_set_margin_params_hpijs(gx_device_ijs *ijsdev)
486
486
-{
487
487
-    char buf[256];
540
540
-/**
541
541
  * gsijs_set_margin_params: Do margin negotiation with IJS server.
542
542
  **/
543
 
 private int
 
543
 static int
544
544
@@ -362,9 +614,6 @@
545
545
     int i, j;
546
546
     char *value;
593
593
     return min(width, end);
594
594
 }
595
595
 
596
 
-private int ijs_all_white(unsigned char *data, int size)
 
596
-static int ijs_all_white(unsigned char *data, int size)
597
597
-{
598
598
-   int clean = 1;
599
599
-   int i;
749
749
 }
750
750
751
751
 
752
 
 private int
 
752
 static int
753
753
 gsijs_set_color_format(gx_device_ijs *ijsdev)