~ubuntu-branches/ubuntu/hardy/openldap2.3/hardy-updates

« back to all changes in this revision

Viewing changes to debian/patches/gnutls-altname-nulterminated

  • Committer: Bazaar Package Importer
  • Author(s): Steve Langasek
  • Date: 2008-03-04 01:59:51 UTC
  • Revision ID: james.westby@ubuntu.com-20080304015951-vt9xyp5gxs13g2p7
Tags: 2.4.7-6ubuntu1
* Merge from Debian unstable, remaining changes:
  + debian/patches/SECURITY_CVE-2008-0658.patch (LP: #197077)
    slapd/back-bdb/modrdn.c in the BDB backend for slapd in OpenLDAP 2.3.39
    allows remote authenticated users to cause a denial of service (daemon
    crash) via a modrdn operation with a NOOP (LDAP_X_NO_OPERATION)
    control, a related issue to CVE-2007-6698.
  + debian/apparmor-profile: add AppArmor profile
  + debian/slapd.postinst: Reload AA profile on configuration
  + updated debian/slapd.README.Debian for note on AppArmor
  + debian/control: Replaces apparmor-profiles << 2.1+1075-0ubuntu4 as we
    should now take control
  + debian/control: Conflicts with apparmor-profiles << 2.1+1075-0ubuntu4
    to make sure that if earlier version of apparmor-profiles gets
    installed it won't overwrite our profile
  + Modify Maintainer value to match the DebianMaintainerField
    specification.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
Author: Steve Langasek <vorlon@debian.org>
2
 
 
3
 
When using GnuTLS, the size returned for subjectAltNames includes a
4
 
terminating NUL whereas the size of a CN does not; account for this
5
 
difference when comparing certificates.
6
 
 
7
 
Partially addresses Debian bug #462588.
8
 
 
9
 
Forwarded upstream as ITS #5361.
10
 
 
11
 
Index: libraries/libldap/tls.c
12
 
===================================================================
13
 
--- libraries/libldap/tls.c     (revision 1074)
14
 
+++ libraries/libldap/tls.c     (working copy)
15
 
@@ -1846,7 +1846,7 @@
16
 
                        if (ntype != IS_DNS) continue;
17
 
        
18
 
                        /* Is this an exact match? */
19
 
-                       if ((len1 == altnamesize) && !strncasecmp(name, altname, len1)) {
20
 
+                       if ((len1 == altnamesize - 1) && !strncasecmp(name, altname, len1)) {
21
 
                                break;
22
 
                        }
23