~ubuntu-branches/ubuntu/hoary/heimdal/hoary-security

« back to all changes in this revision

Viewing changes to debian/patches-0.4e-old/011_sharedlibs

  • Committer: Bazaar Package Importer
  • Author(s): Brian May
  • Date: 2004-05-31 08:30:54 UTC
  • Revision ID: james.westby@ubuntu.com-20040531083054-vskpch8y0p1pv8lv
Tags: 0.6.2-3
* Use default realm configured by krb5-config for KDC (closes:
  #251725).
* Move push.8 man page from heimdal-servers to heimdal-clients
  (push binary is already in heimdal-clients).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -ruN heimdal-0.4e-old/cf/Makefile.am.common heimdal-0.4e/cf/Makefile.am.common
 
2
--- heimdal-0.4e-old/cf/Makefile.am.common      Sat Sep  1 21:12:18 2001
 
3
+++ heimdal-0.4e/cf/Makefile.am.common  Thu Nov 15 11:59:31 2001
 
4
@@ -169,8 +169,7 @@
 
5
 endif
 
6
 
 
7
 if KRB5
 
8
-LIB_krb5 = $(top_builddir)/lib/krb5/libkrb5.la \
 
9
-       $(top_builddir)/lib/asn1/libasn1.la
 
10
+LIB_krb5 = $(top_builddir)/lib/krb5/libkrb5.la
 
11
 LIB_gssapi = $(top_builddir)/lib/gssapi/libgssapi.la
 
12
 endif
 
13
 
 
14
diff -ruN heimdal-0.4e-old/configure.in heimdal-0.4e/configure.in
 
15
--- heimdal-0.4e-old/configure.in       Thu Sep  6 22:22:03 2001
 
16
+++ heimdal-0.4e/configure.in   Thu Nov 15 12:01:18 2001
 
17
@@ -86,14 +86,17 @@
 
18
        LIB_openldap="-R $openldap_libdir $LIB_openldap"
 
19
 fi
 
20
 
 
21
-AC_TEST_PACKAGE_NEW(krb4,[#include <krb.h>],-lkrb,-ldes,/usr/athena, KRB4)
 
22
+AC_TEST_PACKAGE_NEW(krb4,[#include <krb.h>],-lkrb,,,KRB4)
 
23
+if test "$krb4_libdir" = "/usr/lib"; then
 
24
+  krb4_libdir="";
 
25
+fi
 
26
 
 
27
 LIB_kdb=
 
28
 if test "$with_krb4" != "no"; then
 
29
        save_CFLAGS="$CFLAGS"
 
30
        CFLAGS="$CFLAGS $INCLUDE_krb4"
 
31
        save_LIBS="$LIBS"
 
32
-       LIBS="$LIB_krb4 -ldes $LIBS"
 
33
+       LIBS="$LIB_krb4 $LIBS"
 
34
        EXTRA_LIB45=lib45.a
 
35
        AC_SUBST(EXTRA_LIB45)
 
36
        AC_CACHE_CHECK(for four valued krb_put_int, ac_cv_func_krb_put_int_four,
 
37
@@ -156,7 +159,7 @@
 
38
        LIBS="$save_LIBS"
 
39
        CFLAGS="$save_CFLAGS"
 
40
        LIB_kdb="-lkdb -lkrb"
 
41
-       if test "$krb4_libdir"; then
 
42
+       if test "$krb4_libdir" != ""; then
 
43
                LIB_krb4="-R $krb4_libdir $LIB_krb4"
 
44
                LIB_kdb="-R $krb4_libdir -L$krb4_libdir $LIB_kdb"
 
45
        fi
 
46
diff -ruN heimdal-0.4e-old/lib/asn1/Makefile.am heimdal-0.4e/lib/asn1/Makefile.am
 
47
--- heimdal-0.4e-old/lib/asn1/Makefile.am       Mon Sep  3 02:56:45 2001
 
48
+++ heimdal-0.4e/lib/asn1/Makefile.am   Thu Nov 15 11:59:31 2001
 
49
@@ -6,6 +6,8 @@
 
50
 
 
51
 lib_LTLIBRARIES = libasn1.la
 
52
 libasn1_la_LDFLAGS = -version-info 5:0:0
 
53
+libasn1_la_LIBADD = \
 
54
+       $(top_builddir)/lib/com_err/libcom_err.la
 
55
 
 
56
 libasn1_la_LIBADD = @LIB_com_err@
 
57
 
 
58
diff -ruN heimdal-0.4e-old/lib/editline/Makefile.am heimdal-0.4e/lib/editline/Makefile.am
 
59
--- heimdal-0.4e-old/lib/editline/Makefile.am   Wed Nov 15 10:22:29 2000
 
60
+++ heimdal-0.4e/lib/editline/Makefile.am       Thu Nov 15 11:59:31 2001
 
61
@@ -38,13 +38,13 @@
 
62
        unix.h \
 
63
        $(EXTRA_SOURCE)
 
64
 
 
65
-libeditline_la_LDFLAGS = -static
 
66
+libeditline_la_LDFLAGS = -no-undefined
 
67
 
 
68
 EXTRA_SOURCE = $(ES) 
 
69
 
 
70
 libel_compat_la_SOURCES = edit_compat.c
 
71
 
 
72
-libel_compat_la_LDFLAGS = -static
 
73
+libel_compat_la_LDFLAGS = -no-undefined
 
74
 
 
75
 EXTRA_DIST = $(man_MANS)
 
76
 
 
77
diff -ruN heimdal-0.4e-old/lib/krb5/Makefile.am heimdal-0.4e/lib/krb5/Makefile.am
 
78
--- heimdal-0.4e-old/lib/krb5/Makefile.am       Thu Sep  6 22:19:16 2001
 
79
+++ heimdal-0.4e/lib/krb5/Makefile.am   Thu Nov 15 11:59:31 2001
 
80
@@ -11,16 +11,15 @@
 
81
 check_PROGRAMS = n-fold-test string-to-key-test derived-key-test store-test
 
82
 TESTS = n-fold-test string-to-key-test derived-key-test store-test 
 
83
 
 
84
-LDADD = libkrb5.la \
 
85
-       $(LIB_des) \
 
86
-       $(top_builddir)/lib/asn1/libasn1.la \
 
87
-       $(LIB_roken)
 
88
+LDADD = libkrb5.la
 
89
 
 
90
 libkrb5_la_LIBADD = \
 
91
-       ../com_err/error.lo ../com_err/com_err.lo \
 
92
+       $(LIB_res_search) \
 
93
+       $(top_builddir)/lib/com_err/libcom_err.la \
 
94
        $(LIB_des) \
 
95
        $(top_builddir)/lib/asn1/libasn1.la \
 
96
-       $(LIB_roken)
 
97
+       $(LIB_roken) \
 
98
+       $(LIB_dbopen)
 
99
 
 
100
 lib_LTLIBRARIES = libkrb5.la
 
101
 
 
102
diff -ruN heimdal-0.4e-old/lib/vers/Makefile.am heimdal-0.4e/lib/vers/Makefile.am
 
103
--- heimdal-0.4e-old/lib/vers/Makefile.am       Fri Aug 24 08:41:03 2001
 
104
+++ heimdal-0.4e/lib/vers/Makefile.am   Mon Nov 19 17:18:52 2001
 
105
@@ -14,11 +14,12 @@
 
106
 if KRB5
 
107
 ## need to link with des here; otherwise, if krb4 is shared the link
 
108
 ## will fail with unresolved references
 
109
-make_print_version_LDADD = $(LIB_krb4) -ldes
 
110
+make_print_version_LDADD = $(LIB_krb4)
 
111
 endif
 
112
 endif
 
113
 
 
114
 libvers_la_SOURCES     = print_version.c
 
115
+libvers_la_LDFLAGS     = -no-undefined
 
116
 
 
117
 print_version.lo: print_version.h
 
118
 
 
119
diff -ruN heimdal-0.4e-old/tools/krb5-config.in heimdal-0.4e/tools/krb5-config.in
 
120
--- heimdal-0.4e-old/tools/krb5-config.in       Mon Jan 29 17:56:51 2001
 
121
+++ heimdal-0.4e/tools/krb5-config.in   Thu Nov 15 11:59:31 2001
 
122
@@ -89,6 +89,9 @@
 
123
 if test "$do_libs" = "yes"; then
 
124
     lib_flags="-L${libdir}"
 
125
     case $library in
 
126
+    krb5)
 
127
+       lib_flags="$lib_flags -lkrb5"
 
128
+       ;;
 
129
     gssapi)
 
130
        lib_flags="$lib_flags -lgssapi"
 
131
        ;;
 
132
@@ -99,8 +102,8 @@
 
133
        lib_flags="$lib_flags -lkadm5srv"
 
134
        ;;
 
135
     esac
 
136
-    lib_flags="$lib_flags -lkrb5 -lasn1 @LIB_des_appl@ -lroken"
 
137
-    lib_flags="$lib_flags @LIB_crypt@ @LIB_dbopen@ @LIBS@"
 
138
+#    lib_flags="$lib_flags -lkrb5 -lasn1 @LIB_des_appl@ -lroken"
 
139
+#    lib_flags="$lib_flags @LIB_crypt@ @LIB_dbopen@ @LIBS@"
 
140
     echo $lib_flags
 
141
 fi
 
142
 if test "$do_cflags" = "yes"; then