~ubuntu-branches/ubuntu/hoary/heimdal/hoary-security

« back to all changes in this revision

Viewing changes to debian/patches/032_libtool_version_script

  • Committer: Bazaar Package Importer
  • Author(s): Brian May
  • Date: 2004-05-31 08:30:54 UTC
  • Revision ID: james.westby@ubuntu.com-20040531083054-vskpch8y0p1pv8lv
Tags: 0.6.2-3
* Use default realm configured by krb5-config for KDC (closes:
  #251725).
* Move push.8 man page from heimdal-servers to heimdal-clients
  (push binary is already in heimdal-clients).

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
diff -ruN heimdal-0.6.2-old/aclocal.m4 heimdal-0.6.2/aclocal.m4
 
2
--- heimdal-0.6.2-old/aclocal.m4        2004-05-11 10:11:33.000000000 +1000
 
3
+++ heimdal-0.6.2/aclocal.m4    2004-05-11 10:15:47.000000000 +1000
 
4
@@ -2508,6 +2508,9 @@
 
5
     sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
 
6
   fi
 
7
 
 
8
+  # argument to support GNU version scripts
 
9
+  version_script_arg='${wl}--version-script=\${libname}.ver'
 
10
+
 
11
   # We used to test for /lib/ld.so.1 and disable shared libraries on
 
12
   # powerpc, because MkLinux only supported shared libraries with the
 
13
   # GNU dynamic linker.  Since this was broken with cross compilers,
 
14
@@ -3745,8 +3748,8 @@
 
15
   # Check if GNU C++ uses GNU ld as the underlying linker, since the
 
16
   # archiving commands below assume that GNU ld is being used.
 
17
   if test "$with_gnu_ld" = yes; then
 
18
-    _LT_AC_TAGVAR(archive_cmds, $1)='$CC -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname -o $lib'
 
19
-    _LT_AC_TAGVAR(archive_expsym_cmds, $1)='$CC -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
 
20
+    _LT_AC_TAGVAR(archive_cmds, $1)='$CC -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname $version_script_arg -o $lib'
 
21
+    _LT_AC_TAGVAR(archive_expsym_cmds, $1)='$CC -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols $version_script_arg -o $lib'
 
22
 
 
23
     _LT_AC_TAGVAR(hardcode_libdir_flag_spec, $1)='${wl}--rpath ${wl}$libdir'
 
24
     _LT_AC_TAGVAR(export_dynamic_flag_spec, $1)='${wl}--export-dynamic'
 
25
@@ -4897,7 +4900,7 @@
 
26
     lt_cv_sys_global_symbol_pipe lt_cv_sys_global_symbol_to_cdecl \
 
27
     lt_cv_sys_global_symbol_to_c_name_address \
 
28
     sys_lib_search_path_spec sys_lib_dlsearch_path_spec \
 
29
-    old_postinstall_cmds old_postuninstall_cmds \
 
30
+    old_postinstall_cmds old_postuninstall_cmds version_script_arg \
 
31
     _LT_AC_TAGVAR(compiler, $1) \
 
32
     _LT_AC_TAGVAR(CC, $1) \
 
33
     _LT_AC_TAGVAR(LD, $1) \
 
34
@@ -5098,6 +5101,9 @@
 
35
 # Object file suffix (normally "o").
 
36
 objext="$ac_objext"
 
37
 
 
38
+# Linker argument to specify a version script (if supported)
 
39
+version_script_arg="$version_script_arg"
 
40
+
 
41
 # Old archive suffix (normally "a").
 
42
 libext="$libext"
 
43
 
 
44
@@ -6214,7 +6220,7 @@
 
45
 
 
46
   linux*)
 
47
     if $LD --help 2>&1 | grep ': supported targets:.* elf' > /dev/null; then
 
48
-        tmp_archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
 
49
+        tmp_archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname $version_script_arg -o $lib'
 
50
        _LT_AC_TAGVAR(archive_cmds, $1)="$tmp_archive_cmds"
 
51
       supports_anon_versioning=no
 
52
       case `$LD -v 2>/dev/null` in
 
53
diff -ruN heimdal-0.6.2-old/configure heimdal-0.6.2/configure
 
54
--- heimdal-0.6.2-old/configure 2004-05-11 10:11:34.000000000 +1000
 
55
+++ heimdal-0.6.2/configure     2004-05-11 10:18:06.000000000 +1000
 
56
@@ -7559,7 +7559,7 @@
 
57
 
 
58
   linux*)
 
59
     if $LD --help 2>&1 | grep ': supported targets:.* elf' > /dev/null; then
 
60
-        tmp_archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
 
61
+        tmp_archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname $version_script_arg -o $lib'
 
62
        archive_cmds="$tmp_archive_cmds"
 
63
       supports_anon_versioning=no
 
64
       case `$LD -v 2>/dev/null` in
 
65
@@ -8677,6 +8677,9 @@
 
66
     sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
 
67
   fi
 
68
 
 
69
+  # argument to support GNU version scripts
 
70
+  version_script_arg='${wl}--version-script=\${libname}.ver'
 
71
+
 
72
   # We used to test for /lib/ld.so.1 and disable shared libraries on
 
73
   # powerpc, because MkLinux only supported shared libraries with the
 
74
   # GNU dynamic linker.  Since this was broken with cross compilers,
 
75
@@ -9815,7 +9818,7 @@
 
76
     lt_cv_sys_global_symbol_pipe lt_cv_sys_global_symbol_to_cdecl \
 
77
     lt_cv_sys_global_symbol_to_c_name_address \
 
78
     sys_lib_search_path_spec sys_lib_dlsearch_path_spec \
 
79
-    old_postinstall_cmds old_postuninstall_cmds \
 
80
+    old_postinstall_cmds old_postuninstall_cmds version_script_arg \
 
81
     compiler \
 
82
     CC \
 
83
     LD \
 
84
@@ -10013,6 +10016,9 @@
 
85
 # Object file suffix (normally "o").
 
86
 objext="$ac_objext"
 
87
 
 
88
+# Linker argument to specify a version script (if supported)
 
89
+version_script_arg="$version_script_arg"
 
90
+
 
91
 # Old archive suffix (normally "a").
 
92
 libext="$libext"
 
93
 
 
94
@@ -10530,8 +10536,8 @@
 
95
   # Check if GNU C++ uses GNU ld as the underlying linker, since the
 
96
   # archiving commands below assume that GNU ld is being used.
 
97
   if test "$with_gnu_ld" = yes; then
 
98
-    archive_cmds_CXX='$CC -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname -o $lib'
 
99
-    archive_expsym_cmds_CXX='$CC -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols -o $lib'
 
100
+    archive_cmds_CXX='$CC -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname $version_script_arg -o $lib'
 
101
+    archive_expsym_cmds_CXX='$CC -shared -nostdlib $predep_objects $libobjs $deplibs $postdep_objects $compiler_flags ${wl}-soname $wl$soname ${wl}-retain-symbols-file $wl$export_symbols $version_script_arg -o $lib'
 
102
 
 
103
     hardcode_libdir_flag_spec_CXX='${wl}--rpath ${wl}$libdir'
 
104
     export_dynamic_flag_spec_CXX='${wl}--export-dynamic'
 
105
@@ -12369,6 +12375,9 @@
 
106
     sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
 
107
   fi
 
108
 
 
109
+  # argument to support GNU version scripts
 
110
+  version_script_arg='${wl}--version-script=\${libname}.ver'
 
111
+
 
112
   # We used to test for /lib/ld.so.1 and disable shared libraries on
 
113
   # powerpc, because MkLinux only supported shared libraries with the
 
114
   # GNU dynamic linker.  Since this was broken with cross compilers,
 
115
@@ -13433,7 +13442,7 @@
 
116
     lt_cv_sys_global_symbol_pipe lt_cv_sys_global_symbol_to_cdecl \
 
117
     lt_cv_sys_global_symbol_to_c_name_address \
 
118
     sys_lib_search_path_spec sys_lib_dlsearch_path_spec \
 
119
-    old_postinstall_cmds old_postuninstall_cmds \
 
120
+    old_postinstall_cmds old_postuninstall_cmds version_script_arg \
 
121
     compiler_CXX \
 
122
     CC_CXX \
 
123
     LD_CXX \
 
124
@@ -13583,6 +13592,9 @@
 
125
 # Object file suffix (normally "o").
 
126
 objext="$ac_objext"
 
127
 
 
128
+# Linker argument to specify a version script (if supported)
 
129
+version_script_arg="$version_script_arg"
 
130
+
 
131
 # Old archive suffix (normally "a").
 
132
 libext="$libext"
 
133
 
 
134
@@ -14412,7 +14424,7 @@
 
135
 
 
136
   linux*)
 
137
     if $LD --help 2>&1 | grep ': supported targets:.* elf' > /dev/null; then
 
138
-        tmp_archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
 
139
+        tmp_archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname $version_script_arg -o $lib'
 
140
        archive_cmds_F77="$tmp_archive_cmds"
 
141
       supports_anon_versioning=no
 
142
       case `$LD -v 2>/dev/null` in
 
143
@@ -15510,6 +15522,9 @@
 
144
     sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
 
145
   fi
 
146
 
 
147
+  # argument to support GNU version scripts
 
148
+  version_script_arg='${wl}--version-script=\${libname}.ver'
 
149
+
 
150
   # We used to test for /lib/ld.so.1 and disable shared libraries on
 
151
   # powerpc, because MkLinux only supported shared libraries with the
 
152
   # GNU dynamic linker.  Since this was broken with cross compilers,
 
153
@@ -15776,7 +15791,7 @@
 
154
     lt_cv_sys_global_symbol_pipe lt_cv_sys_global_symbol_to_cdecl \
 
155
     lt_cv_sys_global_symbol_to_c_name_address \
 
156
     sys_lib_search_path_spec sys_lib_dlsearch_path_spec \
 
157
-    old_postinstall_cmds old_postuninstall_cmds \
 
158
+    old_postinstall_cmds old_postuninstall_cmds version_script_arg \
 
159
     compiler_F77 \
 
160
     CC_F77 \
 
161
     LD_F77 \
 
162
@@ -15926,6 +15941,9 @@
 
163
 # Object file suffix (normally "o").
 
164
 objext="$ac_objext"
 
165
 
 
166
+# Linker argument to specify a version script (if supported)
 
167
+version_script_arg="$version_script_arg"
 
168
+
 
169
 # Old archive suffix (normally "a").
 
170
 libext="$libext"
 
171
 
 
172
@@ -16738,7 +16756,7 @@
 
173
 
 
174
   linux*)
 
175
     if $LD --help 2>&1 | grep ': supported targets:.* elf' > /dev/null; then
 
176
-        tmp_archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname -o $lib'
 
177
+        tmp_archive_cmds='$CC -shared $libobjs $deplibs $compiler_flags ${wl}-soname $wl$soname $version_script_arg -o $lib'
 
178
        archive_cmds_GCJ="$tmp_archive_cmds"
 
179
       supports_anon_versioning=no
 
180
       case `$LD -v 2>/dev/null` in
 
181
@@ -17856,6 +17874,9 @@
 
182
     sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
 
183
   fi
 
184
 
 
185
+  # argument to support GNU version scripts
 
186
+  version_script_arg='${wl}--version-script=\${libname}.ver'
 
187
+
 
188
   # We used to test for /lib/ld.so.1 and disable shared libraries on
 
189
   # powerpc, because MkLinux only supported shared libraries with the
 
190
   # GNU dynamic linker.  Since this was broken with cross compilers,
 
191
@@ -18920,7 +18941,7 @@
 
192
     lt_cv_sys_global_symbol_pipe lt_cv_sys_global_symbol_to_cdecl \
 
193
     lt_cv_sys_global_symbol_to_c_name_address \
 
194
     sys_lib_search_path_spec sys_lib_dlsearch_path_spec \
 
195
-    old_postinstall_cmds old_postuninstall_cmds \
 
196
+    old_postinstall_cmds old_postuninstall_cmds version_script_arg \
 
197
     compiler_GCJ \
 
198
     CC_GCJ \
 
199
     LD_GCJ \
 
200
@@ -19070,6 +19091,9 @@
 
201
 # Object file suffix (normally "o").
 
202
 objext="$ac_objext"
 
203
 
 
204
+# Linker argument to specify a version script (if supported)
 
205
+version_script_arg="$version_script_arg"
 
206
+
 
207
 # Old archive suffix (normally "a").
 
208
 libext="$libext"
 
209
 
 
210
@@ -19365,7 +19389,7 @@
 
211
     lt_cv_sys_global_symbol_pipe lt_cv_sys_global_symbol_to_cdecl \
 
212
     lt_cv_sys_global_symbol_to_c_name_address \
 
213
     sys_lib_search_path_spec sys_lib_dlsearch_path_spec \
 
214
-    old_postinstall_cmds old_postuninstall_cmds \
 
215
+    old_postinstall_cmds old_postuninstall_cmds version_script_arg \
 
216
     compiler_RC \
 
217
     CC_RC \
 
218
     LD_RC \
 
219
@@ -19515,6 +19539,9 @@
 
220
 # Object file suffix (normally "o").
 
221
 objext="$ac_objext"
 
222
 
 
223
+# Linker argument to specify a version script (if supported)
 
224
+version_script_arg="$version_script_arg"
 
225
+
 
226
 # Old archive suffix (normally "a").
 
227
 libext="$libext"
 
228
 
 
229
diff -ruN heimdal-0.6.2-old/lib/krb5/Makefile.am heimdal-0.6.2/lib/krb5/Makefile.am
 
230
--- heimdal-0.6.2-old/lib/krb5/Makefile.am      2004-05-11 10:11:32.000000000 +1000
 
231
+++ heimdal-0.6.2/lib/krb5/Makefile.am  2004-05-11 10:11:39.000000000 +1000
 
232
@@ -132,7 +132,7 @@
 
233
        write_message.c                         \
 
234
        $(ERR_FILES)
 
235
 
 
236
-libkrb5_la_LDFLAGS = -version-info 20:0:3
 
237
+libkrb5_la_LDFLAGS = -version-info 20:0:3 -symbol-version KRB5_17_HEIMDAL
 
238
 
 
239
 $(libkrb5_la_OBJECTS): $(srcdir)/krb5-protos.h $(srcdir)/krb5-private.h
 
240
 
 
241
diff -ruN heimdal-0.6.2-old/lib/krb5/Makefile.in heimdal-0.6.2/lib/krb5/Makefile.in
 
242
--- heimdal-0.6.2-old/lib/krb5/Makefile.in      2004-05-11 10:11:34.000000000 +1000
 
243
+++ heimdal-0.6.2/lib/krb5/Makefile.in  2004-05-11 10:11:39.000000000 +1000
 
244
@@ -443,7 +443,7 @@
 
245
        $(ERR_FILES)
 
246
 
 
247
 
 
248
-libkrb5_la_LDFLAGS = -version-info 20:0:3
 
249
+libkrb5_la_LDFLAGS = -version-info 20:0:3 -symbol-version KRB5_17_HEIMDAL
 
250
 
 
251
 
 
252
 #libkrb5_la_LIBADD = ../com_err/error.lo ../com_err/com_err.lo
 
253
diff -ruN heimdal-0.6.2-old/ltmain.sh heimdal-0.6.2/ltmain.sh
 
254
--- heimdal-0.6.2-old/ltmain.sh 2004-05-11 10:11:36.000000000 +1000
 
255
+++ heimdal-0.6.2/ltmain.sh     2004-05-11 10:11:39.000000000 +1000
 
256
@@ -947,6 +947,7 @@
 
257
     thread_safe=no
 
258
     vinfo=
 
259
     vinfo_number=no
 
260
+    symbolversion=
 
261
 
 
262
     func_infer_tag $base_compile
 
263
 
 
264
@@ -1496,6 +1497,11 @@
 
265
        continue
 
266
        ;;
 
267
 
 
268
+      -symbol-version)
 
269
+       prev=symbolversion
 
270
+       continue
 
271
+       ;;
 
272
+       
 
273
       -Wc,*)
 
274
        args=`$echo "X$arg" | $Xsed -e "$sed_quote_subst" -e 's/^-Wc,//'`
 
275
        arg=
 
276
@@ -3750,6 +3756,13 @@
 
277
          $run eval '(cd $output_objdir && $rm ${realname}U && $mv $realname ${realname}U)' || exit $?
 
278
        fi
 
279
 
 
280
+       # Eval so we get the libname.
 
281
+       if test -n "$symbolversion"; then
 
282
+               eval version_script_arg=\"$version_script_arg\"
 
283
+       else
 
284
+               version_script_arg=
 
285
+       fi
 
286
+
 
287
        # Do each of the archive commands.
 
288
        if test "$module" = yes && test -n "$module_cmds" ; then
 
289
          if test -n "$export_symbols" && test -n "$module_expsym_cmds"; then
 
290
@@ -3768,6 +3781,21 @@
 
291
          cmds=$archive_cmds
 
292
          fi
 
293
        fi
 
294
+       if test -n "$symbolversion"; then
 
295
+         cat > ${libname}.ver <<EOF
 
296
+HIDDEN {
 
297
+       local:
 
298
+               __*;
 
299
+               _rest*;
 
300
+               _save*;
 
301
+};
 
302
+
 
303
+$symbolversion {
 
304
+       global:
 
305
+               *;
 
306
+};
 
307
+EOF
 
308
+       fi
 
309
 
 
310
        if test "X$skipped_export" != "X:" && len=`expr "X$test_cmds" : ".*"` &&
 
311
           test "$len" -le "$max_cmd_len" || test "$max_cmd_len" -le -1; then