~ubuntu-branches/ubuntu/intrepid/ecasound2.2/intrepid

« back to all changes in this revision

Viewing changes to debian/patches/01_ecasoundrc-location-fix.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Junichi Uekawa
  • Date: 2005-04-14 09:15:48 UTC
  • Revision ID: james.westby@ubuntu.com-20050414091548-vwu2de2157xq1hcm
Tags: 2.4.1-1
* New upstream version
- 01_ecasoundrc-location-fix: included in upstream
- 07_configure_in_maintainer_mode: updated
* removed refererence to artsc-dev
* [debian/control, debian/rules] Use automake1.9
* documentation is now in rst
- add Build-Depends: python-docutils
* debian/menu: quote
* debian/watch: add

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
## 01_ecasoundrc-location-fix.dpatch by Junichi Uekawa <dancer@debian.org>
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: Change path for /usr/share/ecasound/ecasound2.2
 
6
## @DPATCH@                                                                                                                 
 
7
if [ $# -ne 1 ]; then
 
8
    echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
 
9
    exit 1
 
10
fi
 
11
case "$1" in
 
12
    -patch) patch -f --no-backup-if-mismatch -p1 < $0;;
 
13
    -unpatch) patch -f --no-backup-if-mismatch -R -p1 < $0;;
 
14
    *)
 
15
        echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
 
16
        exit 1;;
 
17
esac
 
18
                                                                                                                 
 
19
exit 0
 
20
                                                                                                                 
 
21
diff -ur ecasound2.2-2.3.5/libecasound.orig/Makefile.am ecasound2.2-2.3.5/libecasound/Makefile.am
 
22
--- ecasound2.2-2.3.5/libecasound.orig/Makefile.am      2004-11-13 11:03:21.000000000 +0900
 
23
+++ ecasound2.2-2.3.5/libecasound/Makefile.am   2004-11-13 11:32:12.000000000 +0900
 
24
@@ -49,6 +49,9 @@
 
25
                -I$(top_srcdir)/kvutils \
 
26
                $(ECA_S_EXTRA_CPPFLAGS)
 
27
 
 
28
+# Add this to CPPFLAGS
 
29
+CPPFLAGS += "-DPKGDATADIR=\"${pkgdatadir}\""
 
30
+
 
31
 # ----------------------------------------------------------------------
 
32
 # header files
 
33
 # ----------------------------------------------------------------------
 
34
diff -ur ecasound2.2-2.3.5/libecasound.orig/eca-resources.cpp ecasound2.2-2.3.5/libecasound/eca-resources.cpp
 
35
--- ecasound2.2-2.3.5/libecasound.orig/eca-resources.cpp        2004-11-13 11:03:21.000000000 +0900
 
36
+++ ecasound2.2-2.3.5/libecasound/eca-resources.cpp     2004-11-13 11:13:46.000000000 +0900
 
37
@@ -36,8 +36,7 @@
 
38
 ECA_RESOURCES::ECA_RESOURCES(void)
 
39
   : resources_found_rep(true)
 
40
 {
 
41
-  string ecasound_prefix (ECA_PREFIX);
 
42
-  string ecasound_resource_path = ecasound_prefix + "/share/ecasound";
 
43
+  string ecasound_resource_path (PKGDATADIR);
 
44
 
 
45
   globalrc_repp = new RESOURCE_FILE();
 
46
   globalrc_repp->resource_file(ecasound_resource_path + "/ecasoundrc");
 
47
--- ecasound2.2-2.3.5/ecasoundrc.in~    2004-11-13 11:01:49.000000000 +0900
 
48
+++ ecasound2.2-2.3.5/ecasoundrc.in     2004-11-17 08:09:23.000000000 +0900
 
49
@@ -7,7 +7,7 @@
 
50
 bmode-defaults-nonrt = 1024,false,50,false,100000,true
 
51
 bmode-defaults-rt = 1024,true,50,true,100000,true
 
52
 bmode-defaults-rtlowlatency = 256,true,50,true,100000,false
 
53
-resource-directory = @prefix@/share/ecasound
 
54
+resource-directory = @prefix@/share/ecasound2.2/ecasound
 
55
 resource-file-genosc-envelopes = generic_oscillators
 
56
 resource-file-effect-presets = effect_presets
 
57
 ladspa-plugin-directory = @prefix@/lib/ladspa