~ubuntu-branches/ubuntu/intrepid/ecasound2.2/intrepid

« back to all changes in this revision

Viewing changes to debian/patches/07_configure_in_maintainer_mode.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Junichi Uekawa
  • Date: 2005-04-14 09:15:48 UTC
  • Revision ID: james.westby@ubuntu.com-20050414091548-vwu2de2157xq1hcm
Tags: 2.4.1-1
* New upstream version
- 01_ecasoundrc-location-fix: included in upstream
- 07_configure_in_maintainer_mode: updated
* removed refererence to artsc-dev
* [debian/control, debian/rules] Use automake1.9
* documentation is now in rst
- add Build-Depends: python-docutils
* debian/menu: quote
* debian/watch: add

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#! /bin/sh -e
 
2
## 07_configure_in_maintainer_mode.dpatch
 
3
##
 
4
## All lines beginning with `## DP:' are a description of the patch.
 
5
## DP: AM_MAINTAINER_MODE
 
6
## DP: This is required to get things working with make clean and unpatch.
 
7
## @DPATCH@                                                                                                                 
 
8
if [ $# -ne 1 ]; then
 
9
    echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
 
10
    exit 1
 
11
fi
 
12
case "$1" in
 
13
    -patch) patch -f --no-backup-if-mismatch -p1 < $0;;
 
14
    -unpatch) patch -f --no-backup-if-mismatch -R -p1 < $0;;
 
15
    *)
 
16
        echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
 
17
        exit 1;;
 
18
esac
 
19
                                                                                                                 
 
20
exit 0
 
21
 
 
22
--- ecasound2.2-2.4.1/configure.in~     2005-04-08 06:22:56.000000000 +0900
 
23
+++ ecasound2.2-2.4.1/configure.in      2005-04-12 21:47:12.000000000 +0900
 
24
@@ -19,6 +19,7 @@
 
25
 
 
26
 dnl FIXME: replace with AC_CONFIG_HEADERS when upgrading to a newer automake
 
27
 AM_CONFIG_HEADER([config.h]) 
 
28
+AM_MAINTAINER_MODE
 
29
 
 
30
 dnl ------------------------------------------------------------------
 
31