~ubuntu-branches/ubuntu/intrepid/logrotate/intrepid

« back to all changes in this revision

Viewing changes to debian/patches/52-man-sizetypo.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Paul Martin
  • Date: 2006-04-08 23:02:19 UTC
  • mfrom: (3.1.1 dapper)
  • Revision ID: james.westby@ubuntu.com-20060408230219-7moi9qw2g42w1nye
Tags: 3.7.1-3
* Patch debian/control to fix FTBFS on kfreebsd-amd64. Perhaps we need
  a build-depends macro for !kfreebsd. (Closes: #361465)
* Use and depend on debhelper version 5.
* Switch from dpatch to quilt.
* cpp-crossbuild.patch: change from using $(CPP) to $(CC) -E.
  Thanks to NIIBE Yutaka. (Closes: #284040)
* dst.patch: fix mktime initialisation so that daylight savings is
  taken into account. Thanks to Holger Weiss. (Closes: #278591)
* man-333996.patch: fix typos in logrotate.8 where "then" should be
  "than". Thanks to Adrian Knoth. (Closes: #333996)
* manpage.patch: Apply missed fixes from #101272. Thanks to J S Bygott.
  (Closes: #335060)
* script-argument.patch: Allow the use of $1 in scripts again.
  (Closes: #330783)
* README.Debian: Document that sysklogd does its own log rotation.
  (Closes: #308963)
* README.Debian: Document how scripts are called. (Closes: #308920)
* Update the copyright file.
* debian/control: remove versioned dependency on cron. The version of
  cron forbidden pre-dates woody (currently "oldstable") by several
  years. This versioned dependency is preventing logrotate being
  installed with bcron. (Closes: #304038, #349150)
* debian/rules: Fix backports, allowing them to use selinux.
  (Closes: #340363)
* uncompressChild-warning.patch: Fix a "might be used uninitialised" 
  warning from gcc.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#! /bin/sh -e
2
 
## 52-man-sizetypo.dpatch by Paul Martin <pm@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description.
6
 
 
7
 
if [ $# -lt 1 ]; then
8
 
    echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
9
 
    exit 1
10
 
fi
11
 
 
12
 
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
13
 
patch_opts="${patch_opts:--f --no-backup-if-mismatch} ${2:+-d $2}"
14
 
 
15
 
case "$1" in
16
 
    -patch) patch -p1 ${patch_opts} < $0;;
17
 
    -unpatch) patch -R -p1 ${patch_opts} < $0;;
18
 
    *)
19
 
        echo "`basename $0`: script expects -patch|-unpatch as argument" >&2
20
 
        exit 1;;
21
 
esac
22
 
 
23
 
exit 0
24
 
 
25
 
@DPATCH@
26
 
diff -urNad /home/pm/deb/logrotate/logrotate-3.7/logrotate.8 logrotate-3.7/logrotate.8
27
 
--- /home/pm/deb/logrotate/logrotate-3.7/logrotate.8    2004-09-13 22:50:08.000000000 +0100
28
 
+++ logrotate-3.7/logrotate.8   2004-09-13 22:50:25.000000000 +0100
29
 
@@ -90,7 +90,7 @@
30
 
 "/var/log/httpd/access.log" /var/log/httpd/error.log {
31
 
     rotate 5
32
 
     mail www@my.org
33
 
-    size=100k
34
 
+    size 100k
35
 
     sharedscripts
36
 
     postrotate
37
 
         /usr/bin/killall -HUP httpd