~ubuntu-branches/ubuntu/intrepid/logrotate/intrepid

« back to all changes in this revision

Viewing changes to debian/patches/configparse.patch

  • Committer: Bazaar Package Importer
  • Author(s): Paul Martin
  • Date: 2006-04-08 23:02:19 UTC
  • mfrom: (3.1.1 dapper)
  • Revision ID: james.westby@ubuntu.com-20060408230219-7moi9qw2g42w1nye
Tags: 3.7.1-3
* Patch debian/control to fix FTBFS on kfreebsd-amd64. Perhaps we need
  a build-depends macro for !kfreebsd. (Closes: #361465)
* Use and depend on debhelper version 5.
* Switch from dpatch to quilt.
* cpp-crossbuild.patch: change from using $(CPP) to $(CC) -E.
  Thanks to NIIBE Yutaka. (Closes: #284040)
* dst.patch: fix mktime initialisation so that daylight savings is
  taken into account. Thanks to Holger Weiss. (Closes: #278591)
* man-333996.patch: fix typos in logrotate.8 where "then" should be
  "than". Thanks to Adrian Knoth. (Closes: #333996)
* manpage.patch: Apply missed fixes from #101272. Thanks to J S Bygott.
  (Closes: #335060)
* script-argument.patch: Allow the use of $1 in scripts again.
  (Closes: #330783)
* README.Debian: Document that sysklogd does its own log rotation.
  (Closes: #308963)
* README.Debian: Document how scripts are called. (Closes: #308920)
* Update the copyright file.
* debian/control: remove versioned dependency on cron. The version of
  cron forbidden pre-dates woody (currently "oldstable") by several
  years. This versioned dependency is preventing logrotate being
  installed with bcron. (Closes: #304038, #349150)
* debian/rules: Fix backports, allowing them to use selinux.
  (Closes: #340363)
* uncompressChild-warning.patch: Fix a "might be used uninitialised" 
  warning from gcc.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
# Loosens the config syntax checking to allow more flexibility.
 
2
#  (Closes: #95617,#95630)
 
3
 
 
4
Index: logrotate-3.7.1/config.c
 
5
===================================================================
 
6
--- logrotate-3.7.1.orig/config.c       2006-04-08 20:46:40.250457779 +0100
 
7
+++ logrotate-3.7.1/config.c    2006-04-08 20:48:15.188228344 +0100
 
8
@@ -768,7 +768,7 @@
 
9
 
 
10
                    while (*start) {
 
11
                        chptr = start;
 
12
-                       while (!isspace(*chptr) && *chptr != ',' && *chptr)
 
13
+                       while (!isspace(*chptr) && /* *chptr != ',' && */ *chptr)
 
14
                            chptr++;
 
15
 
 
16
                        tabooExts = realloc(tabooExts, sizeof(*tabooExts) * 
 
17
@@ -780,7 +780,7 @@
 
18
                        tabooCount++;
 
19
 
 
20
                        start = chptr;
 
21
-                       if (*start == ',') start++;
 
22
+                       /* if (*start == ',') start++; */
 
23
                        while (isspace(*start) && *start) start++;
 
24
                    }
 
25