~ubuntu-branches/ubuntu/jaunty/compiz/jaunty-updates

« back to all changes in this revision

Viewing changes to debian/patches/0001-Make-sure-that-unredirected-fullscreen-windows-are-f.patch

  • Committer: Bazaar Package Importer
  • Author(s): Michael Vogt, Michael Vogt, Christopher James Halse Rogers
  • Date: 2008-12-17 21:19:13 UTC
  • Revision ID: james.westby@ubuntu.com-20081217211913-h1ur6u0qx8yydu2x
Tags: 1:0.7.8-0ubuntu5
[ Michael Vogt ]
* patch cleanup with compiz upstream, removed:
  - 0001-Make-sure-that-unredirected-fullscreen-windows-are-f.patch
  - 0003-Move-input-focus-back-to-the-active-window-after-red.pat
  - 015-disable-glib-plugin.patch
  - 019_fix_wnck_2.19.4.patch
  - 022_fix_session_managment.patch 
  - 024_add_config_notify.patch
  - 031_add_compiz_common.patch
  - 038_from_git_fix_incomplete_rotate.patch
  - 043-blur-plugin-fix-from-git.patch
  - 043-new-gnome-session.patch
* removed no longer applied patches from the repo too
* debian/rules
  - fix build failure with latest control center
* debian/control:
  - add missing libgnomeui-dev build-depends
* rebuild against latest libgnome-desktop-dev

[ Christopher James Halse Rogers ]
* debian/patches/050-scale-keybinding-toggle.patch
  - Allow setting the scale initiate keybinding as a toggle (LP: #281911).
    Patch from upstream git.
* debian/patches/051-new-kde4-plasma-api.patch
  - PanelSvg has been renamed to FrameSvg in KDE 4.2.  Upstream bug is
    https://bugs.freedesktop.org/show_bug.cgi?id=18637

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
From aa590d37c6dcc268389ef5b02e35dda253473002 Mon Sep 17 00:00:00 2001
2
 
From: Dennis Kasprzyk <onestone@opencompositing.org>
3
 
Date: Wed, 19 Sep 2007 10:44:33 +0200
4
 
Subject: [PATCH] Make sure that unredirected fullscreen windows are focussed.
5
 
 
6
 
---
7
 
 src/window.c |    2 ++
8
 
 1 files changed, 2 insertions(+), 0 deletions(-)
9
 
 
10
 
Index: compiz-0.6.99+git20071106/src/window.c
11
 
===================================================================
12
 
--- compiz-0.6.99+git20071106.orig/src/window.c 2007-11-04 09:00:14.000000000 -0600
13
 
+++ compiz-0.6.99+git20071106/src/window.c      2007-11-06 11:08:30.000000000 -0600
14
 
@@ -4736,6 +4736,8 @@
15
 
     w->redirected = FALSE;
16
 
     w->screen->overlayWindowCount++;
17
 
 
18
 
+    moveInputFocusToWindow (w);
19
 
+
20
 
     if (w->screen->overlayWindowCount > 0)
21
 
        hideOutputWindow (w->screen);
22
 
 }