~ubuntu-branches/ubuntu/jaunty/compiz/jaunty-updates

« back to all changes in this revision

Viewing changes to debian/patches/045_xscreensaver_damage_fix.patch

  • Committer: Bazaar Package Importer
  • Author(s): Michael Vogt, Michael Vogt, Christopher James Halse Rogers
  • Date: 2008-12-17 21:19:13 UTC
  • Revision ID: james.westby@ubuntu.com-20081217211913-h1ur6u0qx8yydu2x
Tags: 1:0.7.8-0ubuntu5
[ Michael Vogt ]
* patch cleanup with compiz upstream, removed:
  - 0001-Make-sure-that-unredirected-fullscreen-windows-are-f.patch
  - 0003-Move-input-focus-back-to-the-active-window-after-red.pat
  - 015-disable-glib-plugin.patch
  - 019_fix_wnck_2.19.4.patch
  - 022_fix_session_managment.patch 
  - 024_add_config_notify.patch
  - 031_add_compiz_common.patch
  - 038_from_git_fix_incomplete_rotate.patch
  - 043-blur-plugin-fix-from-git.patch
  - 043-new-gnome-session.patch
* removed no longer applied patches from the repo too
* debian/rules
  - fix build failure with latest control center
* debian/control:
  - add missing libgnomeui-dev build-depends
* rebuild against latest libgnome-desktop-dev

[ Christopher James Halse Rogers ]
* debian/patches/050-scale-keybinding-toggle.patch
  - Allow setting the scale initiate keybinding as a toggle (LP: #281911).
    Patch from upstream git.
* debian/patches/051-new-kde4-plasma-api.patch
  - PanelSvg has been renamed to FrameSvg in KDE 4.2.  Upstream bug is
    https://bugs.freedesktop.org/show_bug.cgi?id=18637

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff --git a/src/screen.c b/src/screen.c
2
 
index 15d1fd0..d4d6402 100644
3
 
--- a/src/screen.c
4
 
+++ b/src/screen.c
5
 
@@ -2429,6 +2429,13 @@ damageScreenRegion (CompScreen *screen,
6
 
 
7
 
     XUnionRegion (screen->damage, region, screen->damage);
8
 
 
9
 
+    if (screen->damage->numRects > 50) {
10
 
+       XDestroyRegion (screen->damage);
11
 
+       screen->damage = XCreateRegion ();
12
 
+       XUnionRectWithRegion(&screen->damage->extents, 
13
 
+                           screen->damage, screen->damage);
14
 
+    }
15
 
+
16
 
     screen->damageMask |= COMP_SCREEN_DAMAGE_REGION_MASK;
17
 
 }
18