~ubuntu-branches/ubuntu/jaunty/gnomeradio/jaunty

« back to all changes in this revision

Viewing changes to debian/patches/prefs.c.patch

  • Committer: Bazaar Package Importer
  • Author(s): Francesco Namuri
  • Date: 2008-11-12 19:10:25 UTC
  • mfrom: (1.1.2 upstream)
  • Revision ID: james.westby@ubuntu.com-20081112191025-163hvqs5bggpepee
Tags: 1.8-1
* New upstream release.
* debian/patches/: removed useless GLib_threading, trayicon.c,
  fix_missing_description_in_gnomeradio.xml, prefs.c patches; now they
  are implemented by the author.
* debian/control: Standards-Version updated to 3.8.0, no changes needed.

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
diff -Nur gnomeradio-1.7/src/prefs.c gnomeradio-1.7.new/src/prefs.c
2
 
--- gnomeradio-1.7/src/prefs.c  2006-11-25 12:33:57.000000000 +0100
3
 
+++ gnomeradio-1.7.new/src/prefs.c      2008-02-05 23:11:32.000000000 +0100
4
 
@@ -411,7 +411,8 @@
5
 
 
6
 
        gtk_combo_box_remove_text(GTK_COMBO_BOX(preset_combo), *row + 1);
7
 
        gtk_combo_box_insert_text(GTK_COMBO_BOX(preset_combo), *row + 1, ps->title);
8
 
-       preset_combo_set_item(mom_ps);
9
 
+        mom_ps = *row;
10
 
+        preset_combo_set_item(mom_ps);
11
 
        
12
 
        menuitems = GTK_MENU_SHELL(tray_menu)->children;
13
 
        g_assert(mom_ps < g_list_length(menuitems));