~ubuntu-branches/ubuntu/jaunty/xarchiver/jaunty

« back to all changes in this revision

Viewing changes to debian/patches/02-icon-path.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Lionel Le Folgoc
  • Date: 2007-10-27 14:25:52 UTC
  • Revision ID: james.westby@ubuntu.com-20071027142552-rjwgivl952cfn8k3
Tags: 0.4.6-5ubuntu1
* Merge from debian unstable, remaining changes:
  - keep the .tap file where it's supposed to be
* debian/control:
  - override Maintainer to MOTU since this package is now in universe
  - use the Homepage: field.

Show diffs side-by-side

added added

removed removed

Lines of Context:
 
1
#!/bin/sh /usr/share/dpatch/dpatch-run
 
2
## 02-icon-path.dpatch by Daniel Baumann <daniel@debian.org>
 
3
##
 
4
## DP: Corrects path of icons (Closes: #409502).
 
5
 
 
6
@DPATCH@
 
7
 
 
8
diff -Naur xarchiver-0.4.6.orig/src/support.c xarchiver-0.4.6/src/support.c
 
9
--- xarchiver-0.4.6.orig/src/support.c  2006-11-27 07:26:29.000000000 +0000
 
10
+++ xarchiver-0.4.6/src/support.c       2007-08-15 14:02:40.000000000 +0000
 
11
@@ -31,7 +31,7 @@
 
12
     GtkWidget *file_image;
 
13
        gchar *path;
 
14
        GdkPixbuf *file_pixbuf = NULL;
 
15
-       path = g_strconcat(DATADIR, "/pixmaps/xarchiver/", NULL);
 
16
+       path = g_strconcat(DATADIR, "/icons/", NULL);
 
17
        path = g_strconcat(path, filename, NULL);
 
18
        file_pixbuf = gdk_pixbuf_new_from_file (path, &error);
 
19
        g_free (path);