~ubuntu-branches/ubuntu/karmic/centerim/karmic

« back to all changes in this revision

Viewing changes to debian/patches/disable_ncursesw.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Alessio Treglia
  • Date: 2009-03-26 19:51:53 UTC
  • mfrom: (1.1.5 upstream) (3.1.2 squeeze)
  • Revision ID: james.westby@ubuntu.com-20090326195153-dxo63t1lwbp2m592
Tags: 4.22.7-1ubuntu1
* Merge from debian unstable, Ubuntu remaining changes:
  - Packages that Depend/Recommend/Suggest firefox (metapackage) must
    must alternatively Depend/Recommend/Suggest abrowser.
* Bugfix-only release, fixed bugs: LP: #146308 and LP: #186381.

Show diffs side-by-side

added added

removed removed

Lines of Context:
20
20
esac
21
21
 
22
22
exit 0
23
 
diff -bBdNrw -U5 centerim-4.22.1-101-g6a27/configure.ac centerim-4.22.1-101-g6a27.modif/configure.ac
24
 
--- centerim-4.22.1-101-g6a27/configure.ac      2007-12-04 16:21:35.000000000 -0600
25
 
+++ centerim-4.22.1-101-g6a27.modif/configure.ac        2007-12-05 01:00:43.860047674 -0600
26
 
@@ -79,10 +79,15 @@
27
 
               AS_HELP_STRING([--enable-locales-fix], [enables workaround for
28
 
                               broken locales. use this option if some of
29
 
                               characters in your texts in Chinese or Japanese
30
 
                               diappear])
 
23
diff -bBdNrw -U5 centerim-4.22.7/configure.ac centerim-4.22.7.modif/configure.ac
 
24
--- centerim-4.22.7/configure.ac        2007-12-04 16:21:35.000000000 -0600
 
25
+++ centerim-4.22.7.modif/configure.ac  2007-12-05 01:00:43.860047674 -0600
 
26
@@ -79,10 +79,16 @@
 
27
                               disappear]),
 
28
               locales_fix="$enableval",
 
29
               locales_fix="yes"
31
30
               )
 
31
 
32
32
+AC_ARG_ENABLE(ncursesw,
33
33
+              AS_HELP_STRING([--disable-ncursesw], [disable link with ncursesw]),
34
 
+             link_ncursesw="$enableval",
35
 
+             link_ncursesw="yes"
36
 
+            )
37
 
 
 
34
+             link_ncursesw="$enableval",
 
35
+             link_ncursesw="yes"
 
36
+            )
 
37
+
38
38
 AC_ARG_WITH(fribidi,
39
39
             AS_HELP_STRING([--with-fribidi=[DIR]], [enable Hebrew and Arabic
40
40
                             support using fribidi library in DIR]),
41
41
             [with_fribidi=$withval],
42
 
@@ -272,13 +277,19 @@
43
 
 AM_ICONV_LINK
44
 
 LIBS="$LIBS $LIBICONV"
 
42
             [with_fribidi=no]
 
43
@@ -351,20 +357,25 @@
 
44
 AC_CHECK_SIZEOF([short])
45
45
 
46
46
 AC_CHECK_LIB(socket, socket)
47
47
 AC_CHECK_LIB(nsl, gethostbyname)
48
 
+
 
48
 
49
49
+if test "x$link_ncursesw" = "xyes"; then
50
 
 AC_CHECK_LIB(ncursesw, get_wch,, [AC_CHECK_LIB(ncurses, initscr,,
 
50
 AC_CHECK_LIB(ncursesw, get_wch, [AC_DEFINE(HAVE_NCURSESW, 1, [check widechar ncurses])
 
51
 LIBS="$LIBS -lncursesw"
 
52
                 AC_CHECK_HEADERS(ncursesw/cursesw.h,[])
 
53
                 AC_CHECK_HEADERS(ncursesw/curses.h, [])
 
54
 ], [
 
55
 AC_CHECK_LIB(ncurses, initscr,,
51
56
                                   [AC_CHECK_LIB(curses, initscr,,
52
 
                                    AC_MSG_ERROR(The ncurses terminal library is required in order to build the program))])])
 
57
                                    AC_MSG_ERROR(The ncurses terminal library is required in order to build the program))])
 
58
 ]
 
59
 )
53
60
+else
54
 
+AC_CHECK_LIB(ncurses, initscr,, 
55
 
+       [AC_CHECK_LIB(curses, initscr,, AC_MSG_ERROR(The ncurses terminal library is required in order to build the program))])
 
61
+AC_CHECK_LIB(ncurses, initscr,,
 
62
+       [AC_CHECK_LIB(curses, initscr,, AC_MSG_ERROR(The ncurses terminal library is required in order to build the program))])
56
63
+fi
57
64
 
58
65
 AC_TRY_COMPILE([
59
66
     #include <sys/types.h>
60
67
     #include <sys/socket.h>
61
68
 ],[ socklen_t foo; ], ac_cv_c_socklen_t=yes, ac_cv_c_socklen_t=no)
 
69