~ubuntu-branches/ubuntu/karmic/pilot-link/karmic

« back to all changes in this revision

Viewing changes to debian/patches/05_libpisock++_Makefile.in.dpatch

  • Committer: Bazaar Package Importer
  • Author(s): Ludovic Rousseau
  • Date: 2006-09-22 11:51:36 UTC
  • mfrom: (3.1.8 edgy)
  • Revision ID: james.westby@ubuntu.com-20060922115136-qqmy17bx8j5x0y72
Tags: 0.12.1-5
* urgency medium since libpisock-dev was not usable to build any package
* libpisock-dev now depends on libusb-dev

Show diffs side-by-side

added added

removed removed

Lines of Context:
1
 
#!/bin/sh -e
2
 
## patch by Ludovic Rousseau <rousseau@debian.org>
3
 
##
4
 
## All lines beginning with `## DP:' are a description of the patch.
5
 
## DP: No description
6
 
 
7
 
if [ $# -ne 1 ]; then
8
 
    echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
9
 
    exit 1
10
 
fi
11
 
 
12
 
[ -f debian/patches/00patch-opts ] && . debian/patches/00patch-opts
13
 
patch_opts="${patch_opts:--f --no-backup-if-mismatch}"
14
 
 
15
 
case "$1" in
16
 
       -patch) patch $patch_opts -p1 < $0;;
17
 
       -unpatch) patch $patch_opts -p1 -R < $0;;
18
 
        *)
19
 
                echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
20
 
                exit 1;;
21
 
esac
22
 
 
23
 
exit 0
24
 
 
25
 
@DPATCH@
26
 
--- pilot-link-0.11.8.orig/libpisock++/Makefile.in
27
 
+++ pilot-link-0.11.8/libpisock++/Makefile.in
28
 
@@ -128,7 +128,7 @@
29
 
 libpisock___la_LIBADD =        $(top_builddir)/libpisock/libpisock.la
30
 
 
31
 
 
32
 
-libpisock___la_LDFLAGS =       -export-dynamic -version-info $(PISOCKPP_CURRENT):$(PISOCKPP_REVISION):$(PISOCKPP_AGE)
33
 
+libpisock___la_LDFLAGS =       -export-dynamic -version-info $(PISOCKPP_CURRENT):$(PISOCKPP_REVISION):$(PISOCKPP_AGE) -lstdc++
34
 
 
35
 
 mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
36
 
 CONFIG_HEADER = ../config.h